How do you take a local drive out of mulitpath in Linux?

I have a new system I just built that has somehow added a local drive /dev/sdb1 into multipath:

[root@server /]# multipath -ll
multipath.conf line 114, invalid keyword: polling_interval
multipath.conf line 126, invalid keyword: polling_interval
multipath.conf line 140, invalid keyword: polling_interval
multipath.conf line 141, invalid keyword: selector
multipath.conf line 145, invalid keyword: max_fds
mpath0 (36782bcb0624a720016aa6bcd12321c25) dm-5 DELL,PERC 6/i
[size=279G][features=0][hwhandler=0][rw]
\_ round-robin 0 [prio=1][active]
 \_ 0:2:1:0 sdb 8:16  [active][ready]

Open in new window


It does not need to be in there and should be treated as a normal local drive. How can I remove it from multipath?
LVL 1
ThaidogAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Pepe2323Commented:
Hi

If you don't have storge like SAN that can have more than 1 path there is no sense you have multipath running

So you can disable it, this is a service running

Also you can black list specific devices into /etc/multipath.conf

blacklist {
      wwid SIBM-ESXSST336732LC____F3ET0EP0Q000072428BX1 -----> this is id of the disk
}

you can get it with this command


# multipath -v2
create: SIBM-ESXSST336732LC____F3ET0EP0Q000072428BX1 undef WINSYS,SF2372 ----->  id listed here
size=33 GB features="0" hwhandler="0" wp=undef
`-+- policy='round-robin 0' prio=1 status=undef
  |- 0:0:0:0 sda 8:0  [---------

you can get more details on this link http://docs.redhat.com/docs/en-US/Red_Hat_Enterprise_Linux/6/html/DM_Multipath/ignore_localdisk_procedure.html

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
ThaidogAuthor Commented:
Well I did a chkconfig multipathd off but the local disk was still getting listed with multipath -ll even with the daemon off... I'm guessing due to the driver being loaded. I blacklisted the sd[a/z] devices in multipath.conf and so far so good. Thanks for your help!
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Linux

From novice to tech pro — start learning today.