Powershell, Scheduled Task, Exchange

Hello Experts,

I have a somewhat bizarre problem which I cant figure out. I have a windows 2008 server r2, which acts as a script runner. In other words it's only purpose is to run scheduled scripts.
Everything and all of the scripts works fine, except one of the scripts. This script bulks out mailbox end user information from exchange 2003 and outputes it to a csv file.

My problem:
When I run the script manually I get all the headers + information out in the csv file
When the script is run from scheduled tasks, it does not output all the information required.

Script code:
$Date = Get-Date
$Date = $Date.ToString("ddMMyyyy")

Get-WmiObject -Class Exchange_Mailbox -NameSpace root\microsoftexchangev2 -ComputerName ExchangeServerName1,ExchangeServerName2 | where {$_.DateDiscoveredAbsentInDS -eq $null} | select @{Label='SamAccountName';Expression={(Get-QADUser -Identity $_.LegacyDN).SamAccountName}}, @{Label='mail';Expression={(Get-QADUser -includedproperties "mail" -Identity $_.LegacyDN).mail}}, ServerName, StorageGroupName, Storename, Size, mailboxdisplayname | Export-Csv C:\Management\MailboxUserInfo\Exchange2003MUI$date.csv -NoTypeInformation

When i run the script manually heres what the output looks like:
SamAccountName,"mail","ServerName","StorageGroupName","Storename","Size","mailboxdisplayname"
Firma,"Firstname.Lastname@domain.se","SMCR090V","First Storage Group","Std2","184319","FullName"
EM0403,"Firstname.Lastname@domain.se","SMCR090V","First Storage Group","Std2","567","FullName"

But when ran from scheduled tasks, the output looks like this:
SamAccountName,"mail","ServerName","StorageGroupName","Storename","Size","mailboxdisplayname"
,,"SMCR090V","First Storage Group","Std2","184319","Fullname"
,,"SMCR090V","First Storage Group","Std2","567","Fullname"


Conclusion:
As you can see when the script is ran from scheduled tasks it will not output the SamAccountName and Mail... Any ideas experts ?

cheer,s

//Juuso
LVL 11
JuusoConnectaAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

AnuroopsunddCommented:
in the Schedule task have you entered the username and password with account that you running manually? it may be the permissions issue.
0
JuusoConnectaAuthor Commented:
Thanks for the input. I've taken that into consideration and the result is the same.
I have scheduled the script to be run with the same user account and password than when I run it manually..
0
prashanthdCommented:
Have you set script to run with highest privileges?
0
Has Powershell sent you back into the Stone Age?

If managing Active Directory using Windows Powershell® is making you feel like you stepped back in time, you are not alone.  For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why.

JuusoConnectaAuthor Commented:
Yes
0
prashanthdCommented:
how did you schedule the script? In a batch file?
0
JuusoConnectaAuthor Commented:
No, its directly a powershell script.

Program script: C:\Windows\System32\WindowsPowerShell\v1.0\powershell.exe

Add argument: C:\Management\Scripts\WorkingScripts\Exchange2003UserInfo.ps1
0
AnuroopsunddCommented:
can you check below post and see if this can be the reason

http://www.jamssupport.com/KnowledgebaseArticle50027.aspx
0
JuusoConnectaAuthor Commented:
Have tried that as well, that isnt the issue. The script is fully functional when running it manually, but not when running thru scheduled tasks, regardless if you use the parameter set-executionpolicy.

I can also add that all other scripts, for example a script that basically does the same thing runs against Exchange 2010 works perfectly, but not the one that goes against exchange 2003..

regards
0
slidingfoxCommented:
Looks like the SAMAccountName and Mail items are pulled using the Quest tools (Get-QADUser). Could you try adding the following to the top of the script and see if it makes a difference?

Note: This is assuming that you've installed the Quest AD CmdLets in the default location.

Add-PSSnapin Quest.ActiveRoles.ADManagement
& 'C:\Program Files\Quest Software\Management Shell for AD\qsft.ps1'

Open in new window

0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Qlemo"Batchelor", Developer and EE Topic AdvisorCommented:
Did you issue exact the same commandline? Get-QADUser is Quest cmdlet not loaded as part of the default modules. Your command for testing it manually should say
C:\Windows\System32\WindowsPowerShell\v1.0\powershell.exe C:\Management\Scripts\WorkingScripts\Exchange2003UserInfo.ps1

Open in new window

, started in e.g. a Cmd window.
0
JuusoConnectaAuthor Commented:
Cheers slidingfox, been working so many scripts lately in the same powershell session (probably havent closed it for 3 weeks), so I did not even notice that the quest modules were already in the session, of course I didnt have the add-pssnapin parameter in the scheduled script...

Thanks for this, it was the last of my 10 scripts =), can now relax with a good conscious. Cheers!
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.