Solved

Cisco ASA 5505 8.4 and configure for SBS 2011 Outlook Web Access

Posted on 2012-04-13
7
1,624 Views
Last Modified: 2012-04-13
Hello,

We have successfully setup a new ASA 5505, 8.4 and got internet, SBS 2011 Exchange e-mail, as well as VPN running; however are having issues with external users being able to use Outlook Web Access successfully (works internally).

Currently the Outlook Web Access and another https web based application is stored on our SBS server, and users on the outside were previously able to access them just by going to; https://www.<outside IP address>/owa.  As of now, no one is able to reach this from the outside anymore and I suspect that the ASA is not allowing https access correctly. Can anyone assist with the ASDM config, so that users can reach the web app/Outlook Web access on our internal SBS server from outside of the network?  Thanks
0
Comment
Question by:bns-nyc
  • 3
  • 3
7 Comments
 
LVL 10

Expert Comment

by:pclinuxguru
Comment Utility
Well you could post a sanitized config so we can see what you have going on.
0
 

Author Comment

by:bns-nyc
Comment Utility
Sorry, forgot to include it in post.  Below:


: Saved
:
ASA Version 8.4(2)
!
hostname asa
enable password cTfsR84pqF5Xohw. encrypted
passwd 2KFQnbNIdI.2KYOU encrypted
names
!
interface Ethernet0/0
 switchport access vlan 2
!
interface Ethernet0/1
!
interface Ethernet0/2
!
interface Ethernet0/3
!
interface Ethernet0/4
!
interface Ethernet0/5
!
interface Ethernet0/6
!
interface Ethernet0/7
!
interface Vlan1
 nameif inside
 security-level 100
 ip address 192.168.2.1 255.255.255.0
!
interface Vlan2
 nameif outside
 security-level 0
 ip address 205.x.x.250 255.255.255.248
!
ftp mode passive
clock timezone EST -5
clock summer-time EDT recurring
dns domain-lookup inside
dns domain-lookup outside
same-security-traffic permit intra-interface
object network obj_any
 subnet 0.0.0.0 0.0.0.0
object network SBS_2011
 host 192.168.2.60
object network NETWORK_OBJ_192.168.2.0_24
 subnet 192.168.2.0 255.255.255.0
object network NETWORK_OBJ_192.168.5.192_27
 subnet 192.168.5.192 255.255.255.224
access-list outside_access_in extended permit tcp any object SBS_2011 eq smtp
access-list outside_access_in extended permit tcp any 192.168.2.0 255.255.255.0 eq https
access-list outside_access_in extended permit icmp any interface outside
access-list Sc_splitTunnelAcl standard permit 192.168.2.0 255.255.255.0
pager lines 24
logging asdm informational
mtu inside 1500
mtu outside 1500
ip local pool VPN_Users 192.168.5.194-192.168.5.220 mask 255.255.255.0
icmp unreachable rate-limit 1 burst-size 1
no asdm history enable
arp timeout 14400
nat (inside,outside) source static NETWORK_OBJ_192.168.2.0_24 NETWORK_OBJ_192.168.2.0_24 destination static NETWORK_OBJ_192.168.5.192_27 NETWORK_OBJ_192.168.5.192_27 no-proxy-arp route-lookup
!
object network obj_any
 nat (inside,outside) dynamic interface
object network SBS_2011
 nat (inside,outside) static interface service tcp smtp smtp
!
nat (inside,outside) after-auto source dynamic any interface
access-group outside_access_in in interface outside
route outside 0.0.0.0 0.0.0.0 205.x.x.249 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
timeout tcp-proxy-reassembly 0:01:00
timeout floating-conn 0:00:00
dynamic-access-policy-record DfltAccessPolicy
user-identity default-domain LOCAL
http server enable
http 192.168.2.0 255.255.255.0 inside
http 192.168.1.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart warmstart
crypto ipsec ikev1 transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
crypto ipsec ikev1 transform-set ESP-AES-256-MD5 esp-aes-256 esp-md5-hmac
crypto ipsec ikev1 transform-set ESP-DES-SHA esp-des esp-sha-hmac
crypto ipsec ikev1 transform-set ESP-DES-MD5 esp-des esp-md5-hmac
crypto ipsec ikev1 transform-set ESP-AES-192-MD5 esp-aes-192 esp-md5-hmac
crypto ipsec ikev1 transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac
crypto ipsec ikev1 transform-set ESP-AES-256-SHA esp-aes-256 esp-sha-hmac
crypto ipsec ikev1 transform-set ESP-AES-128-SHA esp-aes esp-sha-hmac
crypto ipsec ikev1 transform-set ESP-AES-192-SHA esp-aes-192 esp-sha-hmac
crypto ipsec ikev1 transform-set ESP-AES-128-MD5 esp-aes esp-md5-hmac
crypto dynamic-map SYSTEM_DEFAULT_CRYPTO_MAP 65535 set pfs group1
crypto dynamic-map SYSTEM_DEFAULT_CRYPTO_MAP 65535 set ikev1 transform-set ESP-AES-128-SHA ESP-AES-128-MD5 ESP-AES-192-SHA ESP-AES-192-MD5 ESP-AES-256-SHA ESP-AES-256-MD5 ESP-3DES-SHA ESP-3DES-MD5 ESP-DES-SHA ESP-DES-MD5
crypto map outside_map 65535 ipsec-isakmp dynamic SYSTEM_DEFAULT_CRYPTO_MAP
crypto map outside_map interface outside
crypto ikev1 enable outside
crypto ikev1 policy 10
 authentication pre-share
 encryption 3des
 hash sha
 group 2
 lifetime 86400
telnet 192.168.2.0 255.255.255.0 inside
telnet timeout 5
ssh timeout 5
console timeout 0

dhcpd address 192.168.2.160-192.168.2.199 inside
dhcpd dns 192.168.2.49 24.29.99.36 interface inside
dhcpd wins 192.168.2.49 24.29.99.36 interface inside
dhcpd domain asc interface inside
!
threat-detection basic-threat
threat-detection statistics access-list
no threat-detection statistics tcp-intercept
webvpn
group-policy sc internal
group-policy sc attributes
 wins-server value 192.168.2.49
 dns-server value 192.168.2.49
 vpn-tunnel-protocol ikev1
 split-tunnel-policy tunnelspecified
 split-tunnel-network-list value sc_splitTunnelAcl
 default-domain value asc.local
username j password zWCAaitV3CB.GA87 encrypted privilege 0
username j attributes
 vpn-group-policy sc
username j password aGI5qCPyw6XJbOia encrypted
username j attributes
 vpn-group-policy sc
 service-type remote-access
username j password O72LiZyIktgAjNrI encrypted privilege 0
username j attributes
 vpn-group-policy sc
 service-type remote-access
tunnel-group sc type remote-access
tunnel-group sc general-attributes
 address-pool VPN_Users
 default-group-policy sc
tunnel-group sc ipsec-attributes
 ikev1 pre-shared-key *****
!
class-map inspection_default
 match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
 parameters
  message-length maximum client auto
  message-length maximum 512
policy-map global_policy
 class inspection_default
  inspect dns preset_dns_map
  inspect ftp
  inspect h323 h225
  inspect h323 ras
  inspect rsh
  inspect rtsp
  inspect esmtp
  inspect sqlnet
  inspect skinny  
  inspect sunrpc
  inspect xdmcp
  inspect sip  
  inspect netbios
  inspect tftp
  inspect ip-options
  inspect icmp
!
service-policy global_policy global
prompt hostname context
no call-home reporting anonymous
Cryptochecksum:048fa267435668f1d833f171ca0919c2
: end
no asdm history enable
0
 
LVL 24

Expert Comment

by:smckeown777
Comment Utility
Just from first glance this line looks incorrect

access-list outside_access_in extended permit tcp any 192.168.2.0 255.255.255.0 eq https

Should be

access-list outside_access_in extended permit tcp any object SBS_2011 eq https
0
IT, Stop Being Called Into Every Meeting

Highfive is so simple that setting up every meeting room takes just minutes and every employee will be able to start or join a call from any room with ease. Never be called into a meeting just to get it started again. This is how video conferencing should work!

 

Author Comment

by:bns-nyc
Comment Utility
thanks for the response smckeown777, I actually tried changing it to: "access-list outside_access_in extended permit tcp any object SBS_2011 eq https"; however users on the outside were still unable to access OWA.

Do I need to reboot the ASA, before theses settings kick in?  I tried making that same change previously, then just clicked apply and save, but did not reboot the ASA afterwords...and no go.
0
 
LVL 24

Accepted Solution

by:
smckeown777 earned 500 total points
Comment Utility
Sorry you are missing the NAT statement
You have this one -

nat (inside,outside) static interface service tcp smtp smtp

You need also

nat (inside,outside) static interface service tcp https https

I think that is what is missing, if not someone will correct me!
0
 

Author Comment

by:bns-nyc
Comment Utility
Thanks smckeown777! Updating the NAT as well as ACL per your instructions worked. Thanks again, much appreciated!
0
 
LVL 24

Expert Comment

by:smckeown777
Comment Utility
Good to know! Cheers...
0

Featured Post

Free Trending Threat Insights Every Day

Enhance your security with threat intelligence from the web. Get trending threat insights on hackers, exploits, and suspicious IP addresses delivered to your inbox with our free Cyber Daily.

Join & Write a Comment

Suggested Solutions

The articles for turning off the Client firewall policy on the internet are for SBS 2008 and don't really help for SBS 2011. They actually moved the Client firewall policy. In 2011, the client firewall policy has moved to the SBS computers conta…
I’m often asked about newer and larger USB drives connected to SBS2008 and 2011 failing Windows Server Backup vs the older USB drives not failing. As disk space continues to grow and drive technology change SBS2008 and some SBS2011 end up with the f…
Internet Business Fax to Email Made Easy - With eFax Corporate (http://www.enterprise.efax.com), you'll receive a dedicated online fax number, which is used the same way as a typical analog fax number. You'll receive secure faxes in your email, fr…
In this seventh video of the Xpdf series, we discuss and demonstrate the PDFfonts utility, which lists all the fonts used in a PDF file. It does this via a command line interface, making it suitable for use in programs, scripts, batch files — any pl…

762 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

12 Experts available now in Live!

Get 1:1 Help Now