Solved

SharePoint Designer 2010 Workflow not consistently capturing "Assigned To"

Posted on 2012-04-13
6
355 Views
Last Modified: 2012-05-08
I built a simple two step SPD workflow which gets triggered from a custom event handler for item adding event.

For some reason,  I can run this code and enter the same data each time and yet randomly the "Assigned To" column does not get value.  I could run it 10 times and sometimes the column gets the value and perhaps 2 or 3 times it does not it.

Please advise.
0
Comment
Question by:Howard Bash
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 4
  • 2
6 Comments
 
LVL 15

Expert Comment

by:dp_expert
ID: 37848938
Can you try to search sharepoint logs for some "Workflow infrastructure" related logs? Is the same account being used to trigger the workflow in each case?
0
 
LVL 1

Author Comment

by:Howard Bash
ID: 37851150
The same account is triggering the workflow in all cases.
0
 
LVL 15

Expert Comment

by:dp_expert
ID: 37854738
Anything in the logs? Are you assigning the same user and sometimes the user is added and sometimes not?
0
Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
LVL 1

Author Comment

by:Howard Bash
ID: 37855493
There is nothing in logs that I found and same user is being used.  Is there some specific log that you would like me to check?
0
 
LVL 15

Accepted Solution

by:
dp_expert earned 500 total points
ID: 37855547
SharePoint logs everything in the diag logs in the 14 hive. If they are set to verbose and nothing gets logged, then there is really nothing where we can search. Can you find any pattern when this error occurs - item values, farm load, number of items on a list, etc? Are inputing this user directly or with some lookup?
0
 
LVL 15

Expert Comment

by:dp_expert
ID: 37941486
Hello, did you found out what was the problem? Can you provide some insights?
0

Featured Post

Why Off-Site Backups Are The Only Way To Go

You are probably backing up your data—but how and where? Ransomware is on the rise and there are variants that specifically target backups. Read on to discover why off-site is the way to go.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Color can increase conversions, create feelings of warmth or even incite people to get behind a cause. If you want your website to really impact site visitors, then it is vital to consider the impact color has on them.
In case you ever have to remove a faulty web part from a page , add the following to the end of the page url ?contents=1
The viewer will receive an overview of the basics of CSS showing inline styles. In the head tags set up your style tags: (CODE) Reference the nav tag and set your properties.: (CODE) Set the reference for the UL element and styles for it to ensu…
Video by: Mark
This lesson goes over how to construct ordered and unordered lists and how to create hyperlinks.

751 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question