Still celebrating National IT Professionals Day with 3 months of free Premium Membership. Use Code ITDAY17

x
?
Solved

SharePoint Designer 2010 Workflow not consistently capturing "Assigned To"

Posted on 2012-04-13
6
Medium Priority
?
371 Views
Last Modified: 2012-05-08
I built a simple two step SPD workflow which gets triggered from a custom event handler for item adding event.

For some reason,  I can run this code and enter the same data each time and yet randomly the "Assigned To" column does not get value.  I could run it 10 times and sometimes the column gets the value and perhaps 2 or 3 times it does not it.

Please advise.
0
Comment
Question by:Howard Bash
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 4
  • 2
6 Comments
 
LVL 15

Expert Comment

by:dp_expert
ID: 37848938
Can you try to search sharepoint logs for some "Workflow infrastructure" related logs? Is the same account being used to trigger the workflow in each case?
0
 
LVL 1

Author Comment

by:Howard Bash
ID: 37851150
The same account is triggering the workflow in all cases.
0
 
LVL 15

Expert Comment

by:dp_expert
ID: 37854738
Anything in the logs? Are you assigning the same user and sometimes the user is added and sometimes not?
0
10 Questions to Ask when Buying Backup Software

Choosing the right backup solution for your organization can be a daunting task. To make the selection process easier, ask solution providers these 10 key questions.

 
LVL 1

Author Comment

by:Howard Bash
ID: 37855493
There is nothing in logs that I found and same user is being used.  Is there some specific log that you would like me to check?
0
 
LVL 15

Accepted Solution

by:
dp_expert earned 2000 total points
ID: 37855547
SharePoint logs everything in the diag logs in the 14 hive. If they are set to verbose and nothing gets logged, then there is really nothing where we can search. Can you find any pattern when this error occurs - item values, farm load, number of items on a list, etc? Are inputing this user directly or with some lookup?
0
 
LVL 15

Expert Comment

by:dp_expert
ID: 37941486
Hello, did you found out what was the problem? Can you provide some insights?
0

Featured Post

Get your Disaster Recovery as a Service basics

Disaster Recovery as a Service is one go-to solution that revolutionizes DR planning. Implementing DRaaS could be an efficient process, easily accessible to non-DR experts. Learn about monitoring, testing, executing failovers and failbacks to ensure a "healthy" DR environment.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

When the s#!t hits the fan, you don’t have time to look up who’s on call, draft emails, call collaborators, or send text messages. An instant chat window is definitely the way to go, especially one like HipChat. HipChat is a true business app. An…
Without even knowing it, most of us are using web applications on a daily basis.  In fact, Gmail and Yahoo email, Twitter, Facebook, and eBay are used by most of us daily—and they are web applications. We generally confuse these web applications to…
This tutorial demonstrates how to identify and create boundary or building outlines in Google Maps. In this example, I outline the boundaries of an enclosed skatepark within a community park.  Login to your Google Account, then  Google for "Google M…
This tutorial will teach you the core code needed to finalize the addition of a watermark to your image. The viewer will use a small PHP class to learn and create a watermark.

704 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question