Go Premium for a chance to win a PS4. Enter to Win

x
?
Solved

SBS 2008 Publishing new internal website, not the defaults

Posted on 2012-04-13
5
Medium Priority
?
647 Views
Last Modified: 2012-04-18
Hi Experts!
A developer has created a web based applicaton.The database is located within SQL 2005 Express and its been configured in IIS 6

On the server if we type the URL http://localhost:5050 (as it has been configured to listen on 5050) the URL works and the http page shows the application / database

On the client machines the various URL's do not work
http://severname:5050
http://servername.domain.local:5050
http://dbname:5050

I noticed that within the SBS Console\Shared Folders and Websites\websites.....only the three default websites are listed. How can I get this app listed in there.
All three default websites work fine - RWW, OWA etc etc
I attach a screen shot of the DB in question within IIS
We only want this database application to work internally and it does not need to be published to the outside world yet.

Thanks in advance
Regards
Rob
IIS-picture.jpg
0
Comment
Question by:RobKanj
  • 2
  • 2
5 Comments
 
LVL 35

Expert Comment

by:Cris Hanna
ID: 37846342
The site should have been configured under IIS 7, not 6.   IIS6 is only there for legacy FTP and a few other things

All other sites are done in IIS 7
0
 

Author Comment

by:RobKanj
ID: 37846462
Apologies Cris
It is in IIS 7
To be exact in Help about - Version 7.0.6000.16386

Thanks
Rob
0
 
LVL 35

Expert Comment

by:Cris Hanna
ID: 37846779
Not sure I can provide much help then  Don't typically , but just a couple thoughts
have you tried http://serverip:5050/
Have you opened ports on the Windows Firewall for inbound and outbound?
0
 
LVL 84

Accepted Solution

by:
David Johnson, CD, MVP earned 2000 total points
ID: 37847240
On the client machines the various URL's do not work
http://severname:5050
http://servername.domain.local:5050
http://dbname:5050



how about http://domain.local:5050

you could change the bindings for the "CUTE" website to dbname.domain.local port 80

and add a cname record in your dns
dbname.domain.local  servername.domain.local

also check your dns records
nslookup servername
nslookup servername.domain.local
nslookup dbname

both from the server and from any worstation
0
 

Author Closing Comment

by:RobKanj
ID: 37860924
The perfect answer...CNAME resolution
Firewall for port 5050 was already allowed and did not want to cange it to 80 as it may have  conflicted with the default SBS workspaces
Thanks
0

Featured Post

 [eBook] Windows Nano Server

Download this FREE eBook and learn all you need to get started with Windows Nano Server, including deployment options, remote management
and troubleshooting tips and tricks

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Recently we ran in to an issue while running some SQL jobs where we were trying to process the cubes.  We got an error saying failure stating 'NT SERVICE\SQLSERVERAGENT does not have access to Analysis Services. So this is a way to automate that wit…
What if you have to shut down the entire Citrix infrastructure for hardware maintenance, software upgrades or "the unknown"? I developed this plan for "the unknown" and hope that it helps you as well. This article explains how to properly shut down …
Familiarize people with the process of retrieving data from SQL Server using an Access pass-thru query. Microsoft Access is a very powerful client/server development tool. One of the ways that you can retrieve data from a SQL Server is by using a pa…
Via a live example, show how to extract information from SQL Server on Database, Connection and Server properties

926 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question