• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 2748
  • Last Modified:

An error occurred while retrieving the RSS feed.

Hi All,
I get this as first line in RSS feed and it gives error

¿<?xml version="1.0" encoding="utf-8"?>

Do I need to replace ¿ with empty string before reading?



An error occurred while retrieving the RSS feed.
Complete database error message:
ORA-31011: XML parsing failed
ORA-19202: Error occurred in XML processing
LPX-00210: expected '<' instead of '¿'
Error at line 1

Feed content:
¿<?xml version="1.0" encoding="utf-8"?>
<rss xmlns:xsd="http://www.w3.org/2001/XMLSchema" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:x-microsoft="http://schemas.microsoft.com/x-microsoft" xmlns:x-trumba="http://schemas.trumba.com/rss/x-trumba" version="2.0">
      <channel>
            <title>Arrow ECS Education Calendar</title>
            <link>http://ecs.arrow.com/services/education_calendar.html</link>
            <description />
            <language>en-us</language>
            <lastBuildDate>02 Apr 2012 19:27:34 GMT</l
0
bcarlis
Asked:
bcarlis
  • 3
  • 3
1 Solution
 
zc2Commented:
Looks like the Byte Order Mark (http://en.wikipedia.org/wiki/Byte_order_mark) is not recognized by your parser.
0
 
bcarlisAuthor Commented:
Found it gives error at this point:

  l_rss_xml := sys.httpuritype(l_rss_url).getxml();
0
 
zc2Commented:
What's the development environment are you using... What is it, Pascal, Delphi?..
You should ask a question in the related zone or study its documentation about how does it tolerate the UNICODE text format. If you find out it does not support UNICODE, then, you can try to find an utility which converts UTF-8 to ASCII and use it before feeding the text to the XML parser. As an another approach,  just remove the leading BOM bytes by yourself.
0
Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
bcarlisAuthor Commented:
I'm in PL/SQL... good idea... but I got it!
I changed the "Override Feed Encoding" from "Auto Detect" to "UTF-8" and that did it!
Thank you for your help
0
 
bcarlisAuthor Commented:
Actually it was more the "Byte Order Mark" comment that lead me to try the different setting... I clicked to fast...
0
 
zc2Commented:
You're welcome
0

Featured Post

[Webinar On Demand] Database Backup and Recovery

Does your company store data on premises, off site, in the cloud, or a combination of these? If you answered “yes”, you need a data backup recovery plan that fits each and every platform. Watch now as as Percona teaches us how to build agile data backup recovery plan.

  • 3
  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now