Index Services query not working on Windows Server 2008 R2 (64 bit)

We are moving our web server from a Windows 2003 Server (32 bit) running IIS 6 to a Windows 2008 Server (64 bit) running IIS 7.
We had a knowledge base that we called Infobase that used Index Services and an old ASP web page (query.asp) that used Server.CreateObject("ixsso.Query") to query the indexed directory.
In moving this to the new server, the query.asp page no longer works.
Our Infobase web site is setup using its own Application Pool that has "Enable 32-bit Applications" = False so I do not think that it is a 64 vs 32 bit issue.
I also tried creating an IndexQuery.aspx page following the Microsoft KB 820105 but that does not work either.
When I look at the catalog in "Computer Management" - "Indexing Service" everything seems correct.

Any ideas what might be causing this to not work?
SCI-SupportAsked:
Who is Participating?

[Webinar] Streamline your web hosting managementRegister Today

x
 
SCI-SupportConnect With a Mentor Author Commented:
I finally figured out the problem!
At some point in setting up and configuring the Microsoft Indexing Service, the main folder that was being indexed got its Security settings changed so that every file in the folder had an Administrator "lock" icon on it.

I deleted the Index and the folder tree, and reset up the Index.
Now the folder that is being indexed no longer is "locked" to Administrator access only.
All index query searches are once again working.

No idea how the Admin security settings got changed, but problem solved.
0
 
Felix LevenSenior System and DatabaseadministratorCommented:
Have you installed the "“IIS 6 management Capability Feature” on IIS-7 (add to the Server role) ?
0
 
SCI-SupportAuthor Commented:
If you meant "IIS6 Management Compatibility" then, Yes, that Role Service is Installed.
How is that pertinent?
0
The new generation of project management tools

With monday.com’s project management tool, you can see what everyone on your team is working in a single glance. Its intuitive dashboards are customizable, so you can create systems that work for you.

 
Felix LevenSenior System and DatabaseadministratorCommented:
"Application Development," checked "ASP" (Classic) and Not only asp.net (New) ?

To maintain Backwards compatibility to iis6 you Need to enable more Features in iis 7.x
0
 
SCI-SupportAuthor Commented:
Application Development has both ASP.NET installed and ASP installed.
All other ASP websites are running fine on this server.

I am thinking it must be a problem with Indexing Services since I can't get a query page to work regardless of whether I try the old query.asp page or the IndexQuery.aspx page.
See my original post for complete details.  It pretty much spells out the situation.

I notice that Windows 2008 Server no longer has a tree entry to "Query the Catalog" in the Computer Management utility under Indexing Services.

Does anybody actually have an ASP or ASP.NET page that successfully queries a catalog on a Windows 2008 R2 Server (64 bit) ?
0
 
Felix LevenSenior System and DatabaseadministratorCommented:
0
 
SCI-SupportAuthor Commented:
I have pretty much tried all of the things you suggest from those articles.
In "Computer Management", the catalog shows that the Size is 5MB and Total Docs is 723 (which is approximately correct), Docs to Index is 0, Deferred for Indexing is 0, Word Lists is 2, Saved Indexes is 5 and Status is Started.

Although the directory tree that is being indexed is NOT within a WWW Server tree, I tried setting up a Virtual Directory under the web site that I want to query the index from and then chaning the catalog properties under the "Tracking" tab to set the WWW Server to my web site instance and checkmarked "Inherit above settings from Service".  However, none of that made any difference.
0
 
SCI-SupportAuthor Commented:
As I test this further, I have determined that I will get matching Index Service query results but only for .TXT file types.  Even though Index Services says it has indexed 700+ documents (which are mostly either .HTM or .DOC or .PDF), for some reason neither the old ASP object - i.e. Server.CreateObject("ixsso.Query") - or the ASP.NET OleDB object - using the Provider=MSIDXS - will find matching results unless the file is a .TXT file.

I have installed the Microsoft Filter Pack from http://www.microsoft.com/download/en/details.aspx?id=17062
but that did not seem to make any difference.

Any ideas on what to try next?
0
 
Felix LevenSenior System and DatabaseadministratorCommented:
If the Content of a Filetype is Not indexed you Need to get an ifilter for that filetype.

http://en.m.wikipedia.org/wiki/IFilter
0
 
SCI-SupportAuthor Commented:
MrGraves, please READ what I wrote before responding.
I already installed the Microsoft Filter Pack.

If you know of a specific iFilter pack that will make the Microsoft Indexing Service index .HTM and .DOC and .PDF when apparently the Filter Packs from Microsoft and Adobe do NOT do this, then PLEASE give me the links to where I CAN download those filter packs from.

Giving me a wiki link that describes what an iFilter is not helpful in any way.
0
 
Felix LevenSenior System and DatabaseadministratorCommented:
http://www.ifilter.org/Links.htm

Sorry I have no more ideas to solve your problem, lest' see if other experts can help.
0
 
SCI-SupportAuthor Commented:
The moral of this story is to always check the security settings on any folders being indexed.
0
All Courses

From novice to tech pro — start learning today.