The case of the 'Access Permissions' with a Windows 7 Share...

Rojosho
Rojosho used Ask the Experts™
on
EE,

I am working on a 'share' access/permissions problem at a client site where one of the PCs can not make changes to any of the documents inside the 'shared folder'; All of the MS Word and Excel documents open up as 'Read Only'.  The strange part about this is at one time in the recent past ALL of this was working.  I am looking for some troubleshooting suggestions and I do not mind starting at the basics, something has changed, but finding out what is eluding me.

BTW, I did not design this, so I am coming in new to the configuration.

Details:
- The customer has a file depository on the 'Main PC' which is acting like a 'file server'.
- There is one folder that contains all of the documents that need to be accessed by all four PCs - Let us call it 'Main-Share'.

I have confirmed the following:
- All four PCs are on the same Workgroup.
- All four PCs have the same Security Rights to the folder and to the files in question.
- On the problem PC, I have access to the target folder and files, I can see them and I can open them up in MS Word or Excel.
- When I open the files in either MS Word or Excel, they come up as 'Read Only' and I can not Save or SaveAs a file back to the target shared folder.
- On the problem PC, I have created an new user both Standard and Administrator and gone through the 'Mapping Drive' process and I get the same result.
- I have attempted this with a user with and without a password - No Go.

Any one have any pointers to some good troubleshooting guides or suggestions?

Rojosho
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
What version of MS-Office your are using. MS-Office 2010 has a feature where downloaded or files on different system are opened as read only by default. But, then when you open the document it comes with a "orange strip" on the top having a button "Enable Editing" if you enable editing then you will be able to save that file.

If this is not the case then some more understanding has to be done by looking at what level of sharing permissions are set for the folder.
Do the following steps.

1. Right click on the shared folder and click on Properties
2. Select Sharing tab
3. Click on Advance Sharing
4. Click on Permissions
5. Check if Read and Change both are selected.
The quickest and safest and likely the best practice anyway:

Open the file and Save As with a new name.  
Then it will be editable.
RojoshoRTCC-III Level-2 Support
Commented:
Et al,

First, 'Fmarhsall'.  That is a good idea and one that I tested in the very beginning.  When I attempt to SAVE AS a document to the share, I get a message indicating that I do not have permission to write to this folder/share.  I will Remote in and get the exact error.

nitinsawhney:
1. I did see an orange strip, but it had to with a 'macro enabling' option (I have a screen shot of it - you know, a picture is worth.... and all that).

2. I attempted to follow your steps, but within the 'Properties' screen, there was not 'Sharing', only 'Security' (Again, i have a screen shot of it).  As you will see, all expect the 'Special Permissions' option is selected.  This is the same configuration on the Workgroup Server side.

These are very good starts and I thank you all for your suggestions... So, what do you think?
Rojosho
Screen-Shots-of-Share-Problem.doc
Hope you must have already tried "Enable Content"? If not then please try it.

The images look fine. I do not see any issue with the permissions.

One more thing can be looked at, please check the file properties, if the file is marked as Read Only
Well of course they come up then as "read only" if you don't have write permission to the store.  So, the question is: why don't you have write permission to the store?"
RojoshoRTCC-III Level-2 Support

Author

Commented:
Et al,

Sorry for the delay.

The problem is resolved.  

•      I went to the actual Share and notice that EVERYONE only had READ permission.
•      I then edit this to allow EVERYONE READ, WRITE and CHANGE
•      It is working now

It is not clear to me as to why there were other users who could edit documents with the older/original ‘permission’ configuration - this is a mystery that I will address at a later date.

Thank you for your time and suggestions -- Case close... 'Book them Dano'

Rojosho
RojoshoRTCC-III Level-2 Support

Author

Commented:
Well done and thank you for time and suggestions...

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial