We help IT Professionals succeed at work.

SBS 2011 shuts down very slowly

ivolach
ivolach used Ask the Experts™
on
I have installed SBS2011 on Proliant 350 G6 with 20GB RAM.
When I shut down the system it takes a little over an hour.
Suspecting a RAM problem, I have tried to boot/shutdown with various RAM configuration (including alternative DIMMs) and I have found that as long as I keep the memory under 4GB the system will shut down in 10 minutes.  Anything above it and the shut down time goes to 1 hour.

Other than the shut down time every thing else seems to be working OK without any errors.
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Top Expert 2014

Commented:
Anything else running on it such as BES or virus checker?
Distinguished Expert 2017

Commented:
What roles does the system have, SQL, Exchange, Sharepoint, etc.
When you raise the amount of memory in the system, those appplication will take up as much as they can which they can not do in a 4GB environment.
When it is shutting down, it has to clear all those apps, but an hour is rather steep.

get procmon from sysinternals.com will redirect to an Microsoft site.
You could try running it while you hit shutdown to see what the system is doing.

Author

Commented:
It is a SBS2011 with sharepoint and exchange 2010 running.
At this point there are no antivirus or firewall runnin.

I'll try the procmon on Monday.  Thanks,
Distinguished Expert 2018

Commented:
This sounds like a hardware issue. With SBS 2011, I'd assume the hardware is still under warranty. Have you contacted the manufacturer?
WORKS2011Managed IT Services, Cyber Security, Backup

Commented:
try unplugging the network cable, I've seen this work and believe it has something to do with DNS, if it shuts down faster afterwards run dcdiag on the server.

Author

Commented:
I have contacted the manufacturer (HP) and by now they have replaced the mother board, memory sticks & processor.

I'll try disconnecting the network on Monday.
Distinguished Expert 2017

Commented:
IMHO, a hardware issue would manifest the same behavior with 4gb or more.
Prior to shutdown with the large memory, what is memory use?
What is your configuration for the raid write through or write back as a policy?
Trying to see whether as mentioned before the larger memory capacity means there is more cached data that has to be written back to disk.

Sas or sata drives?
Hardware or software raid?
WORKS2011Managed IT Services, Cyber Security, Backup

Commented:
could be a problem with the paging file. Is there any errors in the event logs.

you can defrag the paging file, have you tried this?
Top Expert 2014

Commented:
Isn't 10 minutes excessive time to shutdown with 4GB? Something must be misconfigured however much RAM you have in it. I would shutdown individual services one by one and see what makes a difference.
Distinguished Expert 2017

Commented:
All applications running, a four minute shutdown is not out of the ordinary.
SQL, exchange, sharpoing iis, etc. on an sbs.
Top Expert 2014

Commented:
10 minutes, not 4. Still believable I suppose, in pervious versions we used to NET STOP all the Exchange services first with a script, maybe that fix is still applicable to 2011.
Distinguished Expert 2017

Commented:
The time, net stop exchange, net stop web service net stop SQL and the shutdown will likely will come close to the time the asker is currently waiting for the whole process to complete.

To the point an earlier commenter made for the page file, what is the page file setting?
does the system manage it or do you have it set at a specific number 4gb, etc?

Author

Commented:
Tried to shut down with the network disconnected - same results
Run probmon & RAMMAP but I don't know what I am looking for.  The applications seems to take only 7GB of RAM as it shows 13GB free.
Distinguished Expert 2017

Commented:
try andyalder suggestions while timing each step.
i.e. stop exchange and see how long it takes to stop.
Stop sharepoint (IIS) and see how long that takes.
shutdown server and see whether the above tasks were taking a while and the server shutdown itself is faster.
See if the cumulative time equals the time you previously saw.

This way you might be able to narrow whether the services you mentioned that are on the server are the cause for the slow shutdown.

Author

Commented:
I have stopped all msexchange processes, sharepoint processes, SQL sharepoint, and snmp.
Same shutdown time.

The page file was managed by system and was 20GB.  I have changed it to 30GB and left it on the system drive (Raid 1) - no change in shut down time.
Distinguished Expert 2017

Commented:
The point is to lower the size of the page file not to raise it.

Make sure your system is configured for applications.

properties of computer, advanced settings, performance, make sure to remove all the appearance feature and select to optimize for best performance. Then go to the advanced tab, and make sure the settings there for processes and memory are for programs/application and not for background services and system cache.

a 20GB file means that your resources were not being managed optimally.
How active is your exchange? How large is your SQL database?
On the properties of the network connection, change adapter settings, properties of file and printer sharing, make sure your network is optimized for network applications and not file sharing.

A large page file means that the system expending a large amount of resources getting process out of memory and to the disk and vice versa (swapping)
The lower the swapping, the better the performance.

Provided the server is properly configured, it should keep as much in memory as possible rather than read in and write out from/to the page file.
Commented:
I ended up contacting Microsoft for support and the solution was to disable the GPO that forces flushing the page file on shut down.  Once the gpo has been disabled, the shut down time went to less than 4 minutes
Top Expert 2014

Commented:
Question, when you shut down services one by one you reported that the total time was still an hour, which was the one that took the excessive time?

Author

Commented:
The change made by Microsoft support solved the problem.