We help IT Professionals succeed at work.

Documents in Windows 7 have moved

thedslguy
thedslguy used Ask the Experts™
on
Hello Experts

I'm working on a Windows 7 Pro laptop.  Somehow he has managed to relocate his Documents folder so it is now a subfolder of a subfolder in My Music.

I've tried just moving it, but Windows doesn't allow this.  If I simply create a new folder called "My Documents" or "Documents" it creates it as a subfolder of Public Documents.

Does anyone know how to resolve this?  I've considered copying the profile to a separate drive, deleting the profile, re-creating it and moving things back.  Will this work?  Or will I have the same results?

Any insight will be greatly appreciated.

I'd really like to resolve this over the weekend so he can have it back for work on Monday.

Thanks

thedslguy
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
LeeTutorretired
Top Expert 2009
Commented:
If you right click on the My Documents folder, then select Properties from the context menu, then there should be a tab called "Location".  You can use that to change the location of the folder.
thedslguyComputer and Network Consultant

Author

Commented:
LeeTutor

Thanks for the quick response.

I did that and it made "My Documents" a subfolder of "Documents".  

If I open "Documents" there are some documents, but no folders.  I'd like to get them all in one location.

The actual objective is that when he clicks on the start button and then "Documents" he will see his folders..  What we have right now is, as I said, a list of documents, but no folders.  I still have to drill down from the list on the left to get to "My Documents".

Is there a way to get it all together and have it all show up in "Documents" ?
Top Expert 2013

Commented:
thedslguy--I suspect that when using the Location tab and being offered to put your Documents folder into C:\Users\Username\Documents you did so. You really want to put the Documents folder into C:\Users\Username.

Another approach might be to take ownership of the Documents folder you want to move.
http://www.addictivetips.com/windows-tips/windows-7-access-denied-permission-ownership/
LeeTutorretired
Top Expert 2009

Commented:
Documents Library view in Windows ExplorerThe ordinary setup for Windows 7 is that "Documents" is a Library, and "My Documents" is a folder in the Documents Library.  See the attached screenshot of what I get displayed as a Windows Explorer view when I click on Documents in the Start Menu.  Note that the right pane of Windows Explorer shows the contents of the "My Documents" folder in my screenshot.  What differences, if any, in the way it is presented are now true for your pc?
Top Expert 2016

Commented:
you have to go to the library documents and ADD the users documents folder, it probably has the invalid location and "public documents" only..  Set the users documents folder as the default save location

14-Apr-12-2-09-52-PM.tif14-Apr-12-2-07-15-PM.tif
thedslguyComputer and Network Consultant

Author

Commented:
Hello all

These are good suggestions.  I've been out on a couple of calls.  Now I have to go on a service emergency.  When I get back I'll try the suggestions and see what happens.

Stay tuned

And thanks!!

tdg
thedslguyComputer and Network Consultant

Author

Commented:
ve3ofa

Well your suggestion got the folders and all to appear when I click on Documents.  But it didn't move them from the folder inside a music folder.

It's certainly better, but I'm concerned that the user will be confused and mess things up again.

Any ideas on how to relocate the folder?
LeeTutorretired
Top Expert 2009

Commented:
I thought you said the advice I gave you made the My Documents a subfolder of Documents?  Maybe you have it as both a folder in Documents library, but still also in the Music library? If so, just delete that folder, perhaps after checking to see whether all the contents are in common in both.

One other thing, you can use the registry editor, REGEDIT.EXE, from the Run dialog box and check these two locations:

HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\Shell Folders

and

HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\User Shell Folders

Both should have an item in the right pane called Personal.  The value of the Shell Folders "Personal" item should be:

C:\Users\<accountname>\Documents

where "<accountname>" is replaced by whatever your user's account name is,
and the value of the User Shell Folders "Personal" item should be:

%USERPROFILE%\Documents
thedslguyComputer and Network Consultant

Author

Commented:
LeeTutor

My mistake.  Yes, it appears in both places when I followed your suggestion.

I'll try your suggestion with the registry  when I have a chance.  I'm on another project at the moment.

tdg
Top Expert 2016

Commented:
go to the music library properties and remove that folder
thedslguyComputer and Network Consultant

Author

Commented:
LeeTutor

I installed some screenshot software so I can send you a look at what I see when I open Libraries.

I've tried to move the objects listed in Documents but it won't allow me to do anything with them, including delete them.  They appear to be folders, but  I don't recognize the symbol

I did get them moved successfully to Documents, but they still appear as a subfolder.  I re-did your suggestion of changing the location in its properties and that was successful.  And now they are no longer listed under a music folder.  So I'm pretty close.

I haven't done anything in the registry yet.  I'll look at that later this evening.  But as I said, I'm really close now!

Thanks!!

tdg

Screenshot of Documents Library
Top Expert 2013

Commented:
thedslguy--Have you tried to take ownership of the files as suggested?
http://www.addictivetips.com/windows-tips/windows-7-access-denied-permission-ownership/ ?

P.S. your screenshot is very difficult to read on my PC.
Top Expert 2016

Commented:
Welcome to the world of Libraries which is a new item in Windows 7.  
Libraries are a collection of folders, the default libraries are
documents which contain public documents and my documents
music which contains public music and my music (music)
videos which contains public videos and my videos (videos)

the 'my * files" are located in c:\users\username\folder by default this can be changed for those of us that only want the OS in c: and our data elsewhere

You can create your own libraries or add / subtract libraries at will.

Your Screenshot with an explanation
thedslguyComputer and Network Consultant

Author

Commented:
All

I tried taking ownership, but the user already has that, so no help there.

When I open Documents from the start button on my comnputer (and from several other Windows 7 machines)  I get something that looks like this:  (Click on the embedded file below for a better view)


 Documents-ScreenShot.pdf

This is what I'm ultimately trying to accomplish.

As I said, it's certainly better now, but what you see here is what I'd like to have when it's all said and done.

Thanks

tdg
Top Expert 2016
Commented:
change the view settings group by from type to NONE http://screencast.com/t/w6GM5GtMmVN
LeeTutorretired
Top Expert 2009

Commented:
It is hard to tell, but it seems that your screenshot at ID: 37850950 is similar to what you have on your computer in your latest screenshot, and also similar to what appears in my screenshot of my computer.  When you click on the Documents library in the left pane of Windows Explorer, what should show up in the right pane is the folder called My Documents, if that is set as the default folder location for the Documents library.  Since there are two folders in that Library, as in mine, I assume the other folder is Public Documents.

But I think you should check those registry locations to determine if everything is ok.
LeeTutorretired
Top Expert 2009

Commented:
I'm going to have to go to the airport to pick up a friend, and then we will both be attending a writer's seminar, so I won't be back until much later tonight...
thedslguyComputer and Network Consultant

Author

Commented:
My apologies for the delay in responding, everyone.

We got the last of it figured out!  My associate was looking at it and he said he changed the view and now all is normal.

So thanks to all and I'll award points with the next post.

tdg
thedslguyComputer and Network Consultant

Author

Commented:
Oops  

I just noticed the post from Ve3ofa.  That may be what he did.  I'll ask him tomorrow and award points after that.

tdg
thedslguyComputer and Network Consultant

Author

Commented:
Thanks to you both for the help.

It turns out that the two suggestions in combination, were exactly what I needed.

Thank you again!

thedslguy