We help IT Professionals succeed at work.

Unable to access OWA internally exchange 2010

vmagan
vmagan used Ask the Experts™
on
Hi guys,

I have Exchange 2010 on windows server 2008 box. I have always been able to check my emails via owa if needed while on the network. Now all of a sudden it is not working. What can be causing this to not work internally? Is there a setting in exchange 2010 that might have been tweaked? There is no firewall.

Please help.
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®

Commented:
Could you provide more details about what is happening? Why is not working?
When I try to go to the owa page i get Internet explorer cannot display the web page. That's all I get.  Is there an option that would turn off owa internally?

Commented:
Can you try to run Test-OwaConnectivity from EMS. If the test user is not created go to the scripts folder, in the instalation kit root folder, and run new-testcasconnectivityuser.ps1. And check the results of the test. Also be sure that you are using the same URL when testing OWA in browser as the one provided by the test.
WORKS2011Managed IT Services, Cyber Security, Backup

Commented:
1. run ipconfig /flushdns
2. run iisreset
3. try accessing using the ip instead of server name.
4. try it with http and https
5. clear browser history in Internet Explorer

sounds like a DNS issue to me.
WORKS2011Managed IT Services, Cyber Security, Backup

Commented:
note: run 1 from server and workstation run 2 from server
Works,

Tried those steps and still got ie page cannot be displayed.

Z4mfi,

I don't see a test owa in exchange 2010. Where is it located?

Commented:
So you must run Exchange Management Shell on the Exchange 2010 server. Go to C:\Program Files\Microsoft\Exchange Server\V14\Scripts and run New-TestCasConnectivityUser.ps1 script file. After that run "Test-OwaConnectivity | FL" command. And paste the results so we can know more details about this issue ( don't forget to change the private information or replace it with something else )
should i be running "Test-OwaConnectivity | FL" from powershell? When I do i get this.

PS C:\Users\admin> "Test-OwaConnectivity | FL"
Test-OwaConnectivity | FL
PS C:\Users\admin>

and when i ran the script file by right clicking on it and run with powershell i get prompted for password. I put in a password and it disappears.

what am i doing wrong here?

Commented:
1. Don't run any powershell script/batch files/etc. right clicking, ever, you will not see the results unless a break is written in the code of the script ( not in this case ). So open Windows Powershell app am go to the folder specified above and just type the name of the script and press the tab key to autocomplete and enter
2. Run test-owaconnectivity | FL without " "
3. From where are you trying to run this command? From your desktop/workstation or from the exchange server?
I am trying to run this from the exchange server

Commented:
Then you must run Exchange Management Shell and do the steps from above.
I will run this 1st thing in the am. Still having this issue.
I cannot get the cmd to work.

[PS] C:\>\ProgramFiles\Microsoft\ExchangeServer\V14\Scripts\New-TestCasConnectivityUser.ps1
The term '\ProgramFiles\Microsoft\ExchangeServer\V14\Scripts\New-TestCasConnectivityUser.ps1' is not recognized as the
name of a cmdlet, function, script file, or operable program. Check the spelling of the name, or if a path was included
, verify that the path is correct and try again.
At line:1 char:83
+ \ProgramFiles\Microsoft\ExchangeServer\V14\Scripts\New-TestCasConnectivityUser.ps1 <<<<
    + CategoryInfo          : ObjectNotFound: (\ProgramFiles\M...ctivityUser.ps1:String) [], CommandNotFoundException
    + FullyQualifiedErrorId : CommandNotFoundException

what am i doing wrong here. Line 83 is a space between exchange and server. I tried with the space and without. Same with Program files.

Please help.
created new forward zone for mail.exchangeserver.com and created a blank 'A' record with the internal ip address.

See link below to resolution.

http://www.experts-exchange.com/Software/Server_Software/Email_Servers/Exchange/Q_27720772.html
thanks for the help.