Fax over IP, T38 vs. G711ulaw

jwil320
jwil320 used Ask the Experts™
on
Looking for some help on to determine if changing the fax configuration on our network will help solve some problems we are having at our remote offices with faxing. Whenever a fax comes in or out of our network I see the codec that it uses is g711ulaw from the "sh voice call summary" command.

The remote offices are complaining faxing issues like only half a page going through or the fax not going through at all. So would forcing T38 help this at all?  

Here is the current set up. All voice commands are configured on the CUCM server. However I have enabled T38 for faxing on the CUCM server but the fax still comes through as G711ulaw. Do i have to create any dial-peers that specify T38 on all the voice gateways? If I disable T38 from the CUCM gateway config page then I get a line in the 2851 that says mgcp fax t38 inhibit.

2x T1 for voice
          |
 Cisco 2851 ISR
          |
  Cat 6509 ---------- CUCM 7.0
          |
  3X VG224

I've attached a screen shot of the cucm gateway config and the configs fo the 2851 and vg224.
2851.txt
vg224.txt
cucm7.0.png
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Top Expert 2007
Commented:
T38 can correct the issues you describe but it can also be caused attenuation or gain on the PRI itself. If calls are on the pri have good volume then you may not have a problem with it.

To enable t38 on your VG's and ISR from the config prompt add

mgcp default-package fxr-package
mgcp t38 gateway force

then restart mgcp
no mgcp
mgcp

Hope this helps!

Author

Commented:
hmmm i tried the above and now it my office doesn't except any calls. and now a show voice call summary shows the following.



0/0/0:23.1                                        *shutdown*
0/0/0:23.2                                        *shutdown*
0/0/0:23.3                                        *shutdown*
0/0/0:23.4                                        *shutdown*
0/0/0:23.5                                        *shutdown*
0/0/0:23.6                                        *shutdown*
0/0/0:23.7                                        *shutdown*
0/0/0:23.8                                        *shutdown*
0/0/0:23.9                                        *shutdown*
0/0/0:23.10                                       *shutdown*
0/0/0:23.11                                       *shutdown*
0/0/0:23.12                                       *shutdown*
0/0/0:23.13                                       *shutdown*
0/0/0:23.14                                       *shutdown*
0/0/0:23.15                                       *shutdown*
0/0/0:23.16                                       *shutdown*
0/0/0:23.17                                       *shutdown*
0/0/0:23.18                                       *shutdown*
0/0/0:23.19                                       *shutdown*
0/0/0:23.20                                       *shutdown*
0/0/0:23.21                                       *shutdown*
0/0/0:23.22                                       *shutdown*
0/0/0:23.23                                       *shutdown*
0/1/0         -          -  -                     FXOLS_ONHOOK
0/1/1                                            *shutdown*
0/0/1:23.1                                        *shutdown*
0/0/1:23.2                                        *shutdown*
0/0/1:23.3                                        *shutdown*
0/0/1:23.4                                        *shutdown*
0/0/1:23.5                                        *shutdown*
0/0/1:23.6                                        *shutdown*
0/0/1:23.7                                        *shutdown*
0/0/1:23.8                                        *shutdown*
0/0/1:23.9                                        *shutdown*
0/0/1:23.10                                       *shutdown*
0/0/1:23.11                                       *shutdown*
0/0/1:23.12                                       *shutdown*
0/0/1:23.13                                       *shutdown*
0/0/1:23.14                                       *shutdown*
0/0/1:23.15                                       *shutdown*
0/0/1:23.16                                       *shutdown*
0/0/1:23.17                                       *shutdown*
0/0/1:23.18                                       *shutdown*
0/0/1:23.19                                       *shutdown*
0/0/1:23.20                                       *shutdown*
0/0/1:23.21                                       *shutdown*
0/0/1:23.22                                       *shutdown*
0/0/1:23.23                                       *shutdown*
2/0/0                                            *shutdown*
2/0/1         -          -  -                     FXSLS_ONHOOK
2/0/2         -          -  -                     FXSLS_ONHOOK
2/0/3         -          -  -                     FXSLS_ONHOOK
2/0/4         -          -  -                     FXSLS_ONHOOK
2/0/5         -          -  -                     FXSLS_ONHOOK
2/0/6         -          -  -                     FXSLS_ONHOOK
2/0/7         -          -  -                     FXSLS_ONHOOK
2/0/8         -          -  -                     FXOLS_ONHOOK
2/0/9         -          -  -                     FXOLS_ONHOOK
2/0/10        -          -  -                     FXOLS_ONHOOK
2/0/11        -          -  -                     FXOLS_ONHOOK
2/0/12        -          -  -                     FXOLS_ONHOOK
2/0/13        -           - -                     FXOLS_ONHOOK

Author

Commented:
ok just needed to reset the connection from the CUCM.
Exploring ASP.NET Core: Fundamentals

Learn to build web apps and services, IoT apps, and mobile backends by covering the fundamentals of ASP.NET Core and  exploring the core foundations for app libraries.

Top Expert 2007

Commented:
Did the reset from the CM bring it up?

might look at the following to make sure none are shutdown

controller t1 0/0/0 and 0/0/1
serial interface 0/0/0:23
serial interface 0/0/1:23
voice-port 0/0/1:23
voice-port 0/0/0:23

Author

Commented:
yea the reset brought them back online.
Top Expert 2007

Commented:
great, is t38 working for you now?

Author

Commented:
it's somewhat working. I think I'm going to restart all the CUCM servers tonight. The remote offices said their faxes are going through and my main office says everything is ok also. But There is another part of our building that is connected through fiber which use a different CUCM server in the cluster that is complaining now. Which they didn't before the change.


We have 3x CUCM servers. I made sure the T38 fax is enabled on all 3. I forced the T38 connection on all gateways. Is there something else that I am missing? or something that needs to be added because of the redundancy? I've attached the config of the other gateway router it is a 2821 ISR.
2821.txt
Top Expert 2007

Commented:
Can you diagram the connectivity for the part of the building that is having issues? If all 3 call managers are in the same cluster then you shouldn't have to configure each server individually.

Are they getting the same error the others had before or something different?

Author

Commented:
they are in the same cluster. The only issue is the faxes are only half or 3/4 of a page.
Top Expert 2007

Commented:
What devices are between the 2821 and the pri? is qos configured end to end?

Author

Commented:
PSTN---(SRST)      PSTN
    |                        /
 2821               2851
    |                     |
3750--------------6509----------CUCM

Author

Commented:
Yes QoS is configured throughout the network. End to End.
Top Expert 2007

Commented:
Are the faxes connected to fxs interfaces in the 2821 and are the 2 PRI interfaces on the same 2821 the connection these faxes use to reach the pstn?

Author

Commented:
The faxes are connected to a vg224. I believe they only use the pstn connection from the 2821 if our main connection goes down. the 2851 is our main connection to the PSTN.
Top Expert 2007

Commented:
Ok, is t38 enabled on the vg? Can you post the config and a screen shot of the configuration on cucm?

Author

Commented:
I disabled the fax modem passthrough and now everything is working. Thanks for your help.
Top Expert 2007

Commented:
Great, glad all is well!

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial