We help IT Professionals succeed at work.

SMTP blocked, can't figure out why [PIX 501]

musras
musras used Ask the Experts™
on
[Cisco PIX 501, PDM 3.0]
[SBS2003]

Yesterday we added an access rule for RDP. All was good until inbound emails suddenly stopped coming in. SMTP traffic seems to be blocked.

Telnet from outside gives "Could not open connection to the host, on port 25: Connect failed". Telnet from inside is ok.

We've been over the access/translation rules over and over, but must be missing something...

Any help would be greatly appreciated.

Config
interface ethernet0 auto
interface ethernet1 100full
nameif ethernet0 outside security0
nameif ethernet1 inside security100
hostname pixfirewall
domain-name ciscopix.com
fixup protocol dns maximum-length 512
fixup protocol ftp 21
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
fixup protocol skinny 2000
no fixup protocol smtp 25
fixup protocol sqlnet 1521
fixup protocol tftp 69
names
name 192.168.1.10 sbs2003
access-list inside_outbound_nat0_acl permit ip 192.168.1.0 255.255.255.0 192.168.1.96 255.255.255.240 
access-list outside_cryptomap_dyn_20 permit ip any 192.168.1.96 255.255.255.240 
access-list outside_acl permit tcp any host 213.150.xxx.xxx eq 3389 
access-list outside_acl permit tcp any interface outside eq ftp 
access-list outside_acl permit tcp any host 213.150.xxx.xxx eq https 
access-list outside_acl permit tcp any host 213.150.xxx.xxx eq www 
access-list outside_acl permit tcp any interface outside eq 993 
access-list outside_acl permit tcp any interface outside eq imap4 
access-list outside_acl permit tcp any interface outside eq 465 
access-list outside_acl permit tcp any eq smtp host 213.150.xxx.xxx eq smtp 
access-list outside_cryptomap_dyn_40 permit ip any 192.168.1.96 255.255.255.240 
access-list CompanyVPN_splitTunnelAcl permit ip 192.168.1.0 255.255.255.0 any 
access-list Company_splitTunnelAcl permit ip 192.168.1.0 255.255.255.0 any 
access-list outside_cryptomap_dyn_60 permit ip any 192.168.1.96 255.255.255.240 
access-list Company_VPN_splitTunnelAcl permit ip 192.168.1.0 255.255.255.0 any 
access-list outside_cryptomap_dyn_80 permit ip any 192.168.1.96 255.255.255.240 
pager lines 24
icmp permit host 217.157.xxx.xxx outside
mtu outside 1500
mtu inside 1500
ip address outside 213.150.xxx.xxx 255.255.255.128
ip address inside 192.168.1.1 255.255.255.0
ip audit info action alarm
ip audit attack action alarm
ip local pool VPN 192.168.1.100-192.168.1.110
pdm location 0.0.0.0 255.255.255.128 outside
pdm location 0.0.0.0 255.255.255.0 inside
pdm location 217.157.xxx.xxx 255.255.255.255 outside
pdm location sbs2003 255.255.255.255 inside
pdm logging informational 100
pdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list inside_outbound_nat0_acl
nat (inside) 1 0.0.0.0 0.0.0.0 0 0
static (inside,outside) tcp 213.150.xxx.xxx 3389 sbs2003 3389 netmask 255.255.255.255 0 0 
static (inside,outside) tcp 213.150.xxx.xxx smtp sbs2003 smtp netmask 255.255.255.255 0 0 
static (inside,outside) tcp 213.150.xxx.xxx https sbs2003 https netmask 255.255.255.255 0 0 
static (inside,outside) tcp 213.150.xxx.xxx www sbs2003 www netmask 255.255.255.255 0 0 
static (inside,outside) tcp interface imap4 sbs2003 imap4 netmask 255.255.255.255 0 0 
static (inside,outside) tcp interface 993 sbs2003 993 netmask 255.255.255.255 0 0 
static (inside,outside) tcp interface 465 sbs2003 465 netmask 255.255.255.255 0 0 
static (inside,outside) tcp interface ftp sbs2003 ftp netmask 255.255.255.255 0 0 
access-group outside_acl in interface outside
route outside 0.0.0.0 0.0.0.0 213.150.xxx.xxx 1
timeout xlate 0:05:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout sip-disconnect 0:02:00 sip-invite 0:03:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+ 
aaa-server TACACS+ max-failed-attempts 3 
aaa-server TACACS+ deadtime 10 
aaa-server RADIUS protocol radius 
aaa-server RADIUS max-failed-attempts 3 
aaa-server RADIUS deadtime 10 
aaa-server RADIUS (inside) host sbs2003 timeout 10
aaa-server LOCAL protocol local 
http server enable
http 217.157.xxx.xxx 255.255.255.255 outside
http 192.168.1.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server community public
no snmp-server enable traps
floodguard enable
sysopt connection permit-ipsec
crypto ipsec transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac 
crypto dynamic-map outside_dyn_map 20 match address outside_cryptomap_dyn_20
crypto dynamic-map outside_dyn_map 20 set transform-set ESP-3DES-MD5
crypto dynamic-map outside_dyn_map 40 match address outside_cryptomap_dyn_40
crypto dynamic-map outside_dyn_map 40 set transform-set ESP-3DES-MD5
crypto dynamic-map outside_dyn_map 60 match address outside_cryptomap_dyn_60
crypto dynamic-map outside_dyn_map 60 set transform-set ESP-3DES-MD5
crypto dynamic-map outside_dyn_map 80 match address outside_cryptomap_dyn_80
crypto dynamic-map outside_dyn_map 80 set transform-set ESP-3DES-MD5
crypto map outside_map 65535 ipsec-isakmp dynamic outside_dyn_map
crypto map outside_map client authentication RADIUS LOCAL
crypto map outside_map interface outside
isakmp enable outside
isakmp policy 20 authentication pre-share
isakmp policy 20 encryption 3des
isakmp policy 20 hash md5
isakmp policy 20 group 2
isakmp policy 20 lifetime 86400
telnet 217.157.xxx.xxx 255.255.255.255 outside
telnet 0.0.0.0 0.0.0.0 inside
telnet timeout 5
ssh 217.157.xxx.xxx 255.255.255.255 outside
ssh 0.0.0.0 255.255.255.0 inside
ssh timeout 5
management-access inside
console timeout 0
dhcpd address 192.168.1.20-192.168.1.40 inside
dhcpd dns sbs2003 195.184.xxx.xxx
dhcpd wins sbs2003 
dhcpd lease 3600
dhcpd ping_timeout 750
dhcpd auto_config outside
dhcpd enable inside

Open in new window

Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Top Expert 2012
Commented:
Hi, did you change any other lines?

This doesn't look right

access-list outside_acl permit tcp any eq smtp host 213.150.xxx.xxx eq smtp

Should be

access-list outside_acl permit tcp any host 213.150.xxx.xxx eq smtp

Author

Commented:
As far as I know no other lines were changed.

Would you happen to know how to correct?

Author

Commented:
There we go!

I removed and added the access & translation rules and hey presto...

Thanks so much for your help!