Port forwarding confusion

S Connelly
S Connelly used Ask the Experts™
on
Hello Folks,

I might be a bit confused here so perhaps someone can correct me where I am wrong...

Two questions:
1. I wish to enable port forwarding so that I can view my home security cameras from outside my home. I understand that I will eventually need a service like DDNS but right now I just want to test this out.

Modem/firewall: Actiontec v1000h
Networked DVR details:
  IP address: 192.168.1.100 (static)
  Port: 1503

What I tried:
1. Under Firewall, I clicked on Firewall settings and selected Firewall security level HIGH.
2. Checked both boxes (Traffic In/Out) for T120, Conferencing Service, port1503
3. Clicked Port Forwarding
4. For "Set the LAN port...", entered Start port: 1503, end port 1503
5. Protocol: TCP
6. LAN IP Address: 192.168.1.100
7. Ignored "Set the remote port...."
8. Clicked Apply

On the iPhone:
Device IP: Modem's temporary WAN address
Device port: 1503
User name and pass

But this configuration fails with a time out. It should also be noted:
a) This works from inside lan on 192.168.1.100
b) I also tried a similar configuration for an IP camera and also failed to connect from the WAN.
c) I tried and failed at testing with other Firewall settings (step 1)

Any ideas? Thank you
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
EirmanChief Operations Manager
Commented:
portforward.com shows you how to port forward with any router and some devices, so it may help. When you arrive at a page looking for money, just skip it and it will show you how to do it manually for free.
Gajendra RathodLead System Administrator
Commented:
Please check the setting of Intrusion Detection in firewall.

Make an exception rule to allow port 1503 traffic to your security camera.
Check below link and also your firewall. Disable your firewall for one time to check if it is responding or not

Confirm your port is responding or not by this link http://www.t1shopper.com/tools/port-scan/


check this also :-
http://www.actiontec.com/howto/h2_detail.php?id=76&cat_id=3
11/26 Forrester Webinar: Savings for Enterprise

How can your organization benefit from savings just by replacing your legacy backup solutions with Acronis' #CyberProtection? Join Forrester's Joe Branca and Ryan Davis from Acronis live as they explain how you can too.

It wasn't clear that you forwarded incoming port 1503 to a fixed IP address on the LAN at port 1503.  Maybe you did that but again, it's not clear.  It's needed.

That is, assuming that the internal machine is listening on port 1503.  Is it?
S ConnellyTechnical Writer

Author

Commented:
Hello fmarshall, yes the forwarding was set up correctly on that port (btw, the port number is arbitrary - I can change the port number to any unused port number). Anyhow, that fact that it didn't appear to work (that is, access the device from outside the firewall) surprised me and so that is why I asked EE for advice.

Thanks to all, I will check over all your suggestions today and respond back.
What I meant to address was this:

Computer or perhaps camera: IP address xxx.yyy.zzz.123
Listening on port 1503 or whatever you pick for providing the service.

Then, from within the LAN you should be able to access the service by addressing xxx.yyy.zzz.aaa:1503.  If that doesn't work then ....

Current public address 1.2.3.4 with port PPPP set up for this service.
Then from the internet side you should be able to access the service at 1.2.3.4:PPPP

To do this, the router should be set for port forwarding:
Incoming port PPPP
Target IP address xxx.yyy.zzz.123:1503  that is, port 1503.

So, there can be two different port numbers used for this purpose.  If you use the same one like 1503, well you still need to enter it in the port forwarding setup.

I'm sorry if this is a bit pedantic but I was sensing that one of the items might be missing because you said that you had ignored "set the remote port" and I'm not sure you want to ignore that.....
S ConnellyTechnical Writer

Author

Commented:
Hello all,

Thank you again for all your suggestions.

@Eirman
Thanks for the portforward.com idea, unfortunately, it didn't tell me anything I did not already know... in fact, it confirmed that I was doing the port forward correctly.

@Gajendra_Rathod
>Please check the setting of Intrusion Detection in firewall.

Thanks but I cannot find any such settings on the Actiontec V1000H. Somewhat related, I did try changing "Set your Firewall Security Level" to "NAT Only" but that did not help either.

@neil40m
Excellent links!
>Confirm your port is responding or not
Yes it is! "is responding on port 1503 (imtc-mcs)." So that confirms that the port forwarding is correct.

@fmarshall
Thanks for all your help!
This is how I am testing the cameras. Perhaps this will offer some insight on where the problem lies.

I am using an iPhone app called Super mEye (although I have tested others with same negative result)
Under device list, I have entered both a local (on LAN) IP address of 192.168.1.100 PORT ??? Ah.... that is the problem!!
It seems that the user setting that I assigned as Port 1503 is not actually for remote access (despite being called remote access). The app Super mEye defaulted to a different port in the 34000 range. I opened this port forward and presto, it works! It appears that this specific port is controlled under an undocumented area called Mobile Monitor!

This is what happens when you buy cheap Chinese goods, lousy manuals, zero support, and confusing functionality.

Thank you all!

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial