Clipboard not working on RDS session

ZeelSol
ZeelSol used Ask the Experts™
on
Good morning,

We seem to have a problem when trying to copy & paste from an RDS session to a local machine.

When 'copied' the item does not appear in the clipboard, clipboard is enabled in the RDS connection settings.
I have tried killing the RDPCLIP process and restarting it, but no joy.

Can anyone shed any light on this issue?

Thanks!
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Check if group policy or RDP server setting are explicitly denying use of clipboard, server settings take precedence over connection settings. Warning on RDP server settings are TO DENY, so selecting "local printers" or anything in the list will deny it's use, no matter what you put in the RDP connection shortcut.

Author

Commented:
Hi asavah,

Thanks for the reply,

The group policy object is set to not defined, and should work by default,

Any other ideas?

Thanks,

Commented:
Have you tried to log off from the session, rather than disconnecting. As sometimes a session can display this sort of behaviour.

Also as mentioned by asavah, take a look at the Remote Desktop policy, which is different to the Group Policy.

Also a little more detail would be helpful, are you trying to copy data from SBS 2003, 2008 or 2011?
Group Policy
"Computer Configuration \ Administrative Templates \ Windows Components \ Remote Desktop Services \ Remote Desktop Session Hosts \ Device and Resource Redirection \ Do not allow clipboard redirection" set it to DISABLED.

Make sure you select "clipboard" under local resources in your rdp file.

 If you use XP client connecting to SERVER 2008 or SBS2008/2011 try updating RDC client to the latest version from here http://support.microsoft.com/kb/969084 also make sure client machine has .net framework 3.5 installed (it's optional but it helps with Easy Print issues)
Raymond PengSystems Engineer

Commented:
Can you check that the following services are running on both machines?

1. Network DDE DSDM
2. Network DDE
3. ClipBook

Start > run > services.msc

Author

Commented:
Excellent that has done the trick!

Thanks for all your replies.

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial