Publishing 3rd party app using UAG

Lance_P
Lance_P used Ask the Experts™
on
Hi,
  I am currently using UAG to publish an app which uses IIS. I have no issue's in getting it to work, and it is accessible externally as well.

However, when I try to access the app directly, bypassing the portal, the URL created for the app takes me to the Main Portal from where I can click on the link and then launch the app.

I have tried to make the default internal app the one I need, but then it takes me back to the portal and I see 2 links, one for the portal and one for the app.

If I uncheck the "Display home page within portal frame" then I get an error.

The app itself has to be access with a /XXX so the app is publish with app.domain.com/xyz

The path under web servers is /xyz.

I have no issues if I use https://app.domain.com/xyz. Works fine without taking me to the portal link. Just need to users to type app.domain.com and then let UAG do the http to https redirection.


I have tested this with Sharepoint and there I can go direct to the app using sharepoint.domain.com ..

So it has to be some setting or rule which needs to be created perhaps?

Thanks in advance
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®

Commented:
Use an application template like Other Web Application (Application Specific Hostname).  You can then specify the public hostname that the application replys to directly...

Author

Commented:
Well I have tried that as well, but it just wont work with that setting. Will give it another shot though.

Thanks for the reply.
I hadn't work on UAG, but TMG. I think the concept of publishing is same.

You need two publishing rules, one for http to https redirection and the second to publish hte web app:

1. Create a deny rule from external to the web app IP address, in action tab configure it to redirect the traffic rather than blocking it.

2. Create a publish rule as your needs and change the Path tab as follow:

Internal path= /xxx/* (supposing that xxx is the path of the web application.
External path= /xyz/* ( xyz is the path that the users are need to type it in the url, you can set it to /* ).
11/26 Forrester Webinar: Savings for Enterprise

How can your organization benefit from savings just by replacing your legacy backup solutions with Acronis' #CyberProtection? Join Forrester's Joe Branca and Ryan Davis from Acronis live as they explain how you can too.

Author

Commented:
I haven't got time to work on this as yet. But will post back shortly.
Commented:
Ok here's an update, since I could not get it working as required, i have done a redirect from the www provider directly to the https://xyz.domain.com/path and that has taken care of the problem. Ofcourse xyz gets redirect to xyz1 but that will work as long as the user does not have to type in https with the path.

Thanks
Glad you get a solution.

Author

Commented:
Could not get it to work in any other way.

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial