asp.net c# visual studio 2008 AjaxControlToolkit

Codeaddict7423
Codeaddict7423 used Ask the Experts™
on
Hello,

I have a web application that was  built using Visual Studio 2008. I am also using AjaxControlToolKit.  

I recently upgraded the AjaxControlToolkit to the version released on November 16, 2011 (from the version released April, 2011).

Now, I get error messages that say "Error Creating Control - ToolkitScriptManager1"
AND
"Error Creating Control - ContentPlaceHolder1"

I am unable to see any of my pages under DesignView and cannot update the website until this issue is resolved.

ANY HELP would be greatly appreciated. "URGENT"
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
<%@ Register Assembly="AjaxControlToolkit" Namespace="AjaxControlToolkit" TagPrefix="asp" %>

add aspx page top
You need register the Ajax Assembly in the Page of reference it in web.Config
as rkworlds said ass register tag
Learn Ruby Fundamentals

This course will introduce you to Ruby, as well as teach you about classes, methods, variables, data structures, loops, enumerable methods, and finishing touches.

Author

Commented:
krworlds,

Thank you for the quick reply.

Attached, please find a screenshot of what I see on my screen.

I recently upgraded to the AJaxControlToolkit (version releaseed 11/16/2011) and now I get this error.  ANY suggestions to get this to work would be greatly appreciated.
ajaxtoolkit-errormessage.jpg
Vikram Singh SainiSoftware Engineer cum AD Developer

Commented:
ok we get screenshot showing error but it doesn't show the code part in which you are using ajax controls. Share your code if possible.

Problem 3 topic present solution to your problem. Give it try at link: http://www.ll.do/2011/12/how-to-upgrade-to-new-version-of.html

Could you also test with solution at link: http://stackoverflow.com/questions/2083203/deploying-asp-net-ajax-1-0-and-3-5-web-application-on-same-server

Author

Commented:
vs00saini,

Thank you for the quick reply.
I have been researching issues related to upgrading AjaxControlToolkit from version 2.0 to version 3.5 and I'm still having problems.

One issue is related to an error message stating "Error Creating Control - ContentPlaceHolder1"  The given assembly name or codebase was invalid.  (Exception from HRESULT: 0x80131047).

I have also changed my web config as follows:

-----------
Removed:
----------
<httpModules> <add name="ScriptModule" type="System.Web.Handlers.ScriptModule, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35"/> </httpModules>  
----------
Removed:
----------
<sectionGroup name="system.web.extensions" type="System.Web.Configuration.SystemWebExtensionsSectionGroup, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35">
----------
Edited
-----------
<configuration>    <runtime>       <assemblyBinding>          <dependentAssembly>             <assemblyIdentity name="System.Web.Extensions"                               publicKeyToken="31bf3856ad364e35"                               culture="neutral" />             <bindingRedirect oldVersion="1.0.61025.0"                              newVersion="3.5.0.0"/>          </dependentAssembly>       </assemblyBinding>    </runtime> </configuration>
-------------


ANY help in getting this to work would be greatly appreciated.

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial