We help IT Professionals succeed at work.

Ping only returns the first of 4

durhamgoat
durhamgoat used Ask the Experts™
on
I have a canon IR 2010 which is on our network and as of friday began some strange behavior. At first it would print documents after a long time like over 2 hours, now it will not print them at all. It is a scanner and will scan a document and send it via network to my outlook inbox, this continues to work.
I have pinged it and it seems to return the first ping but not the remaining 3.
thoughts?
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
As you are not getting ping Reply properly try to check Network cable/ switch... due to which it may be the issue.
Chris StauntonSr. Infrastructure Engineer

Commented:
This could also be a faulty NIC in the printer, if you have the ability to reseat the NIC, I would give that a try.  If you are pinging from a Windows box do a ping -t <ip of printer> and see if you can see breaks in the ping responses, wiggle the cables etc.  The -t will allow for continuous ping which can be broken by hitting CTRL+c at any time.
Jer

Commented:
So, outgoing traffic seems fine, while incoming traffic is being interrupted.  Aside from swapping out the network cables and making sure that everything is clean and in good shape, you may need to look for software updates.  If it is a physical issue with the I/O card (NIC) on the copier, that gets messier.  You may be able to reseat it, but it could requires a service call.  However, in the meantime, I'd try to eliminate the physical variables, such as the cables and switch ports used.

Author

Commented:
There was a 4 port switch in the line to our main switch, I removed and tried. I also tried running the -t and it just pings once and then not again.
Senior Systems Support Analyst
Commented:
You could have a duplicate IP address on your network - a simple way to test for this is to turn off the canon IR 2010 and then ping it's IP address.  If you get a response while it is powered down it is a clear indication that some other device has the same IP address.

Author

Commented:
The IP address returns no pings when the copier is off. When I run a network scanner it still comes up in the list as a 0ms response time. It does however share the same host name as another computer on the network and no other devices do.
Michael DyerSenior Systems Support Analyst

Commented:
A duplicate host name should not impact the ping command if you are pinging by ip address.  This feels like a hardware issue to me - I'd place a service call with your Canon tech.

Author

Commented:
I assigned it a new static ip address. The scanner came up with it as a different host name and now it works. Equitrac michael was the closest so I will accept his as solution.