Wordpress Gallery

HelpNearMe
HelpNearMe used Ask the Experts™
on
Hi experts,

I'm working on a client site that was developed by another developer and I can't seem to use the gallery function.  The popup window appears with the thumbnails etc to insert the gallery just fine and when I press insert gallery the place holder graphic appears in the page body indicating that there should be a gallery there (admin panel).

When I view the live page no gallery appears, no evidence that a gallery should appear and no space allocated for the gallery appears in the page.

When I view the html in the page editor (WP admin panel) I can see the gallery short code etc but it simply doesn't work.

Is there a setting somewhere that I should check to see if the gallery is enabled or something?

Thanks,

HNM
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Tony van SchaikFront-end Developer

Commented:
Do have an URL for me so that i can lookup the code?

Author

Commented:
Client might be PO'd if I share the URL so I've attached a screenshot showing the admin panel HTML and Visual view, source as shown by chrome dev tools, and a shot of the live page.  You can see there is no evidence that the gallery is functioning at all.

Any ideas?

HNM
sample1.jpg
Tony van SchaikFront-end Developer

Commented:
Is this Nextgen Gallery you're using?

Are the images really in that gallery and are there, also thumbs of the images. Sometimes it happens that the thumbs aren't generated properly...?
Microsoft Azure 2017

Azure has a changed a lot since it was originally introduce by adding new services and features. Do you know everything you need to about Azure? This course will teach you about the Azure App Service, monitoring and application insights, DevOps, and Team Services.

Author

Commented:
No just the standard wp gallery.  No gallery plugin used.

Author

Commented:
And yes the images are in the gallery, it's really strange.  I repeated the steps on another wp instance on another server and it work perfectly with the same images.  But this one is a no go.  I think the primary developer tweaked something and I don't know about it.  I also don't have ftp access so I can really check under the hood.

Kind of frustrating.  Any ideas?  Is there a main switch or something for the default gallery function in WP?

HNM
Front-end Developer
Commented:
Kinda weird it should work out-of-the box, is this version WP 2.5 or higher? It tested it in my own website (with Wordpress 3.3.1) and it works like it should. I have added the images as thumbnails not medium or big images.

WP Gallery issues
Otherwise you can also try the update Wordpress if you're are using an older version it might be a know bug/issue. But before doing that, make a backup first!

Author

Commented:
Version 3.3.1, I just told the client that I can't do anything.  Kind of like trying to fix a locked car.  The primary developer needs to sort it out now.

Thanks for trying!

HNM
Tony van SchaikFront-end Developer

Commented:
Ok good luck then!

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial