Internal Exchange Server 2007 and GoDaddy.com

the-miz
the-miz used Ask the Experts™
on
We recently moved to an internal Exchanger Server 2007 for mail.  Our domain is registered with GoDaddy.  Everything is working fine for the most part with the exception of some delayed incoming mail.  I ran a test on my Exchange server which ha told me Port 587 did not respond.

I have read I must configure a smarthost.

In Org Conf -> Hub Transport -> Send Connectors Tab -> Default Send Connector properties -> Network Tab  it is configured to Use domain name system [DNS] "MX" records to route mail automatically.

For my receive connector, the SMTP service is disabled on the Exchange server as it was causing a problem receiving any mail.  When disabled it works, for the most part with some delays....  I read somewhere I must configure IIS SMTP Virtual Server smart host.  IIS -> Default SMTP Virtual Server properties -> Delivery Tab -> Advanced -> Smart Host

What has been told to me, that I should use smtpout.secureserver.net as the smart host, is this true even though i removed these records from my GoDaddy DNS settings and only use mail.mydomain.com ??

Also, when the settings is set in IIS, do I start the SMTP service on the server?  If I start the service will mail be stopped again, or work properly and fast with no delay?

Your help is greatly needed.
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Commented:
Port 587 is for authenticated SMTP.  Since you cannot expect every other email server that wants to deliver email to your email domain to use (and know) a username and password, it doesn't really matter that port 587 does not respond.  What really matters is that port 25 must respond.

You don't necessarily require a smarthost.  A smarthost might be of help if your server has trouble delivering email - ie, you are getting bouncebacks.  If your server is configured properly, and you have a valid PTR record, you should be fine without using a smarthost.  At any rate, whether you have a smarthost or not, it doesn't affect incoming email.

With newer versions of Exchange (2007 and 2010), mail delivery does not require the SMTP service.  In fact, as you have found out already, it causes problems.  Leave it off.  The IIS SMTP Virtual Server smarthost setting was needed in Exchange 2003 and older - you don't need this with Exchange 2007.

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial