trunk ports and vtp

tolinrome
tolinrome used Ask the Experts™
on
How can I trunk ports from my new  2960S poe switch to a catalyst 4507R? I also need to enable this switch for vtp. How do I do that, with what specific commands?
Thanks.
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
To trunk:

the 4507:
sw# vlan dot1q tag native
sw(config-if)# switchport mode trunk
sw(config-if)# switchport trunk native vlan #
sw(config-if)# switchport trunk allowed vlan all

the 2960:
sw(config-if)# switchport mode trunk
sw(config-if)# switchport trunk native vlan #

Make sure the native vlan commands on both are the same.

To make VTP work, make sure the switches are not already part of a VTP domain:

Switch# show vtp status
VTP Version                     : running VTP1 (VTP2 capable)
Configuration Revision          : 4
Maximum VLANs supported locally : 64
Number of existing VLANs        : 18
VTP Operating Mode              : Server
VTP Domain Name                 :                           --> empty value here, no VTP domain
VTP Pruning Mode                : Disabled
VTP V2 Mode                     : Disabled
VTP Traps Generation            : Disabled

Then choose your VTP server switch from where you will create and manage VLANs and propagate the changes:

sw(config)# vtp mode server       --> default mode
sw(config)# vtp domain domain-name.com
sw(config)# vtp password yourpassword       (optional command)

Now choose which switches will act as clients to auto configure VLANs according to the VTP Server configured above, make sure the configuration revision is set to 0 from a show vtp status. If not, go ahead and change the vtp domain and that should reset the counter to 0, then proceed with following:

sw(config)# vtp mode client
sw(config)# vtp domain domain-name.com
sw(config)# vtp password yourpassword       (optional command)

Author

Commented:
ok, to trunk the the switches I didnt know I had to use the command on both switches, to trunk them? I'm trying to connect port 1 on the 4507 to port 48 on the new switch, I have an ethernet cable connected between them. I also need to enable 24 ports on it for VoIP.

I did a sh vlan status on the 4507 and results are:

User Access Verification

Username: Admin
Password:

4507#sh vtp status
VTP Version capable             : 1 to 3
VTP version running             : 2
VTP Domain Name                 : Paradise
VTP Pruning Mode                : Enabled
VTP Traps Generation            : Enabled
Device ID                       : 0018.b900.6280
Configuration last modified by 192.168.1.254 at 4-4-12 18:15:15
Local updater ID is 192.168.1.254 on interface Vl1 (lowest numbered VLAN interface found)

Feature VLAN:
--------------
VTP Operating Mode                : Server
Maximum VLANs supported locally   : 1005
Number of existing VLANs          : 17
Configuration Revision            : 27
MD5 digest                        : 0xEF 0x66 0x34 0x72 0xBF 0xFE 0x3B 0x05
                                    0xE8 0x44 0xAB 0x35 0xAE 0xF0 0x09 0xF6
4507#
Ok great, where do you need assistance now?

Author

Commented:
I got the switches trunked and created the new vlan. I want that vlan to be able to pick up IP addresses from my windows dhcp server so I will create a new scope. But how do I make certain that those IP's from the new scope are only assigned to the new vlan on the 2960S.
Manually assign those switchports  to the voice vlan.

switchport mode access
switchport access vlan # --> data
switchport voice vlan # --> voice

Then enter the ip helper command to direct DHCP broadcasts to the DHCP server:

sw# interface fastethernet 0/0.10  --> default gateway's subinterface for voice vlan
 ip helper-address <dhcp server's ip>

When the DHCP broadcast is forwarded to the server, the source address will allow the server to identify from which pool it should serve an IP from.

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial