Unable to connect to internet after CentOS Server 6.2 install

AIX25
AIX25 used Ask the Experts™
on
I have recently installed CentOS 6.2 onto my laptop.  After install, I am trying to connect to my home cable internet (comcast), but with no success.  Any information on this would be great.
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®

Commented:
What kind of laptop?  Can you confirm that your NIC card is installed?
Sikhumbuzo NtsadaIT Administration

Commented:
I suppose you have DHCP enabled on your "comcast" internet device/router:

In your laptop can you log in to a terminal and do "/sbin/ifconfig" as root user, then tell us if you have an IP address and a correct default gateway?

Author

Commented:
I have a Lenovo Thinkpad T61

I am able to get the internet to work now after some configuration with direct connection to the router.  I was hoping that I could access this with my wifi? I tried installing
"iwl4965-firmware" after some google searching, but with no luck.. Any suggestions?
Sikhumbuzo NtsadaIT Administration

Commented:
Have you tried setting up the wireless settings manually, then select the option to activate?

Author

Commented:
I tried searching on how to do that.  Would you know how?
Sikhumbuzo NtsadaIT Administration

Commented:
Are you able to use a terminal

If yes do this as root:

cat /etc/sysconfig/network-scripts/ifcfg-wlan0

Open in new window


....then post back the result.

I want to see if the Laptop can recognise the presence of your wireless card and is set to DHCP on boot.

Author

Commented:
Actually, I can only access my system as a terminal.  It is setup as a server.

The output is:

DEVICE="wlan0"
HWADDR="00:1C:BF:A3:92:DA"
NM_CONTROLLED="yes"
ONBOOT="yes"
Sikhumbuzo NtsadaIT Administration

Commented:
What is the out put of "iwconfig", can you see your wireless access point?

If yes try the following:


root@santasi-PC:~#vi /etc/sysconfig/network-scripts/wlan0


auto lo

iface lo inet loopback
iface wlan0 inet static
address 	172.16.0.10
netmask 	255.255.0.0
network 	172.16.0.0
broadcast 	172.16.255.255
gateway 	172.16.0.1

Open in new window


....then bring down the connection....

root@santasi-PC:~#ifdown wlan0

Open in new window



....bring it up again....


root@santasi-PC:~#ifup wlan0

Open in new window



....now ping another computer or to the internet to test.


Oh one more thing do you have a passkey enabled on your wireless access point?
Can you turn it off while we are testing we will get back to it once it works.

Author

Commented:
The output from iwconfig is:

wlan0     IEEE 802.11abg  ESSID:off/any  
          Mode:Managed  Access Point: Not-Associated   Tx-Power=15 dBm  
          Retry  long limit:7   RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:off

And after updating wlan0 file, still unable to ping
IT Administration
Commented:
Okay the step above will not work because the Laptop cannot detect the wireless access point.

I suspect the drivers might not be working fine.

Author

Commented:
Installed drivers, and works

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial