Email not forwarding to Contacts Exchange 2003

laurencoull
laurencoull used Ask the Experts™
on
I've set up some Contacts in Exchange 2003 on my 2003SBS server specifying an external email address (eg joe.bloggs@yahoo.com) and I've set a forward in Exchange General to the Contact, where in turn the external email address is specified. But although emails come in to the users' main AD accounts as normal, they don't forward to the external addresses.
I've looked at a few hits on this and done the obvious suggestions such as ticking all boxes in Exchange / Global Settings / Default/PropertiesAdvanced but to no avail. Dismounted & remounted the Store and restarted the Information Store Service. Still nothing. The external email addresses are accepting email ok when sent directly to them.
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Dinesh SinghArchitect
Commented:
Hi,


Are you able to send directly to contact which you created? checkout the queues for NDR which has generated.

and track the message it will give clear idea.

Author

Commented:
There are no NDR's generated.

Not sure how i can send an email to the contact, the contacts don't have a proper address as such, there just an object in AD?
Check if you have selected "Deliver messages to both forwarding address and mailbox" for the exchange user mailbox.
Check the queue on the internet connector. Do you see any e-mails sent to to that contact in the queue.
If it's not in the queue use the message tracking center http://www.msexchange.org/tutorials/Exchange-2003-Message-Tracking-Logging.html to check if the e-mail you have sent is delivered or not.

If all of the above are not working mostly you need to recreate your contact with proper smtp e-mail address.
11/26 Forrester Webinar: Savings for Enterprise

How can your organization benefit from savings just by replacing your legacy backup solutions with Acronis' #CyberProtection? Join Forrester's Joe Branca and Ryan Davis from Acronis live as they explain how you can too.

Author

Commented:
Yep, I have selected "Deliver messages to both forwarding address and mailbox" for the exchange user mailbox.
Not sure what you mean by "Check the queue on the internet connector": Where do I find the internet connector?
Managed to enable Message Tracking ok & see that immediately after each entry where the incoming email is listed, the next entry is always from Postmaster@mydomain.com with subject line "Delivery Status Notification (Failure)"
Clicking into these I see 6 stages they've gone through, the last 2 of which are
SMTP: Started outbound transfer of  message
SMTP: Message sent to Badmail
Is this what's happening, instead of going out to the external email address specified on the Contact, they're going to Badmail? Why????
And in the entries where the incoming email itself is listed, the last 3 stages are:
SMTP: Store Driver: Message delivered locally to store
SMTP: Started Outbound transfer of message
SMTP: Non-delivered report (NDR) generated
I've checked the external email address specified on the Contact carefully and it IS CORRECT!
I've managed to get this to work on other 2003 SBS Exchange servers with identical config and they work, so why not this one?
I've deleted and re-created the Contact many times. The details on the Contact, which are 100% based on the ones which work well on other servers are:
Name of contact: DavidExternal
Alias as shown on the Exchange General tab: DavidExternal
Email address as shown on the General tab and the Primary entry on the Email Addresses tab: david@<externaldomain.com>
Email address as shown on the Exchange General tab: SMTP:david@<externaldomain.com>
Other (ie non-Primary) addresses in the Email Addresses tab: DavidExternal@<localdomain>.local & the X400 one which Exchange always creates for you.
Baffled!!!
contact should contain the external smtp e-mail address.
In the exchange tab you should specify the contact not the external smtp e-mail address.

Follw this article.
http://www.msexchange.org/tutorials/mf015.html

Author

Commented:
Ok: Deleted & re-created my Contact again & went through the process exactly as per the article:
Still getting the "SMTP: Message sent to Badmail" in the Message Tracker
Commented:
go to contact in exchange, properties, and maybe try to set:

Use mapi rich text format   -  NEVER

Author

Commented:
You mean in the Exchange Advanced tab on the Contact?
Not seeing an option to set it to NEVER, albeit there is a tick box 'Use mapi rich text format'
This was not checked: I checked it just as a 'clutching at straws' attempt, but still getting the "SMTP: Message sent to Badmail" in the Message Tracker
... But maybe I'm looking in the wrong place and there IS an option somewhere to set it to NEVER??

Commented:
There may not be a "never" setting in 2003... I don't have a 2k3 server running to check.

That was just something to try. It has caused an issue with certain contacts for me. Not all...but I moved to exchange 2010.

here's a link to another thread that may help:

http://www.experts-exchange.com/Software/Server_Software/Email_Servers/Exchange/Q_22747248.html

Commented:
a few more questions:

can you just outright send an email to that address - david@(externaldomain)   ??

What service pack are you running?

If you create a distribution group....say one called:  David-INT-EXT  .. then add davids internal and external contact, does that work?

Author

Commented:
No, don't think there is in 2003. No worries, appreciate the advice.
Yes I can send email outright no problem
Service pack 2
Tried the distribution group- Same "SMTP: Message sent to Badmail" message

Commented:
just for fun, here's a screen shot

it shows the "never" mapi rich text box... also, do you have the 'allow automatic forward' checked?
I know you said you had done the obvious, but didn't really specify the "internet message formats".. so wanted to check.
I'm assuming you did though.

 1.Open Exchange System Manager
 2.Expand Global Settings
 3.Locate Internet Message Formats
 4.In the right-hand panel, right click Properties on "Default"
 5.In the Advanced tab, check the option "Allow Automatic Forward"
exch.gif

Author

Commented:
Yep, all 6 boxes are ticked and I found and checked the "never" mapi rich text box
Same problem persists.................. depressing

Commented:
are these contacts hidden from the GAL?

Commented:
Also, is the SMTP connector configured to "Use DNS to route each address space on this connector", or "SmartHost"?
Try switching between the two settings.

I guess other things to try might be:

turn off any antivirus on the server
turn off anti spam

when making changes, make sure to allow some time for them to 'catch up'
I have frustrated myself before with my own impatience  ... more than once :)
Automatic forward and DNS may not help here.
As e-mail is already sent outside when it is sent normally, DNS is not an issue.
Automatic forwarding is used when users need to configure forwarding. Our scenario is different as the admin is configuring forwarding through a contact.

One more suggestion. Leave the contact as it is. Can you configure another new mailbox and configure forwarding with the same contact.
Any updates.

Author

Commented:
Tried that but to no avail. And I'm now less convinced that this is only affecting the one contact, as on sending test emails to some other contacts I've found they're also failing to forward with the same "SMTP: Message sent to Badmail" & "SMTP: Non-delivered report (NDR) generated" in the Message Tracker.
Alan HardistyCo-Owner
Top Expert 2011
Commented:
Was the domain ever managed on your Exchange 2003 server?

Please download and install the IIS 6.0 Toolkit from http://support.microsoft.com/kb/840671

Then run Metabase Explorer and check to see if the Problem External Domain is listed under:

Server> LM> SmtpSvc> 1> Domain

If the External domain is listed - delete it and then try the forwarding again.

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial