HELP!!!  Cannot connect with Remote Desktops when the servers have NLA enabled.

rsnellman
rsnellman used Ask the Experts™
on
Hi, I recently just configured my 2008 servers to use NLA for Remote Connnections.  I use the Remote Desktops add-on on my Windows XP Pro x32 w/SP3 PC.  I have performed the registry hacks as directed from here

to allow my Windows XP Pro x32 w/SP3 PC to use Remote Desktop Connections with NLA.  I can connect using the Remote Desktop Connection, but I cannot access my servers through the Remote Desktops console any longer.  Apparently, they are different, which I believe I knew that a long time ago when I first started using Remote Desktops.

Anyways, I am trying to figure out how I can still use the Remote Desktops with NLA rather than the Remote Desktop Connections.

Anyone know how to set this up?  Is it even possible?

Thanks in advance.
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
rsnellmanIT Manager

Author

Commented:
The Remote Desktops mmc version I am using is v.5.2.3790.0.  It mentions its use for connecting to terminal servers, but I use it instead of Remote Desktop Connection service.  It has worked well for many years and keeps my server list organized nicely.
Top Expert 2016
Commented:
It either doesn't support NLA.. or you need to enable Credential Security Support Provider
the fixit is here
Rodney BarnhardtServer Administrator

Commented:
By chance, in the properties of your RDP, do you have the -admin added to always connect to console 0? If so, I have ran into this a while back with our Exchange server. It drove me nuts why I had the issue, but my co-worker did not. We finally tracked it down to the -admin variable. This is what it would look like in the variable field if you do:

%windir%\system32\mstsc.exe -admin

If that is the case, just remove the -admin and try it.
rsnellmanIT Manager

Author

Commented:
ve3ofa,
Already did that.  That allows me to connect to my 2008 servers via Remote Desktop Connections, but not thru Remote Desktops.  These are two different apps.  If I turn off NLA on the servers I can connect to them via Remote Desktops just fine.  Just trying to figure out how to still use Remote Desktops without having to upgrade to Windows 7 at the moment.  I am scheduled for a new office PC this summer, so I am holding off for a side-by-side migration of my office PC.


rbarnhardt,
I am not sure what you are referring to.  Could you provide more details of where to find this mstsc.exe -admin?  Is this on the server side or the client side?


Thanks.
Rodney BarnhardtServer Administrator

Commented:
I have inserted screen shots below. These are from a Windows 7 system. Locate your RDP, right click, and select properties
RDP Properties location
In the highlighted section below, is where the -admin would be located if you are using it.

Where the -admin variable is located.
Top Expert 2016

Commented:
Remote Desktops
What O/S are you connecting from?
IT Manager
Commented:
OK, thanks for the replies.  I tried all of those options you previously mentioned with no resolution.  I was using Windows XP Pro with Remote Desktops mmc version 5.2.3790.0 that came with Windows Server 2003 CD.  So, I figured I could not find a newer version of this Remote Desktops for Windows XP or Server 2003, so I would try Windows 7 Enterprise (Pro).  I had to install the RSAT features, but after that it just worked.

So, there you have it, must use Windows 7 RSAT to connect wtih Remote Desktops using NLA to Server 2008 machines.


Thanks to all.
rsnellmanIT Manager

Author

Commented:
My answer was how the issue was resolved.

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial