No Internet Access

Shepwedd
Shepwedd used Ask the Experts™
on
Hi,

All Windows 7 PC's (400) across our domain have recently started displaying a yellow warning triangle in the botton right of the screen with a message saying 'No Internet Access'. The machines can access the internet absolutely fine.

I have rebooted PC's, run repairs on the network adapter, Disabled and Enabled the connection. Deleted and re-installed the network card and cleared out Proxy Settings and so far only one thing seems to resolved it. I can get the warning to disappear on my PC by conneting up to an FTP site (using FireFTP). When I disconnect again the warning stays away.

As far as I know nothing has changed on our switches or ISA Server and we have the desktop firewalls disabled and run McAfee Enterprise 8.8

Does anyone have any ideas why this might be occuring and how I might resolve this for my other users ?

Many thanks
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
rtayIT Director

Commented:
A lot of times this issue is cause by the anti-virus software.  Disabling and renabling the anti-virus software works in some cases.  I have had the issue with AVG.  Once it was removed it went away.
Hello,

2 things you can try, on one of the problem machines:

1. Can you update the network drivers?  The manufacturer website should have newer drivers available.

2. Ca you temporarily disable McAfee client on one of the problem machines and then disable and re-enable the network adapter with the McAfee client turned off?
Sikhumbuzo NtsadaIT Administration

Commented:
Check if there is an additional protocol added in your TCP/IP settings. If the is uncheck it then test.
Yeah, I suppose it could be some infection, but here's the more likely reason.

That icon is fired by Windows checking a particular web site that MS runs. If Windows can talk to it, then you have Internet access.  Of course, in true MS fashion, this "assumes" that the site is up and it "assumes" that you are NOT behind any kind of proxy server or Internet access filter and it "assumes" that even if you are then the user logged on has access right to see that web site.

So there are three things that you can do about it.

1. Ignore it; it's mostly bogus anyway.
2. Change the Registry key to not query the server:  HKLM/system/currentcontrolset/services/nlasvc/parameters/internet – set enable activeprobing to 0
3. Create a GPO to turn it off:  I've not actually tried this so don't know if it actually works or not:

Create or open a GPO which will be applied to your server(s).
Navigate to Computer Configuration\Policies\Administrative Templates\Network\Network Connections.
Enable the “Do not show the “local access only” network icon” setting.
Close the GPO and GPMC.msc.

Author

Commented:
Many thanks for your reponses.

I have updated the Network drivers and it didn't resolve the issue.
I have disabled McAfee and it didn't resolve the issue.
I have checked for additional TCP/IP Protocols and can't see anything out of the ordinary.

I can look at turning it off but it is handy if it is telling the truth.
Commented:
If anyone is interested I found out how to Turn off the Indicator in Group Policy.

Expand Computer Configuration, expand Administrative Templates, expand System, expand Internet Communication Management, and then click Internet Communication settings.

In the details pane, double-click Turn off Windows Network Connectivity Status Indicator active tests, and then click Enabled.

Futher info about how it works here:
http://technet.microsoft.com/en-us/library/ee126135%28v=ws.10%29.aspx

Author

Commented:
Nobody came up with anything better.

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial