Exchange 2003 Not Pushing Email To Devices

Pawel_Kowalski
Pawel_Kowalski used Ask the Experts™
on
Hello, I have a exchange 2003 installation under SBS 2003 that works great aside from the fact that it will not push information to mobile devices, I have to set them to manually check the server for new items.

I've been searching around and for Push to work I read the server must have exchange 2003 SP2 installed, I verified that this is the case on our server.

I did have to change quite a few directory security settings in IIS to make exchange activesync work, is it possible I missed a setting that would allow direct push to work?

This is happening on Android devices as well an iphone. I tested a different exchange installation (running exchange 2010) and push works fine so I don't think this has anything to do with the devices themselves.

Thanks.
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
AmitIT Architect
Distinguished Expert 2017

Commented:
Alan HardistyCo-Owner
Top Expert 2011

Commented:
Please have a read of my Exchange 2003 / Activesync article and check all your settings are correct, then if / when they are, run the test on the test site and report any errors that displayed that my article doesn't cover.

http://www.experts-exchange.com/Software/Server_Software/Email_Servers/Exchange/A_1798-Exchange-2003-Activesync-Connection-Problems-FAQ.html

Alan

Author

Commented:
Thanks for the comments. Before you guys responded I noticed that if I go to access servername/OMA it tells me that it cannot connect to my mailbox:

Unable to connect to your mailbox on server SERVER. Please try again later. If the problem persists contact your administrator.

After some digging I found that I need to install this hotfix:

http://support.microsoft.com/kb/916640

Which I did but still get the same error.

Alan, I can go through everything in your guide (much of what I already did) but I assume since OMA can't find my mailbox I assume it won't help me much. I did try the exchange remote connectivity test and it shows that everything is fine.
Alan HardistyCo-Owner
Top Expert 2011

Commented:
OMA is unrelated to Activesync, but might indicate a separate problem.

You might be best advised to follow Method 2 of KB883380 and then try the OMA again and also Activesync as it should iron out any virtual directory problems.

When you are removing IIS directories - remove the exchange-oma virtual directory too, then follow KB817379 to re-add the directory.

Both of these KB articles are referenced in my article:

http://www.experts-exchange.com/Software/Server_Software/Email_Servers/Exchange/A_1798-Exchange-2003-Activesync-Connection-Problems-FAQ.html

Author

Commented:
Thanks, I really appreciate the help. I followed these steps as well as went through your guide. I didn't run in to any problems rebuilding the directories (including exchange-oma) but I continue to have this problem.

The only warning the connectivity test throws up is about the certificate not working with certain windows mobile devices since it is from GoDaddy. Since I can sync I assume that is not the problem.
Alan HardistyCo-Owner
Top Expert 2011

Commented:
The cert error isn't an issue, unless you have some antique (several years old) Windows Mobile 5.0 devices.

So are things syncing now?

Author

Commented:
I can sync as before but exchange is still not pushing emails to my devices.
Alan HardistyCo-Owner
Top Expert 2011

Commented:
What hardware firewall / router do you have and what is the default timeout on the Default Website set to?

Does Push mail work on Wi-Fi?

Commented:
As you mentioned its go daddy certificate can you try without SSL on mobile devices and check if it works fine then its issue with cert and need to install root & intermediate cert on mobile devices manuallly

Author

Commented:
Push mail does not work on our internal wifi (on the same subnet as the server) nor over the air. This is on 3 devices:

Samsung Note running android 2.3 (both wifi and 4G don't work)
Apple iPod (wifi only)
HTC View Tablet Running Android 3.0 (wifi and 3G)

I verified on all these that the settings are set to push, not manual or periodic updates. Aside from the push issue everything works perfectly. I also have another client with exchange 2010 running with push working perfectly on these devices, so I don't think the devices are the issue.

We do not have a hardware firewall, we simply use the router that is built in with our comcast business modem and forward the appropriate ports (80 and 443). I disabled the windows firewall running on the server to see if that would help but still no luck.

Finally, for the default website the connection timeout is 120 seconds and "Enable HTTP keep-alives" is checked.

Ash007, I tried checking "accept all certificates" on my samsung note and still I have the same issue.

Could the fact I cannot access http://server/OMA be related to this?

Thanks again for all the help.
Alan HardistyCo-Owner
Top Expert 2011

Commented:
Okay - if it isn't working on Wi-Fi - it won't work properly anywhere.

Please change the timeout on the default website to 480 (as per my article) and then run iisreset, then try push mail again.

The problem with the OMA virtual directory may be related - but it isn't specifically used in Activesync.

Have you followed KB883380 (Method 2 - also deleting the exchange-oma virtual directory) and then followed KB817379 to re-create the Exchange-OMA virtual directory?

(All detailed in my article).

Author

Commented:
I set the time out to 480 and restarted IIS as well as my devices (sorry I missed this in your article). Unfortunately still the same problem.

I did method 2 under KB883380 yesterday (in addition to deleting and recreating the exchange-oma directory).
Alan HardistyCo-Owner
Top Expert 2011

Commented:
Okay - no problems.

Can you re-install Exchange 2003 SP2 again then please - it often fixes various problems.  it might just help fix this problem.

Author

Commented:
Ok, I will try that. Is the process as simple as downloading the following file and installing it:

http://www.microsoft.com/download/en/details.aspx?displaylang=en&id=9664

Or should there be certain things I should be aware of that could cause problems?
Alan HardistyCo-Owner
Top Expert 2011

Commented:
Essentially yes - but sometimes it complains about IMF and won't work.  If it does, follow this article:

http://exchangepedia.com/blog/2006/11/update-manually-removing-imf-v1.html

Although this is about IMF v1 - your error will be about IMF v2 but the same article applies.

Alan

Author

Commented:
Ok, thanks. The reinstallation went nice and smooth. Just to be safe I rebooted the server as well as my devices.

Unfortuantely still the same issue :(. Everything works great aside from pushing updates to my devices.
Alan HardistyCo-Owner
Top Expert 2011

Commented:
Can you please setup a test account for me and email me the details to alan @ it-eye.co.uk.

Just want to make sure nothing simple is being overlooked.

Thanks

Alan

Author

Commented:
Ok sent. I noted in the email that I have not yet deployed the MX record for exchange in our DNS zone since I want everything working before I do so. Let me know if you need anything else or if for some reason you didn't get my email. As I said I can't thank you enough for your help.
Alan HardistyCo-Owner
Top Expert 2011

Commented:
All seems to be working apart from the AUTD (Always Up To Date) notifications.

For that, please have a read of the following:

http://technet.microsoft.com/en-us/library/cc164312(v=exchg.65).aspx

Make sure you have “Enable Up-To-Date Notifications Enabled” and check the other settings too.

This is probably all that is missing.

Author

Commented:
Isn't direct push over HTTP a far more efficient method of doing this since you don't have to use SMS, or am I misunderstanding the difference between AUTD and DirectPush?

Under mobile servers I have "Enable Direct Push over HTTP(s)" on, "Enable up-to-date notifications via SMTP and Text Messaging" was off. I turned it on just to test, but still continue to have the same problem. After I turned it on I deleted the exchange account on my phone and readded it, that didn't fix the problem.

I also verified that "Up-to-date notifications" are enabled under my active directory account.

What I haven't yet done is create a mobile carrier since I don't have the details for ATT that I need. But I would much rather do this over HTTP, not over SMS.
Alan HardistyCo-Owner
Top Expert 2011

Commented:
Slight misunderstanding.

The way Activesync works is as follows:

The handheld (once configured), keeps an open connection (via HTTPS) to the Exchange server although no data is transmitted, the connection is usually open for a specified period of time.  If nothing happens, then from time to time, the handheld will send a Ping to the server to keep the connection alive for longer.

If a new email arrives on the server, then the server sends a message to the handheld using the AUTD notifications (a Push message), asking the handheld to perform a sync.  The handheld then receives the 'Push' notification and then syncs the account, downloading the new content.

Without the Push Notification, the handheld will never initiate a sync, which seems to be the problem with your configuration.

There is no SMS going on here at all.

As you have now enabled the AUTD notifications, please restart the server (or all Exchange Services) and then you should be working happily, unless something else is wrong.

You don't need to create a mobile carrier.

Author

Commented:
Ok, thanks. I rebooted the server but unfortuantely still the same problem.
Alan HardistyCo-Owner
Top Expert 2011

Commented:
Okay - I saw that nothing had changed.

Please check the application event log and look for AUTD errors.  Anything in there?
Alan HardistyCo-Owner
Top Expert 2011

Commented:
Please also check that the individual user accounts have the notifications enabled.

Author

Commented:
No application log errors aside from the 3005 errors that were the before.

I also verified that in active directory under the "Exchange features" tab both you and I have up-to-date notifications enabled.
Alan HardistyCo-Owner
Top Expert 2011

Commented:
Any AV software installed on the server?

Author

Commented:
No AV software.
Alan HardistyCo-Owner
Top Expert 2011

Commented:
And you definitely have Exchange 2003 SP2 Installed?

Author

Commented:
In the exchange system manager if I go to Administrative Groups > Servers my server version is listed as Version 6.5 (Build 7638.2: Service Pack 2) so I assume the answer is yes :).

This is a very frustrating error, searching google I see others have had this issue but there doesn't seem to be a solution.
Alan HardistyCo-Owner
Top Expert 2011

Commented:
Yep - that is SP2!

It's the first time I have seen the problem too and I have worked with Activesync for about 7 years.

Commented:
Can you tell me whats the error code you get on Mobile device
Co-Owner
Top Expert 2011
Commented:
There is no error - the emails do not get pushed to the device, but when you open the Mail app on the device, the emails are pulled down.

Activesync is working - it is just that the Up-To-Date notifications are not getting to the devices to tell them to perform a sync.

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial