Connecting iPad / iPhone to Windows RRAS VPN

BzowK
BzowK used Ask the Experts™
on
Hello All -

My Problem
Currently, I remote to my home computers via standard RDP and a range of ports forwarded on my router.  To add a layer of security as well as functionality, I'm going to remove those ports and start using RRAS.  I set up the server end of it and successfully tested it with a Windows 7 laptop from an outside network.  Unfortunatly, I am unable to connect with my iPad which I do much of my RDP from.  I set the iPad's VPN connection up as PPTP (which I think would be the one to use given my basic server config), but also tried L2TP with no luck.

Attempted L2TP
I've tried setting up L2TP as well using the steps in this interesting article, but haven't had any success. I followed the steps to add the Shared Secret, Add the Policy, restarted the service, and verified the correct ports were open, but still cannot connect with an iPad.  Note:  I did not test the configuration in the article above with any other device - just an iPad using native VPN.

I hear that the iPad (same iOS as iPhone/iPod) supports higher encryption.  Honestly, though, I am not concerned about having the best encryption as anything would be better that leaving 3389 open.  I tried to find apps that I could also test connecting with, but all VPN ones seem to either be for Cisco gear or private browsing.

My Config
I'm currently using Windows Server 2011 SBS.  My router has the following ports pointed to the server and open during testing:  
TCP: 1723, 50, 51
UDP: 500, 4500

Error Message (PPTP)
When I try to connect from my iPad via PPTP when connected to internal wireless, it works.  However, when connected to external internet, it displays "Connecting" for a couple of seconds, "Starting" for about 30 seconds, then fails with the pop up error "A connection could not be established to the PPP server..."

Any suggestions or links that can tell me what I'm doing wrong?  Thanks!
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Is the VPN server's WAN interface using a private IP, and do you have appropriate NAT rules set up on the router for the VPN ports.

L2TP is problematic when the VPN server endpoint is a NAT'd private IP.

Does the router have protocol GRE enabled?

Does RRAS on SBS support Perfect Forward Secrecy?  Try disabling it.

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial