Exchange 2003 and The RPC_S_SERVER_UNAVAILABLE error (0x6ba) was thrown by the RPC Runtime process

jettanitegb
jettanitegb used Ask the Experts™
on
This is similar to the issue this user is having:

EE

I have Exchange 2003 running on a Single Server (not a DC)  I have 2 DC's one is a 2003 Server, the other is a 2008 R2 Server.

We are migrating from Exchange 2003 to Office 365.  Using the TES tool, I am getting the The RPC_S_SERVER_UNAVAILABLE error (0x6ba) was thrown by the RPC Runtime process. error.

I have searched the internet...did the registry change for the ports on Exchange and the port on the DC's.  No firewall on the servers, even uninstalled and reinstalled the RPC components on Exchange and same errors.

Here are some links to things I tried (and did not resolve)
http://social.technet.microsoft.com/Forums/en-US/exchangesvrgeneral/thread/2b061c75-faa0-4951-ba79-99186f62d5f4

http://forums.whirlpool.net.au/archive/1766383

http://www.petri.co.il/how-can-i-configure-rpc-over-https-on-exchange-2003-single-server-scenario.htm

I am stuck....I searched the rest of Experts Exchange also, I found similar issues, but those didn't fix my error either.

Thanks in advance
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Alan HardistyCo-Owner
Top Expert 2011

Commented:
Did you use the rpcnofrontend.zip tool in the Petri Article you linked to?

Is internal DNS working happily on your server(s)?

Have you installed and run the Exchange 2003 Best Practises Analyzer tool?

http://www.microsoft.com/download/en/details.aspx?displaylang=en&id=5334

Author

Commented:
Yes I did all those things....
Alan HardistyCo-Owner
Top Expert 2011

Commented:
Can you re-run the tool and post the entries that you set in the registry please.

Author

Commented:
Here are the registry entries:

mail02:100-5000;mail02:6001-6002;mail02.x.com:6001-6002;file02:6001-6002;file02.x.com:6001-6002;mail02:6004;mail02.x.com:6004;file02:6004;file02.x.com:6004;file02:593;file02.x.com:593;mail02:593;mail02.x.com:593;mail.x.com:593

I changed the domain name to "x" to hide my shame!

As far as Best Practices, what are you looking for there?
Alan HardistyCo-Owner
Top Expert 2011

Commented:
The way I see it, you should have the following in HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Rpc\RpcProxy

mail02:6001-6002;mail02.internaldomain.local:6001-6002;mail02.externaldomain.com:6001-6002;mail02:6004;mail02.internaldomain.local:6004;mail02.externaldomain.com:6004

Please re-run the rpcnofrontend tool and correct the values to reflect the correct settings and then test again.

Author

Commented:
The internal domain and external domain are the same.
Alan HardistyCo-Owner
Top Expert 2011

Commented:
Okay - so please use the tool again and set the registry entries accordingly.  You have too many at the moment and that's confusing the hell out of Exchange.

You should therefore have:

mail02:6001-6002;mail02.domain.com:6001-6002;mail02:6004;mail02.domain.com:6004

Author

Commented:
I thought I needed the domain controller listed in there also....that's what the file02 entry is...

Author

Commented:
OK...made the reduced registry changes, restarted the Exchange System Attendant (includes most Exchange Services), and tested remote connectivity and...

same error.
Alan HardistyCo-Owner
Top Expert 2011

Commented:
The guide you need to be following is this one:

http://technet.microsoft.com/en-us/library/bb124671(v=exchg.65).aspx

Please check through steps 1-5 and make sure you have everything in place correctly.

Off to do some cycling - back in 10 miles!

Author

Commented:
Done that...yes there are in place...
I appreciate the help and follow up, but like I said, I have been hammering on this for quite a while....
Alan HardistyCo-Owner
Top Expert 2011

Commented:
Right - 10 miles covered!

Okay - been a while since I did a multi-site server environment and refreshing my brain has helped I think.

Registry keys need to be:

mail02:100-5000;mail02:6001-6002;mail02.domain.com:6001-6002;file02:6001-6002;file02.domain.com:6001-6002;mail02:6004;mail02.domain.com:6004;file02:6004;file02.domain.com:6004;mail.domain.com:6001-6002;mail.domain.com:6004;file02:593;file02.domain.com:593;mail02:593;mail02.domain.com:593;mail.domain.com:593;
Alan HardistyCo-Owner
Top Expert 2011

Commented:
What do you have set in the registry here:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\NTDS\Parameters

Is the name on your SSL certificate mail.domain.com?

Author

Commented:
Change reg entries back.

That other reg entry (NTDS) is only on the DC's and this is the data: ncacn_http:6004

The SSL Cert is mail.x.com (again x being the actual domain)
Alan HardistyCo-Owner
Top Expert 2011

Commented:
Did you change the registry key to the post above?  I modified it after posting it initially.

Author

Commented:
Yes, I changed them back to the settings I had originally in my earlier post.

Btw....the RPC error is still there...
Alan HardistyCo-Owner
Top Expert 2011

Commented:
Okay - that's what I thought.  My comment here:

http:#a37858597

Has different registry settings. Please copy / paste the settings from this comment to your server and then try the test site.

Author

Commented:
Ok....made the change, restarted Exchange services, restarted IIS (for good measure)
and
Same error....

Author

Commented:
Anyone else have any input or ideas?  I DO appreciate the help....
Update....

Configured Outlook 2010 to use RPC over HTTPS and it works (this is an internal PC)  One note is I had to set Basic Auth, as NTLM Auth didn't work.

Author

Commented:
No Solution given

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial