SBS DHCP issues

MckAndrew
MckAndrew used Ask the Experts™
on
I am migrating to an sbs 2011 server from a sbs 2003 domain , i am not taking any of the AD settings, however i wanted to make a smooth transition, and thought if i shut down DHCP on the original server I could then add new clients which would join the new domain .
My problems arose when i set up the new scope only to find that the new server DHCP service shutdown with the following message;
"The DHCP service has detected that it is running on a DC and has no
credentials configured for use with Dynamic DNS registrations
initiated by the DHCP service.   This is not a recommended security
configuration.  Credentials for Dynamic DNS registrations may be
configured using the command line "netsh dhcp server set
dnscredentials" or via the DHCP Administrative tool."

When i saw this i checked the DHCP service and found that it had stopped , I then ran "Fix my network wizard" this reported that there was another device which was acting as a DHCP server. I checked the network and the router DHCP router has been disabled, as i mentioned the original SBS 2003 server DHCP had been disabled. and there are no other devices other than workstations. i thought it might be something to do with IP6 as i only configured the IP4 scope on the new server. I am currently stumped but it might be obvious to someone out there ?

Confused
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®

Commented:
So what was serving your address previously?
Distinguished Expert 2018

Commented:
Between SBS 2008 and 2011, I have worked on hundreds of servers and I've *never* seen the DHCP service give that error as a false positive. Every time it happens, I've been able to find another DHCP server on the network. Wireshark or Netmon may help you find it.

Author

Commented:
Hi Geodash,
         The Old SBS 2003 server originally provided DHCP for the domain,

Hi Cgaliher,
                I tried a few more changes.... as it was after hours i removed all devices from the switch leaving only the router and the new SBS 2011 server online, here are the results;
when i run the "fix my network wizard" it reports 4 issues

1. primary DNS server is not configured correctly

2. Could not configure the router

3. DHCP is not configured correctly

4.The Internet Domain name is not configured

by the way i do have internet access from the server

I have done so far in relation to those points
1 checked the DNS provided by the ISP and placed that in the Nic on
the server (212.159.13.49 & 212.159.13.50) the router IP Lan side is
192.168.5.10

2 this error states that it cannot configure the router and that i
should open the required ports. I have opened the required ports (25,
443, 987, 80) and tested by using an external web port checker and
they are confirmed as open. and i still get this error message ?

3 I configured DHCP for the scope needed and it has supplied ip's to
devices on the network and states that it is active ?

4. I guess i need to run the wizard but this is the only portion i do
not understand clearly.
C++ 11 Fundamentals

This course will introduce you to C++ 11 and teach you about syntax fundamentals.

Distinguished Expert 2018
Commented:
You've misconfigured DNS. SBS SHOIOD only poi t to itself for DNS on the NIC properties. The DNS server that is running on the SBS will answer any DNS queries, even ones originating from the ASbs Server itself.

#2 is a warning, not an error. It will throw the warning if UPnP is disabled on the router so you know to open the ports manually. There is no way for the wizard to test if the ports are open though since many firewalls allow you to configure inbound and outbound rules separately and the server is on the LAN side. So the wizard will ALWAYS throw the warning, it doesn't mean the ports aren't open. It is just an informational message for sysadmins.

#3 the SBS installer preconfigured a scope. You shouldn't be doing this manually.

#4 hopefully now you understand more clearly.

-Cliff
All,
        I have since found the issue there was an issue with the SBS 2003 server, even though i had switched of DHCP of this server, it was still attempting to server IP's soulution remove from network. However their were also some con figuration issues, incorrect settings on the nic.  thank you  Cgaliher.

this has now been resolved

Author

Commented:
No answer was exactly correct the nearest solution was from Cgaliher who gave a partially right response.

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial