Can't write to / create a file: Access Denied

urs_mis
urs_mis used Ask the Experts™
on
I've got a user that I'm working with who needs "HEC Georas 10.0" installed. However, when I run the installation, it says that it can't write to "1.txt" and I should check and make sure that I have permissions to write to the directory. Apparently the installer creates a bunch of txt files in that folder.

Well, I went to the folder and verified that I have file permissions. I even created a text file there. However (here's the odd part), I cannot create a text file named "1.txt". I get an access denied error. I can create 2.txt or 3.txt but not 1.txt. I have verified that there are no hidden files there with that name.

Then I tried creating the 1.txt file in another directory (such as my desktop). No dice. Same error. I had it tried on two other xp machines, one of which was in a completely different office. Same error. Any idea what could be going on here? I'm a bit confused because 1.txt doesn't seem like it should be a reserved name (I can create files like 1.bmp just fine).

Thanks.
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Chris BRetired

Commented:
Hypothesis - any (text) file with a long name - more than 8.3 will be seen by dos as xxxxxx~1.txt and I suspect this is the issue. Not sure how to fix this though. You should be able to write 1.txt into an empty directory, but this might not resolve your issue. I would be contacting the publisher for a fix.

The XP file name total length as I recall is 256 characters including slashes etc, so if your folder structure has long names, this could be the problem. Try starting the installation from c:
Just might fix it.

Chris B
Hi urs_mis,

maybe some antivirus/antispam software installed on that machines is the cause. Searching the web I found there seems to exist malware which is sent via email as 1.TXT:
http://r.virscan.org/85adcf44f4588b661e8de6f35c608ef4
http://www.joewein.de/sw/spam-1-txt.htm

Try to temporary deactivate the antivir/antispam software running for installing. But, allthough if my guess it right and this may help installing it might be that after antivir/antispam software is turned on again access again is restricted for this file so the installed software maybe doesn't work correctly. If so I think you can either try to exclude that file from the antivir/antispam scanner if possible or use another antivir/antispam software.

Hope that helps,

ZOPPO
Top Expert 2013

Commented:
urs_mis--You say you have no hidden files.  But have you checked the box "Hide Protect operating system files" in Control Panel|Folder Options|View tab?
If so, uncheck it, click Yes on the warning box|Apply.
Now can you find 1.txt in that folder?
If so, rename it (like 1.old) and see if you can install the program.
Introduction to R

R is considered the predominant language for data scientist and statisticians. Learn how to use R for your own data science projects.

Author

Commented:
@burrcm- No dice. The file path isn't a long one, and even when I create a new empty folder I still can't create that text file. We're trying to get ahold of the publisher, but I'm not too optimistic about that.

@Zoppo- I'll try that and let you know if that fixes it.

@jcimarron- I did that, and I found some system folders, but no files.

Just as an update, I was finally able to create a 1.txt file on another, freshly built XP machine, so I'm not sure what is going on here.
Top Expert 2013

Commented:
urs_mis--HEC Georas 10.0 is an "Early Access Preview" .  I do not know if that is part of the problem.
Look in Control Panel|Add/Remove and see if is shown there.  If so remove it and try to reinstall again.
There may be a problem with the downloaded installation file.  Are you using this one
http://www.hec.usace.army.mil/software/hec-ras/hec-georas_downloads.html  ?


Is HEC Georas 10.0 compatible with Win XP?

Author

Commented:
It should be. We have other users running it on XP (which makes it all the stranger).

Author

Commented:
I disabled the antivirus and everything installed. Thanks for the help.

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial