Import Calendar from PST with New-MailboxImportRequest

Svet Paperov
Svet Paperov used Ask the Experts™

I have some troubles with New-MailboxImportRequest cmdlet trying to import the Calendar items only.

For example, the following cmdlet works as expected and everything is imported (mails, calendar items, etc.):

New-MailboxImportRequest -Mailbox Testuser1 -FilePath \\BACKUPSERVER\PST\TestUser1\Outlook.pst

However, if I try to import calendar folder only by using the following cmd (as in the Exchange help), nothing is imported:

New-MailboxImportRequest -Mailbox Testuser1 -FilePath \\BACKUPSERVER\PST\TestUser1\Outlook.pst -IncludeFolders "#Calendar#"

It goes in Queued as usual:
Name                          Mailbox                                        Status
----                                -------                                        ------
MailboxImport5          xxxxxxxxxxxxx.local/xxxx/xxxxxxxx/Test Users/... Queued

I monitor the importing process with
Get-MailboxImportRequest | Get-MailboxImportRequestStatistics | ft TargetAlias,Percent*,BytesTransferred*

For several minutes it shows
TargetAlias                                 PercentComplete BytesTransferred              BytesTransferredPerMinute
-----------                                          --------------- ----------------                                    -------------------------
testuser1                                            0

TargetAlias                                 PercentComplete BytesTransferred              BytesTransferredPerMinute
-----------                                          --------------- ----------------                                    -------------------------
testuser1                                            100 0 B (0 bytes)

… and nothing is imported in the mailbox calendar.

Get-MailboxImportRequest -Identity "Test User 1\MailboxImport5" | fl returns Completed status:
RunspaceId     : 99b881ca-ba9b-4462-83a1-36f9ea1126a4
FilePath       : \\BACKUPSERVER\PST\TestUser1\Outlook.pst
TargetDatabase : Mailbox Database 2
Mailbox        : xxxxxxxxxxxxxxx.local/xxxx/xxxxxxxxx/Test Users/Test User 1
Name           : MailboxImport5
RequestGuid    : 144854f8-f9f6-46e5-9168-fdb34a039c8e
RequestQueue   : Mailbox Database 2
Flags          : IntraOrg, Pull
BatchName      :
Status         : Completed
Protect        : False
Suspend        : False
Direction      : Pull
RequestStyle   : IntraOrg
OrganizationId :
Identity       : xxxxxxxxxxxxxxx.local/xxxx/xxxxxxxxx/Test Users/Test User 1\MailboxImport5
IsValid        : True

The solution from the following thread doesn’t work for me:

I am using Exchange Server 2010 SP2 Update Rollup 1.

Any suggestions, please?
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®

Have you tried opening that PST with Outlook and manually Drag-n-Drop the items in question to ensure that the Exchange system will accept them?   That of course is not a solution, but I would validate that that you can successfully do so via the manual method first because I have seen some odd things happen with calendar items being imported.  Once imported if you can visually see them do a refresh as well because I have also seen items restore and seconds later Exchange removes them
Svet PaperovIT Manager


Hello  lucid8,

Yes, this method works but this is not the solution I am looking for.

As I said, if I import the whole PST, without using the IncludeFolders parameter, it imports everything, including the Calendar. But, if I select the calendar only with IncludeFolders parameter it doesn’t import it.

It seems to me there is something wrong with the syntax but it is the same as in the help of New-MailboxImportRequest cmdlet on

Thanks for the input

The entires you have look correct, however, have you tried it without the #, I think that's only need if you are outside the U.S. so that it can find the equivalent base folder.  Would be interesting to see if it reacts the same

New-MailboxImportRequest -Mailbox Testuser1 -FilePath \\BACKUPSERVER\PST\TestUser1\Outlook.pst -IncludeFolders "Calendar"
How to Generate Services Revenue the Easiest Way

This Tuesday! Learn key insights about modern cyber protection services & gain practical strategies to skyrocket business:

- What it takes to build a cloud service portfolio
- How to determine which services will help your unique business grow
- Various use-cases and examples

Svet PaperovIT Manager


Yes, tried that as well with the same result, no import.

And tried

New-MailboxImportRequest -Mailbox Testuser1 -FilePath \\BACKUPSERVER\PST\TestUser1\Outlook.pst -IncludeFolders "#Calendar#/*"

also without success.


Have you tried this same command with say the #Inbox# to determine if its something with the specific folder vs the command?

How about these?

New-MailboxImportRequest -Mailbox Testuser1 -FilePath \\BACKUPSERVER\PST\TestUser1\Outlook.pst -IncludeFolders "#Calendar#\*"

New-MailboxImportRequest -Mailbox Testuser1 -FilePath \\BACKUPSERVER\PST\TestUser1\Outlook.pst -IncludeFolders "Calendar\*"
Svet PaperovIT Manager


Hi there,

Some development on my question:

I didn’t notice that I was working with a French language PST file where Calendar is “Calendrier” and I was importing it in an English language Exchange mailbox. However, the #Calendar# syntax should be able to deal with that.

I remember having a similar problem when importing French language PST in an English language PST: in that case I had to export the calendar only and import it in the Calendar folder of the new PST.

So, the only way I am able to import “le calendrier” in exchange mailbox is with:

New-MailboxImportRequest -Mailbox Testuser1 -FilePath \\BACKUPSERVER\PST\TestUser1\Outlook.pst -TargetRootFolder "Calendar" -IncludeFolders "Calendrier"

But, in that case a new Calendar named “Calendrier” is created inside the mailbox calendar: not the solution I was looking for.

I will do some more tests tomorrow with English-to-English and French-to-French imports but I think they should work without any problem.


interesting and yes you are correct that the whole purpose of #Calendar# is to deal with normalizing the actual name of the Calendar folder which differs in actual container name by language.   Odd, but great info and I look forward to hearing if you find a resolution
Svet PaperovIT Manager


Hi there,

I did some more tests and the results are not good at all: #...# does not working.
In order to eliminate the language factor I’ve tested the import of an English PST into an English Mailbox. I’ve also tested Calendar and Inbox. In both cases:

- IncludeFolders “Calendar” and  - IncludeFolders “Inbox” worked, but

- IncludeFolders “#Calendar#” and  - IncludeFolders “#Inbox#” did not (100 % completed, 0 bytes impoted)

My results are in consistency with the solution in the link I’ve mentioned in the question. However, that solution does not use #...#, it uses the real names instead which vary with the language.

Did anybody else have a similar experience?

You are patched on all Exchange servers up to SP2 RU1, correct?
Svet PaperovIT Manager



Very odd, indeed....
IT Manager
Hello again,

Some follow up: I patched my Exchange Server 2010 SP2 up to the new RU2 but it did not fixed the # # problem.

Even if we've decided not to import the Calendar altogether because of other issues, I am still curious why the name normalization of the standard folders doesn't work. So, I will keep the question open for now, hopping for comments from other experts.

Svet PaperovIT Manager


We didn't find a solution but a workarround.

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial