Remote Desktop connection Protocol and compression problems

makinglifeezy
makinglifeezy used Ask the Experts™
on
I am hoping someone may have come across this issue as we have been working on it for over 4 months now.

We have a terminal server (Win2k8) all remote users working from a Windows XP computer do not have this issue, it has been since we purchased some Windows 7 PRO notebooks this issue has developed. We first thought it could have been something to do with 64bit edition of windows so this was changed to 32bit with the same issue still persisting.

Whilst connected to RDP we are getting getting sessions that just freeze up and popup a dialogue box saying reconnecting (this mainly happens if it is minimized then maximized), also more often are recieving a protocol error or decompression error.

Again this only seems to happen to users that have a Windows 7 notebook, we have been banging our heads againtst the wall trying to work this out.
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Terminal server and terminal client communicate by following the RDP protocol. This protocol compresses and encrypts data to save network bandwidth and improve security. According to the error message, it seems that there are some network issues so the client would not decompress the package.

 

To isolate the root cause, please perform the following tests to see whether this problem exists in these scenarios:

 

1.       Establish a remote desktop connection from the problematic server to itself. Can you connect properly? If it works, the terminal service on the server should be working.

2.       Establish a remote desktop connection from a client which is in the same LAN as the problematic server. Can you connect properly? If it works, the problem may lies in the routers and the network that between the server and the client.

 

Meanwhile, please check the following:

 

1.       It was reported that some network adapters which has TCP/IP offload enabled may cause this issue. For example, if you have Broadcom NetXtreme NIC, we should ensure that the “IPv4 Large Send Offload option” for the NIC is turned off.

2.       Disable TCP and IP checksum offloading on network adapter.

3.       Update the NIC driver on the server.

4.       On the server, run the following commands to disable advanced network features to test again:

 

-          Run the following commands one by one:

 

netsh int tcp set global RSS=disabled

netsh interface tcp set global autotuninglevel=disabled

netsh int tcp set global chimney=disabled

 

-          Reboot the server to test.

 

5.       Set the encryption level to Low.

 

-      Open the Terminal Services Configuration snap-in.

-      Right click the "RDP-Tcp" connetion item, and click Properties.

-      In the General tab, select "Low" in the "Encryption level" list box, and click OK.


Hope this helps.
I found the issue to be problems with a particular network card driver.

Author

Commented:
I had found the above mentioned steps and covered all these already.

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial