Copy Selected As Table Fails to Paste

mcjann
mcjann used Ask the Experts™
on
Need respone urgently as this outcome is unexpected during execution of a protocol.

Have a view with columns that match the columns in an Excel spreadsheet.

After selecting 2000 documents and using the native LN function "Copy Selected as Table" some of the documents do not paste into the spreadsheet.

To identify the dropped rows I took an export using Lotus Script and all 2000 records pull in the Excel sheet generated. Then I did a look up to the list generated by manual copy/paste function to identify the docs that did not paste. There are 59 docs now isolated to a folder but I see no common thread to cause a failure. When I take the same 59 (in the folder) and select them and perfrom Copy Selected as Table they all come over when pasted. When I switch to the designated view with the same docs selected again they all come over.

During execution of a protocol the tester is extracting records 2000 at a time so I thought it could be a clipboard thing. But a second user with a clear clipboard and fresh launch of the database gets the same result on the range of numbers reported by tester.

Any ideas . . .
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Sjef BosmanGroupware Consultant

Commented:
First off: I have no clue. what are the versions of Windows, Excel and Notes you're using?

To eliminate one of the players: can you try with OpenOffice Calc, just to see if you get similar issues?

Author

Commented:
Sorry I left out the SW versions: Windows XP Professional 2002, Excel 2007 and LN Client 7.

What is OpenOffice Calc?
Sjef BosmanGroupware Consultant

Commented:
It's a free alternative to the MS Office suite. Download from here: http://www.openoffice.org/
I've seen similar issues from time to time.
Try to close Notes Client, delete cache.ndk and rebuild database view indexes.

I rely on "copy as table" only when I can easily visually identify if something is missing otherwise I use scripts to populate Excel from Lotus Notes.  
The thing is that "copy as table" relies on too many things to always work properly (Lotus Notes client health, Clipboard status and other running programs etc)
Commented:
Downloading any software is not possible in our highly controlled computing environment.

I was able to get a successful paste into MS Word where I could take a look at the items the did not paste into Excel. I found that there were two groups of sequential records (25 in the first and 34 in the second) that did not paste. Although there was no common thread the record immediately proceeding the first failed record was found to have double quotation marks (i.e. "") in a column value that is displaying the last 2 entries in a multi string field. Excel, for whatever reason doesn’t like that. The workaround for the issue was to drop the offending data column (with the double quotation marks) using the customize view option. That same column was dropped from the Excel spreadsheet. The formulas automatically adjusted, and the column dropped in not critical to the verification process.

Thanks for the suggestion and the issue has been resolved.

Commented:
Hi there ,,,

In fact, when I have such a similar problem ,the only way I am doing it as you mentioned is through MS word or a wordpad....

But are you getting any errors over here ?? please check evenviewer then select application

one more thing to mention is can you try it on an other PC or a later version of Lotus notes or  and check


Best Wishes

Author

Commented:
The solution worked

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial