IIS Authentication website not working sometimes

lapucca
lapucca used Ask the Experts™
on
Hi,
I put a site in IIS 7 to Enable Windows Authentication and all others are disabled.  The problem now is for some users like me, it works when I go to the site from my home and I authenticated by supplying my domain credential but when I go to the site from my work pc where I already logged into the domain then it pops up the log in dialog but when I hit submit it just comes right back to me 3 times and then it wont' log me in and give me the following error.  Is there any place I should check that could be causing this?  Or this is some AD or Network issue?  Thanks

401 - Unauthorized: Access is denied due to invalid credentials.
You do not have permission to view this directory or page using the credentials that you supplied.
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Kent DyerIT Security Analyst Senior
Commented:
Most likely when you login from home, you are using a VPN which means you login with a pseudo or sub-credentials.  When you login at the office, you login as domain\jdoe.  Even with your vpn, you are still logging in as domain\jdoe, but it maybe preceded with vpn_jdoe or something like that.  When you are logged in from home, go to a command (CMD) prompt and type in set to review the user/computer variables.

HTH,

Kent

Author

Commented:
No, I'm sorry that I wasn't clear.  I didn't log into vpn when at home.  It just pops up the login dialog window and authenticate the person in our AD.  Once the user is authenticated the it runs through my php code at this site and is redirected to another site.  The problem is that this only work for people that aren't using the work PC where they're already logged into the domain.
Top Expert 2011
Commented:
Hello,

When your website prompt you can try with one of the following combination to authenticate against AD.

domain\username
username@domain

If still not working you may need to enable basic authentication on your website.

Regards,
Sanjay Santoki
Commented:
Have you added it as a trusted site?

Author

Commented:
The problem only happens in IE as I come to find out later.  The problem is then resolved by moving up NTLM in the provider list in IIS

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial