Integration between Exchange and Lync

Mohammed Hamada
Mohammed Hamada used Ask the Experts™
on
I'm trying to integrate Exchange unified messaging role with Lync and i don't know why when running the tool mentioned in Jeff Scher'z blog below it doesn't find any dial plans.

Using the Exchange Management Shell execute the exchucutil.ps1 script located in the Exchange Server’s Scripts directoJeff Schertz Linkry, as shown in the path below.

Here's what I get when I run the tool.


[PS] C:\Program Files\Microsoft\Exchange Server\V14\Scripts>.\ExchUCUtil.ps1

Using Global Catalog: GC://DC=mydomain,DC=com

Configuring permissions for mydomain.com\RTCUniversalServerAdmins ...
mydomain: The appropriate permissions have been granted for the Office Communications Servers and Administrators to be
able to read the UM dial plan and auto attendants container objects in Active Directory. No new permissions have been ad
ded to the container objects.
UM DialPlan Container: The appropriate permissions have been granted for the Office Communications Servers and Administr
ators to be able to read the UM dial plan and auto attendants container objects in Active Directory. No new permissions
have been added to the container objects.
UM AutoAttendant Container: The appropriate permissions have been granted for the Office Communications Servers and Admi
nistrators to be able to read the UM dial plan and auto attendants container objects in Active Directory. No new permiss
ions have been added to the container objects.

Configuring permissions for mydomain.com\RTCComponentUniversalServices ...
mydomain: The appropriate permissions have been granted for the Office Communications Servers and Administrators to be
able to read the UM dial plan and auto attendants container objects in Active Directory. No new permissions have been ad
ded to the container objects.
UM DialPlan Container: The appropriate permissions have been granted for the Office Communications Servers and Administr
ators to be able to read the UM dial plan and auto attendants container objects in Active Directory. No new permissions
have been added to the container objects.
UM AutoAttendant Container: The appropriate permissions have been granted for the Office Communications Servers and Admi
nistrators to be able to read the UM dial plan and auto attendants container objects in Active Directory. No new permiss
ions have been added to the container objects.

Configuring UM IP Gateway objects...
Pool: LYNCFE.mydomain.com
A UMIPGateway already exists in Active Directory for the Office Communications Server Pool. A new UM IP gateway wasn't c
reated for the Pool.
IsBranchRegistrar: False

MessageWaitingIndicatorAllowed: True
OutcallsAllowed: True
WARNING: The command completed successfully but no settings of '1:1' have been modified.
There are no SIP URI dial plans that can be associated with the UM IP gateway that is used for the Office Communications
 Server pool.

Permissions for group mydomain.com\RTCUniversalServerAdmins

ObjectName                              AccessRights                            Configured
----------                              ------------                            ----------
mydomain                               ListChildren                            True
UM DialPlan Container                   ListChildren, ReadProperty              True
UM AutoAttendant Container              ListChildren, ReadProperty              True


Permissions for group mydomain.com\RTCComponentUniversalServices

ObjectName                              AccessRights                            Configured
----------                              ------------                            ----------
mydomain                               ListChildren                            True
UM DialPlan Container                   ListChildren, ReadProperty              True
UM AutoAttendant Container              ListChildren, ReadProperty              True



PoolFqdn                                UMIPGateway                             DialPlans
--------                                -----------                             ---------
LYNCFE.mydomain.com                  1:1                                     {(not found)}

-

Any help is appreciated
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®

Commented:
I suppose the first thing to do is to see what dialplans exchange knows about. If you issue a  

get-umdialplan

command from an Exchange Powershell prompt what does it return. You might want to check the on-line exchange docs at:-

http://technet.microsoft.com/en-us/library/gg398129.aspx

I assume that you have a matching dial-plan names between Lync and Exchange to route the calls? Did you enable UC on any users, it says you need to do that before running ExchUCUtil.ps1

What dial plans are in Lync?
Senior IT Consultant
Commented:
@g4ugm,

Thanks for your comment but I got it solved, just for your information the dial plans in Exchange has nothing to do with the ones in Lync!

I solved it by simply deleting the dial plans in exchange and re-created them! Then I used the script .\ExchUCUtil.ps1 in exchange management shell. it shows the dial plan and created it.

Then I went on lync to the UM integration tool which is located in your Lync Front End server in directory path:
C:\Program Files\Common Files\Microsoft Lync Server 2010\Support\OcsUmUtil.exe

According to Jeff schert's article, each of SA and AA should have their own numbers assigned from the gateway! so I assigned two numbers and added them using this integration tool.

After that I could see in the event log that there's a problem with TLS connection since LYNC requires Secured connection as I read in one of the articles, so it should use either a public certificate or a CA trusted but not self signed.

So I used the following command to generate an exportable certificate key from Exchange server:

Set-Content -path ".\UMG.txt" -Value (New-ExchangeCertificate -GenerateRequest -KeySize 2048 -SubjectName "c=CountryHere, s=ProvinceHere, l=CityHere, o=CompanyNameHere, ou=DepartmentNameHere, cn=CertificateNameHere"  -PrivateKeyExportable $True)


Now this command will generate a key which you will find on your C root drive in a text file format. If you would like to use the same command you should be able to but you need to remove all fields with their relevant information e.g. "CountryHere remove it with Your country".

Now you need to browse to your MS Certificate Authority server from exchange using this format: https://servername/certsrv 

This format didn't work for me even though it's the usual format, I had to browse using the IP address and without secured http.

Now click on
1- Request a certificate
2-  advanced certificate request
3-  Submit a certificate request by using a base-64-encoded CMC or PKCS #10 file, or submit a renewal request by using a base-64-encoded PKCS #7 file.
4-  Paste your CSR (TextFileContent) ino the cert request area and change your Certificate Template to "Web Server"
7.  Download your Certificate

Note: You should allow Active X content in your IE to get the download option for the new Certificate.

Import the certificate into Trusted Root Certification authorities on Exchange server.
Goto Exchange Console, Under Microsoft Exchange on-premisis, Goto Server Configuration and locate the last certificate "usually on top of the exchange certificate list" Double click on it and click Complete pending and browse to the certificate location then click complete.

Now Assign all the services that you'd like to have for Exchange.

Commented:
No objections
Mohammed HamadaSenior IT Consultant

Author

Commented:
Self Managed!

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial