We help IT Professionals succeed at work.

apt-get install - 404 not found

tonelm54
tonelm54 used Ask the Experts™
on
Ive been trying to install curlftpfs onto one of my ubuntu servers, but when I try and install I just get 404 Not Found.

What im donig is typing "sudo apt-get install curlftpfs", which returns:-
sudo apt-get install curlftpfs
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages were automatically installed and are no longer required:
  ssl-cert
Use 'apt-get autoremove' to remove them.
The following NEW packages will be installed
  curlftpfs
0 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
Need to get 30.2kB of archives.
After this operation, 115kB of additional disk space will be used.
WARNING: The following packages cannot be authenticated!
  curlftpfs
Install these packages without verification [y/N]? y
Err http://gb.archive.ubuntu.com jaunty/universe curlftpfs 0.9.2-1
  404 Not Found
Failed to fetch http://gb.archive.ubuntu.com/ubuntu/pool/universe/c/curlftpfs/curlftpfs_0.9.2-1_i386.deb  404 Not Found
E: Unable to fetch some archives, maybe run apt-get update or try with --fix-missing?

When I try and run "sudo apt-get update", I get:-

Ign http://gb.archive.ubuntu.com jaunty Release.gpg
Ign http://security.ubuntu.com jaunty-security Release.gpg
Ign http://gb.archive.ubuntu.com jaunty/main Translation-en_GB
Ign http://security.ubuntu.com jaunty-security/main Translation-en_GB
Ign http://gb.archive.ubuntu.com jaunty/restricted Translation-en_GB
Ign http://security.ubuntu.com jaunty-security/restricted Translation-en_GB
Ign http://gb.archive.ubuntu.com jaunty/universe Translation-en_GB
Ign http://security.ubuntu.com jaunty-security/universe Translation-en_GB
Ign http://gb.archive.ubuntu.com jaunty/multiverse Translation-en_GB
Ign http://security.ubuntu.com jaunty-security/multiverse Translation-en_GB
Ign http://gb.archive.ubuntu.com jaunty-updates Release.gpg
Ign http://security.ubuntu.com jaunty-security Release
Ign http://gb.archive.ubuntu.com jaunty-updates/main Translation-en_GB
Ign http://security.ubuntu.com jaunty-security/main Packages
Ign http://gb.archive.ubuntu.com jaunty-updates/restricted Translation-en_GB
Ign http://security.ubuntu.com jaunty-security/restricted Packages
Ign http://gb.archive.ubuntu.com jaunty-updates/universe Translation-en_GB
Ign http://security.ubuntu.com jaunty-security/main Sources
Ign http://gb.archive.ubuntu.com jaunty-updates/multiverse Translation-en_GB
Ign http://security.ubuntu.com jaunty-security/restricted Sources
Ign http://gb.archive.ubuntu.com jaunty Release
Ign http://security.ubuntu.com jaunty-security/universe Packages
Ign http://gb.archive.ubuntu.com jaunty-updates Release
Ign http://security.ubuntu.com jaunty-security/universe Sources
Ign http://gb.archive.ubuntu.com jaunty/main Packages
Ign http://security.ubuntu.com jaunty-security/multiverse Packages
Ign http://gb.archive.ubuntu.com jaunty/restricted Packages
Ign http://security.ubuntu.com jaunty-security/multiverse Sources
Ign http://gb.archive.ubuntu.com jaunty/main Sources
Ign http://security.ubuntu.com jaunty-security/main Packages
Ign http://gb.archive.ubuntu.com jaunty/restricted Sources
Ign http://security.ubuntu.com jaunty-security/restricted Packages
Ign http://gb.archive.ubuntu.com jaunty/universe Packages
Ign http://security.ubuntu.com jaunty-security/main Sources
Ign http://gb.archive.ubuntu.com jaunty/universe Sources
Ign http://security.ubuntu.com jaunty-security/restricted Sources
Ign http://gb.archive.ubuntu.com jaunty/multiverse Packages
Ign http://security.ubuntu.com jaunty-security/universe Packages
Ign http://gb.archive.ubuntu.com jaunty/multiverse Sources
Ign http://security.ubuntu.com jaunty-security/universe Sources
Ign http://gb.archive.ubuntu.com jaunty-updates/main Packages
Ign http://security.ubuntu.com jaunty-security/multiverse Packages
Ign http://gb.archive.ubuntu.com jaunty-updates/restricted Packages
Ign http://security.ubuntu.com jaunty-security/multiverse Sources
Ign http://gb.archive.ubuntu.com jaunty-updates/main Sources
Err http://security.ubuntu.com jaunty-security/main Packages
  404 Not Found
Ign http://gb.archive.ubuntu.com jaunty-updates/restricted Sources
Err http://security.ubuntu.com jaunty-security/restricted Packages
  404 Not Found
Ign http://gb.archive.ubuntu.com jaunty-updates/universe Packages
Err http://security.ubuntu.com jaunty-security/main Sources
  404 Not Found
Ign http://gb.archive.ubuntu.com jaunty-updates/universe Sources
Err http://security.ubuntu.com jaunty-security/restricted Sources
  404 Not Found
Ign http://gb.archive.ubuntu.com jaunty-updates/multiverse Packages
Err http://security.ubuntu.com jaunty-security/universe Packages
  404 Not Found
Ign http://gb.archive.ubuntu.com jaunty-updates/multiverse Sources
Err http://security.ubuntu.com jaunty-security/universe Sources
  404 Not Found
Ign http://gb.archive.ubuntu.com jaunty/main Packages
Err http://security.ubuntu.com jaunty-security/multiverse Packages
  404 Not Found
Ign http://gb.archive.ubuntu.com jaunty/restricted Packages
Err http://security.ubuntu.com jaunty-security/multiverse Sources
  404 Not Found
Ign http://gb.archive.ubuntu.com jaunty/main Sources
Ign http://gb.archive.ubuntu.com jaunty/restricted Sources
Ign http://gb.archive.ubuntu.com jaunty/universe Packages
Ign http://gb.archive.ubuntu.com jaunty/universe Sources
Ign http://gb.archive.ubuntu.com jaunty/multiverse Packages
Ign http://gb.archive.ubuntu.com jaunty/multiverse Sources
Ign http://gb.archive.ubuntu.com jaunty-updates/main Packages
Ign http://gb.archive.ubuntu.com jaunty-updates/restricted Packages
Ign http://gb.archive.ubuntu.com jaunty-updates/main Sources
Ign http://gb.archive.ubuntu.com jaunty-updates/restricted Sources
Ign http://gb.archive.ubuntu.com jaunty-updates/universe Packages
Ign http://gb.archive.ubuntu.com jaunty-updates/universe Sources
Ign http://gb.archive.ubuntu.com jaunty-updates/multiverse Packages
Ign http://gb.archive.ubuntu.com jaunty-updates/multiverse Sources
Err http://gb.archive.ubuntu.com jaunty/main Packages
  404 Not Found
Err http://gb.archive.ubuntu.com jaunty/restricted Packages
  404 Not Found
Err http://gb.archive.ubuntu.com jaunty/main Sources
  404 Not Found
Err http://gb.archive.ubuntu.com jaunty/restricted Sources
  404 Not Found
Err http://gb.archive.ubuntu.com jaunty/universe Packages
  404 Not Found
Err http://gb.archive.ubuntu.com jaunty/universe Sources
  404 Not Found
Err http://gb.archive.ubuntu.com jaunty/multiverse Packages
  404 Not Found
Err http://gb.archive.ubuntu.com jaunty/multiverse Sources
  404 Not Found
Err http://gb.archive.ubuntu.com jaunty-updates/main Packages
  404 Not Found
Err http://gb.archive.ubuntu.com jaunty-updates/restricted Packages
  404 Not Found
Err http://gb.archive.ubuntu.com jaunty-updates/main Sources
  404 Not Found
Err http://gb.archive.ubuntu.com jaunty-updates/restricted Sources
  404 Not Found
Err http://gb.archive.ubuntu.com jaunty-updates/universe Packages
  404 Not Found
Err http://gb.archive.ubuntu.com jaunty-updates/universe Sources
  404 Not Found
Err http://gb.archive.ubuntu.com jaunty-updates/multiverse Packages
  404 Not Found
Err http://gb.archive.ubuntu.com jaunty-updates/multiverse Sources
  404 Not Found
W: Failed to fetch http://security.ubuntu.com/ubuntu/dists/jaunty-security/main/binary-i386/Packages  404 Not Found

W: Failed to fetch http://security.ubuntu.com/ubuntu/dists/jaunty-security/restricted/binary-i386/Packages  404 Not Found

W: Failed to fetch http://security.ubuntu.com/ubuntu/dists/jaunty-security/main/source/Sources  404 Not Found

W: Failed to fetch http://security.ubuntu.com/ubuntu/dists/jaunty-security/restricted/source/Sources  404 Not Found

W: Failed to fetch http://security.ubuntu.com/ubuntu/dists/jaunty-security/universe/binary-i386/Packages  404 Not Found

W: Failed to fetch http://security.ubuntu.com/ubuntu/dists/jaunty-security/universe/source/Sources  404 Not Found

W: Failed to fetch http://security.ubuntu.com/ubuntu/dists/jaunty-security/multiverse/binary-i386/Packages  404 Not Found

W: Failed to fetch http://security.ubuntu.com/ubuntu/dists/jaunty-security/multiverse/source/Sources  404 Not Found

W: Failed to fetch http://gb.archive.ubuntu.com/ubuntu/dists/jaunty/main/binary-i386/Packages  404 Not Found

W: Failed to fetch http://gb.archive.ubuntu.com/ubuntu/dists/jaunty/restricted/binary-i386/Packages  404 Not Found

W: Failed to fetch http://gb.archive.ubuntu.com/ubuntu/dists/jaunty/main/source/Sources  404 Not Found

W: Failed to fetch http://gb.archive.ubuntu.com/ubuntu/dists/jaunty/restricted/source/Sources  404 Not Found

W: Failed to fetch http://gb.archive.ubuntu.com/ubuntu/dists/jaunty/universe/binary-i386/Packages  404 Not Found

W: Failed to fetch http://gb.archive.ubuntu.com/ubuntu/dists/jaunty/universe/source/Sources  404 Not Found

W: Failed to fetch http://gb.archive.ubuntu.com/ubuntu/dists/jaunty/multiverse/binary-i386/Packages  404 Not Found

W: Failed to fetch http://gb.archive.ubuntu.com/ubuntu/dists/jaunty/multiverse/source/Sources  404 Not Found

W: Failed to fetch http://gb.archive.ubuntu.com/ubuntu/dists/jaunty-updates/main/binary-i386/Packages  404 Not Found

W: Failed to fetch http://gb.archive.ubuntu.com/ubuntu/dists/jaunty-updates/restricted/binary-i386/Packages  404 Not Found

W: Failed to fetch http://gb.archive.ubuntu.com/ubuntu/dists/jaunty-updates/main/source/Sources  404 Not Found

W: Failed to fetch http://gb.archive.ubuntu.com/ubuntu/dists/jaunty-updates/restricted/source/Sources  404 Not Found

W: Failed to fetch http://gb.archive.ubuntu.com/ubuntu/dists/jaunty-updates/universe/binary-i386/Packages  404 Not Found

W: Failed to fetch http://gb.archive.ubuntu.com/ubuntu/dists/jaunty-updates/universe/source/Sources  404 Not Found

W: Failed to fetch http://gb.archive.ubuntu.com/ubuntu/dists/jaunty-updates/multiverse/binary-i386/Packages  404 Not Found

W: Failed to fetch http://gb.archive.ubuntu.com/ubuntu/dists/jaunty-updates/multiverse/source/Sources  404 Not Found

E: Some index files failed to download, they have been ignored, or old ones used instead.

I would have thought it could be an internet issue, but it seems to ping google.co.uk fine :-S

So I belive there is an issue with apt-get, but no idea how I can fix it.

Any ideas
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Ubuntu has a release cycle which includes deprecation process.  It looks like Jaunty has been dropped due to its age.  Jaunty's life cycle for support ended in October 2010 and as it is not an LTS version, it has been dropped.  I would advise an upgrade to Lucid (10.04 LTS) which will afford you until 2015 for server version - giving you plenty of time to prepare another upgrade.

https://wiki.ubuntu.com/LTS
http://ubuntuguide.org/wiki/Ubuntu:Jaunty
http://gb.archive.ubuntu.com/ubuntu/dists/ - Jaunty is simply not there any more.

Author

Commented:
Good afternoon,
Any ideas how I can upgrade easily? Im running:-

Linux version 2.6.28-19-server (buildd@vernadsky) (gcc version 4.3.3 (Ubuntu 4.3.3-5ubuntu4) ) #66-Ubuntu SMP Sat Oct 16 18:41:24 UTC 2010

Ive tried to use "sudo apt-get dist-upgrade"

But just get:-

Reading package lists... Done
Building dependency tree
Reading state information... Done
Calculating upgrade... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
It looks like you might have to make a stop at 9.10 (karmic) first, before you can upgrade to 10.04 (lucid).

In the GUI, if you go to System->Administration->Upgrade Manager
what version[s] does it show are available?

Author

Commented:
Im using Ubuntu server :-(
Is a CD drive available for the machine?  If so, then you have the option of mounting the server ISO for the upgrade.

Author

Commented:
I would prefer to do it over the internet, as the serve is running on a remote site.

Is there an idiots guide on upgrading from the internet?
Discovered http://www.snowfrog.net/2009/05/02/apt-sourceslist-for-old-versions-of-ubuntu/ when searching for "ubuntu old repositories".  Turns out ubuntu keeps them all at http://old-releases.ubuntu.com/ubuntu/ & you should be able to change your gb.archive.ubuntu.org references in the sources.list to old-releases.ubuntu.com and then be able to perform the upgrade.  The sources.list lives in /etc/apt/ but make sure you take a backup first!  Once changed, run:

apt-get update

Then attempt:

update-manager --dist-upgrade

Hopefully, that'll get you the on the correct upgrade path.