Windows 7 Network Adaptor Icon

The-It-Pro
The-It-Pro used Ask the Experts™
on
I am running Windows 7 64bit. On some of the machines on my netowrk, the network adaptoor shows an yellow exclamation mark, saying there is no internet access, but there is. When running network diagnostics, its comes up with no errors other than me having to sign up for an ISP. I can connect to the internet from the machine and have no connection issues whatsoever. Any ideas?
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®

Commented:
I would suggest you to completely uninstall then reinstall the Network adapter driver and check if it fixes the issue:

1st Visit the system manufacturer’s website, download and  latest driver and

a.     Type “devmgmt.msc” in start search box and press enter.

b.     Expand the Network adapter.

c.      Right click on the listed driver for  Network and select “Uninstall” (network and wireless if its laptop)

d.     Put a check mark to the box which says “Delete the driver software for this device”.

e.     Click OK.

F.   Restart and install the latest Network drivers.


I would recommend windows 7 running on latest windows updates.
Top Expert 2012

Commented:
Are you sure there isn't more than one network adapter on the machines?  What does device manager show?

Author

Commented:
Hi, i did uninstall and re-install the intel drivers and the OS is updated. As for the 2 NIC's, no, im using only the onboard one. There are no other adaptors in the machine
Build an E-Commerce Site with Angular 5

Learn how to build an E-Commerce site with Angular 5, a JavaScript framework used by developers to build web, desktop, and mobile applications.

Top Expert 2012

Commented:
Did you run spyware removal programs?  Some of them are too aggressive and remove system files they don't recognize.

Author

Commented:
No spyware ran. Mcaffee antivirus. Fuuny thing is , i have 2 or 3 other machines with exact same config and no errors. Quite the random thing.
Try removing/uninstalling the McAfee, its known to cause errors on network services due to its core network service running.

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial