Query Regarding Kickstart installation ks.cfg file

sudhirgoogle
sudhirgoogle used Ask the Experts™
on
Hello,

I have in-house custom made RHEL 5.7 DVD, DVD has ks.cfg, ks_cdrom.cfg and ks_altroot.cfg in it. When i insert the dvd and boot the server it automatically installs RHEL, which ks file has been used by anaconda ? and how do i verify it ?
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Are you seeing any menu before it starts running kickstart.

There should be configuration scripts at a location like
/tftpboot/linux-install/pxelinux.cfg      

You will have to see various files in there because the names are different with each config.  You should see menu and also the file that menu loads.

Also see
/tftpboot/linux-install/msgs

Author

Commented:
there is no such directory exist in DVD disc

Author

Commented:
when i boot from DVD disc, it shows default RHEL installation boot screen ( The Red color screen) with Boot :  at the bottom. when i hit enter it automatically installs Linux, it will not prompt me to enter any information, it does installation automatically and finishes it successfully.

Author

Commented:
Here is my understanding..

1. When i boot from RHEL disc, the bootloader will look for the top-level directory isolinux
2. inside isolinux directory it will look for a file isolinux.cfg
3. It will load the boot screen as per the configuration in isolinux.cfg
4. and in my isolinux.cfg the defualt lable value is mention as cdrom
5. the cdrom label pointed to ks_cdrom.cfg -> that's why this file is used by defualt.

Please look at snapshot attached.

correct me if my understanding is wrong.
isolinux.png
This is exactly correct.  This is the file I wanted to see.  If you don't enter any option at the boot prompt you will go to default.  However, if you chose any other option, it would pick the one picked by you.

Author

Commented:
Thank you very much farzanj. before i close this question and award points just want to clarify one last issue. when i type local in boot prompt i.e Boot: local , it throws error saying " isolinux: disk error 01, ax = 0201, drive 01".

In isolinux.cfg file, the lable local pointed to localboot 1.

Please take a look at the snapshot attached.
boot-local.png
Are you trying to do boot from local disk on the local disk?

Why don't you simply give the path of the ks file.

Also this may help:
http://docs.redhat.com/docs/en-US/Red_Hat_Enterprise_Linux/6/html/Installation_Guide/s1-kickstart2-startinginstall.html

Author

Commented:
I have booted the server from rhel dvd disc in a intention to do installation but later i change my mind and postponed the installation by 1 day,  in this scenario i am at boot: prompt, what is the command to skip the dvd installation and boot from harddrive,  without rebooting the server and removing the dvd disc from cdrom or without altering boot sequence ?

i thought typing 'local' in boot: prompt will boot from harddrive.
Julian ParkerSenior Systems Administrator

Commented:
I have the following in my boot config file;

label local
   localboot 0xffff


you can then have the default set to local but if you want to do anything you need to select it so you should have a decent delay and display the options if possible.

Author

Commented:
thanks for your solution

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial