localhost ping problem

ang31fac3
ang31fac3 used Ask the Experts™
on
Hello, i trying to ping my computer name "ping mycomputername" on cmd, but when i do i only get reply from ipv6.
I all ready tryed to disable ipv6 on my network adapter but nothing happent....
It seems like i dont have ipv4!!
I tryed to use static ip and dns from the router.

i have windows 7 pro and im on a windows 2003 domain
Best regards, please reply ASAP!!
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Top Expert 2012

Commented:
To disable IPv6 please go through this link.

http://support.microsoft.com/kb/929852

Try changing binding order to have IPv4 list first.

http://theregime.wordpress.com/2008/03/04/how-to-setview-the-nic-bind-order-in-windows/

Commented:
So you are trying to ping your own machine from your own machine?

Try to make a dns lookup to see if the DNS can find your computer:

nslookup mymachinename

you can also try setting a static IP address and try to make a tracert to your OWN ip address and see how you are getting through your network.

May I ask why do you want to ping your own machine?

Author

Commented:
nslookup gives:



Server:  UnKnown
Address:  192.168.1.10

Name:    apostolis.dmn.gr
Address:  192.168.1.114
run below command to disable IPV6 completely

reg add HKLM\SYSTEM\CurrentControlSet\Services\Tcpip6\Parameters /v DisabledComponents /t REG_DWORD /d 0xff /f
You can specify a ping using IPv4.

ping 192.168.1.25 -4

Author

Commented:
My problem is that i dont have internet on my network
When i connect to router via wifi from my mobile phone everything its ok
When im trying to connect from a pc-client i dont have internet
The only "strange" thing is the ping reply.
i have all ready use a static ip and i put as dns the router ip

Author

Commented:
when i ping the local computer name i have the problem
with ip directly its ok

Author

Commented:
when i disable the ipv6 i have

Pinging APOSTOLIS.dmn.gr [::1] with 32 bytes of data:
Reply from ::1: time<1ms
Reply from ::1: time<1ms
Reply from ::1: time<1ms
Reply from ::1: time<1ms

Ping statistics for ::1:
    Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
    Minimum = 0ms, Maximum = 0ms, Average = 0ms

Commented:
Okay.

So you have a Internet Access problem.

This must have to do something with your Default Gateway.

Set the Default gateway of your machine and try again.

If you have already done that in the IP static address assignment you can try ping your default gateway.

If that works, then try to ping 8.8.8.8 which is a google dns server, if you get reply from this then you have internet access but a DNS problem.

Let me hear from you.
Did you run the above command from Command prompt.. just reboot and test...


reg add HKLM\SYSTEM\CurrentControlSet\Services\Tcpip6\Parameters /v DisabledComponents /t REG_DWORD /d 0xff /f

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial