Windows 7 My Documents folder

WellingtonIS
WellingtonIS used Ask the Experts™
on
As we are all familiar with the new "style" of windows 7, however my users coming from XP are not.  Windows 7 has a folder on the desktop with the username under in.  In that contains the "My Documents" folder.  When that becomes redirected via GPO it changes to the folder name on the server.  My users aren't that savvy to open up the desktop folder and then the user folder to find and save their docs located on the server.  I fear they will save everything into that folder on the desktop with the user  name and nothing will be on the server.  Besides manually going in an creating a shortcut on the desktop, is there any way to pull that out on to the desktop?  I can see the potential issues with this one.
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
You should remove the Users File Folder shortcut from the desktop and place just a My Documents Shortcut there. You can add shortcuts to the desktop using a GPO.

To add the shortcut to all users desktop
When your GPO Editor windows opens expand to "User Configuration/Windows Settings/Internet Explorer Maintenance/URLs". Double click "Favorites and Links".
Select "Favorites" and click "Add URL". Name it whatever you would like and type file:C:Documents and SettingsAll UsersDesktop into to the URL: field.
Select OK and you're finished.

Author

Commented:
Will this work even if I have the folder being redirected to a server via GPO?
Yes the Server redirect should take over, You can set the Home Directory on the Account instead of using a GPO Folder Redirection.
Acronis in Gartner 2019 MQ for datacenter backup

It is an honor to be featured in Gartner 2019 Magic Quadrant for Datacenter Backup and Recovery Solutions. Gartner’s MQ sets a high standard and earning a place on their grid is a great affirmation that Acronis is delivering on our mission to protect all data, apps, and systems.

Author

Commented:
When I try to add the url. c:\users\public\desktop it's staying specify a valid URL
because you should use the actually username so make it
C:\Users\%username%\Documents

Author

Commented:
Here's what happens when I try...  See attached
error.png
trying removing the c: and just have \users....
It's been a while since i have done this.

Author

Commented:
Tried users\%username%\Documents
\\users\%username%\documents\
\users\public desktop
\\user\public\desktop
None of these worked.
Top Expert 2016

Commented:
syntax
\\servername\users\%username%\Documents
Commented:
I would create Group Policy Preference using Group Policy Management Editor with the following:

User Configuration>Preference>Windows Settings> Shortcuts>(New Shortcut)

Change the shortcut location to Desktop and target path to \\servername\share folder\%username%\My Documents

Author

Commented:
I just tried this on my test machine.  Thax for that.  Hopefully this achieves my goal.

Author

Commented:
that worked.  I just have to solve the prefix part but at least I know it can be done.  thanks.

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial