Cisco Router setup with DSL

ckleavitt2
ckleavitt2 used Ask the Experts™
on
I would greatly appreciate help with an issue setting up  a Cisco 851w router to a DSL provider (birch communications).

 I found a sample config for my IOS version (12.3) and am pasting the config I loaded into the router. However, I am not able to ping outside, and assume the pppoe connection is not occuring. Thank you in advance. The ISP VisionNet DSL modem is in bridged mode.



version 12.3
no parser cache
no service pad
service timestamps debug uptime
service timestamps log uptime
service password-encryption
no service dhcp
!
hostname Router1
!
!
enable secret 5 XXXXXXXXX
no aaa new-model
ip subnet-zero
ip cef
!
ip dhcp pool my-dhcp-pool
   ip dhcp excluded-address 192.168.16.1 192.168.16.99
   ip dhcp excluded-address 192.168.16.150 192.168.16.254
   network 192.168.16.0 255.255.255.0
   default-router 192.168.16.254
   dns-server 4.2.2.2

!!!!! Configure Router as PPPoE Client to the ISP
vpdn enable
!
vpdn-group 1
request-dialin
protocol pppoe
!!!!!
!
!
!
interface vlan1
description My LAN Interface
ip address 192.168.16.254 255.255.255.0
!!!! When NAT/PAT occurs, this interface is the source candidate (inside local)
ip nat inside
!!!!
no ip mroute-cache
no cdp enable
!
interface Ethernet1
description Physical ADSL Interface (Facing the ISP)
no ip address
no ip mroute-cache
!!!! Ties this interface to the Dialer interface
pppoe enable
pppoe-client dial-pool-number 1
!!!!
no cdp enable
!
interface Serial0
no ip address
no ip mroute-cache
shutdown
no cdp enable
!
interface Serial1
no ip address
no ip mroute-cache
shutdown
no cdp enable
!
interface Dialer1
description Logical ADSL Interface
ip address negotiated
ip mtu 1492
!!!! When NAT/PAT occurs, this interface is the destination candidate (inside global)
ip nat outside
!!!!
encapsulation ppp
ip tcp adjust-mss 1452
no ip mroute-cache
!!!!! Ties this logical interface to the proper physical interface
dialer pool 1
!!!!!
!!!!! Passing the protocol allowed by the "dialer-list" command
dialer-group 1
!!!!!
no cdp enable
ppp authentication chap pap callin
ppp chap hostname XXXXXXX@mybirch.net
ppp chap password 0 XXXXXXXXX
ppp pap sent-username XXXXXXXX@mybirch.net password 0 XXXXXXXX
!!!! Default Gateway to the ISP
ppp ipcp route default
!
ppp ipcp dns request accept
ppp ipcp address accept
!
!!!! PAT subnets allowed by the ACL 10
ip nat inside source list 10 interface Dialer1 overload
!!!!
no ip http server
ip classless
!!!!
!
!
!!!! ACL 10 determines which subnet to be PATed
access-list 10 permit 192.168.16.0 0.0.0.255
!!!!
!!!! Determine which protocol to pass through
dialer-list 1 protocol ip permit
!!!!
no cdp run
!
!
!
line con 0
exec-timeout 120 0
stopbits 1
line vty 0 4
exec-timeout 0 0
login local
length 0
!
scheduler max-task-time 5000
end
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®

Commented:
Here is a great step by step guide from Cisco.  Start with the Layer 2 issues section, if you are having issues, post back some of the output so we can help troubleshoot.

http://www.cisco.com/en/US/tech/tk175/tk15/technologies_configuration_example09186a008071a7c2.shtml

Author

Commented:
Thank you for the response. It would really help if someone could confirm whether my general configuration even looks right, or if I am way off. The troubleshooting guide will definitely help once I know I am actually close on the config. Obviously you cant tell me the ISP specific information, which I have (and is confirmed correct). However, does the rest of the config appear to be accurate? The guide link you posted makes mention of ATM, which the guide I used did not mention at all for pppoe (ppp over ethernet). This make me wonder if I have based my configuration off inaccurate info. Thanks.
Garry GlendownConsulting and Network/Security Specialist

Commented:
"show user" should list whether your DSL connection via PPPoE is active (there should be a virtual interface active, e.g. vi1)
The VPDN commands shouldn't be necessary (at least not with any 83x/87x/88x/89x router's I've encountered)
ip mtu 1492 seems pretty large - I'd try with a smaller MTU (we usually have "mtu 1456" configured)
Depending on the IOS version, you may need to use " dialer watch-group 1" instead of "dialer group 1" ...

Apart from that, you should be good  ...
When you do a "term mon" and "debug pppoe events", do you get any output? Especially ones with "PADI" etc.? If, can you post the information?
Introduction to R

R is considered the predominant language for data scientist and statisticians. Learn how to use R for your own data science projects.

TimotiStDatacenter Technician
Top Expert 2012

Commented:
There's no "interface Ethernet1" on the 851. The WAN interface (the one next to the internal 4 port switch) is "interface FastEthernet 4".
Also, there are no serial interfaces on the 851.

Everything else looks fine.

Tamas

Author

Commented:
I have come back to this same issue, when putting in the cisco 851w router with IOS 12.3 Advanced Security, I cannot connect to our DSL provider. I found a template but am still not getting a connection. Here is the new config that is supposed to be for the 851w:

service password-encryption
hostname xxxxxx
enable secret xxx
enable password xxxx
aaa new-model
aaa authentication login default local
aaa authorization exec default local
aaa session-id common
ip http server
ip http secure-server
line con 0
 password xxxx
line vty 0 4
 password xxxx
ip domain name xxx.com
no ip domain lookup
username admin privilege 15 password xxxx
ip dhcp excluded-address 192.168.16.1 192.168.16.99
ip dhcp excluded-address 192.168.16.126 192.168.16.254
ip dhcp excluded-address 192.168.2.1 192.168.2.99
service dhcp
ip dhcp pool Internal-net
   network 192.168.16.0 255.255.255.0
   default-router 192.168.16.254
   import all
   domain-name xxxxx.com
   lease 4
ip dhcp pool VLAN20
   network 192.168.2.0 255.255.255.0
   default-router 192.168.2.1
   import all
   domain-name xxxx.com
   lease 4
vpdn enable
interface Dialer1
 ip address negotiated
 ip nat outside
 ip virtual-reassembly
 encapsulation ppp
 ip tcp adjust-mss 1452
 dialer pool 1
 dialer-group 1
 ppp authentication chap callin
 ppp chap hostname xxxxx@mybirch.net
 ppp chap password xxxxxx
 ppp ipcp dns request
 ppp ipcp address accept
access-list 1 permit 192.168.16.0 0.0.0.255
access-list 1 permit 192.168.2.0 0.0.0.255
dialer-list 1 protocol ip list 1
ip nat inside source list 1 interface Dialer1 overload
ip access-list extended Guest-ACL
 deny   ip any 192.168.16.0 0.0.0.255
 permit ip any any
interface FastEthernet4
 pppoe enable
 pppoe-client dial-pool-number 1
 no cdp enable
ip route 0.0.0.0 0.0.0.0 Dialer1
interface FastEthernet0
 spanning-tree portfast
interface FastEthernet1
 spanning-tree portfast
interface FastEthernet2
 spanning-tree portfast
interface FastEthernet3
 spanning-tree portfast
bridge irb
interface Dot11Radio0
 encryption vlan 1 mode ciphers tkip
 encryption vlan 20 mode ciphers tkip
 ssid xxxxx_Guest
    vlan 20
    authentication open
    authentication key-management wpa
    guest-mode
    wpa-psk ascii xxxxxxx
 ssid xxxxxxx
    vlan 1
    authentication open
    authentication key-management wpa
    wpa-psk ascii xxxxxxx
 channel 1
 no cdp enable
 no dot11 extension aironet
interface Dot11Radio0.1
 encapsulation dot1Q 1 native
 no snmp trap link-status
 bridge-group 1
 bridge-group 1 subscriber-loop-control
 bridge-group 1 spanning-disabled
 bridge-group 1 block-unknown-source
 no bridge-group 1 source-learning
 no bridge-group 1 unicast-flooding
interface Dot11Radio0.20
 description Guest wireless LAN - routed WLAN
 encapsulation dot1Q 20
 ip address 192.168.2.1 255.255.255.0
 ip access-group Guest-ACL in
 ip nat inside
interface Vlan1
 description Internal Network
 ip nat inside
 ip virtual-reassembly
 bridge-group 1
 bridge-group 1 spanning-disabled
interface BVI1
 description Bridge to Internal Network
 ip address 192.168.16.254 255.255.255.0
 ip nat inside
 ip virtual-reassembly
bridge 1 route ip
int f0
 no shut
int f1
 no shut
int f2
 no shut
int f3
 no shut
int f4
 no shut
int dot0
 no shut
ip inspect name MYFW tcp
ip inspect name MYFW udp
ip access-list extended Internet-inbound-ACL
 permit udp any eq bootps any eq bootpc
 permit icmp any any echo
 permit icmp any any echo-reply
 permit icmp any any traceroute
 permit gre any any
 permit esp any any
int dialer1
 ip inspect MYFW out
 ip access-group Internet-inbound-ACL in




Also, here is some of the output of the PPP debug:

*Mar  1 19:25:11.147: %DIALER-6-BIND: Interface Vi1 bound to profile Di1
*Mar  1 19:25:11.147: Vi1 PPP: Using dialer call direction
*Mar  1 19:25:11.147: Vi1 PPP: Treating connection as a callout
*Mar  1 19:25:11.147: Vi1 PPP: Authorization NOT required
*Mar  1 19:25:11.147: Vi1 PPP: No remote authentication for call-out
*Mar  1 19:25:11.147: Vi1 LCP: O CONFREQ [Closed] id 1 len 10
*Mar  1 19:25:11.147: Vi1 LCP:    MagicNumber 0x16AB9F4C (0x050616AB9F4C)
*Mar  1 19:25:11.151: %LINK-3-UPDOWN: Interface Virtual-Access1, changed state to up
*Mar  1 19:25:11.159: Vi1 PPP: I pkt type 0xC021, datagramsize 21 link[ppp]
*Mar  1 19:25:11.163: Vi1 PPP: I pkt type 0xC021, datagramsize 12 link[ppp]
*Mar  1 19:25:11.163: Vi1 LCP: I CONFREQ [REQsent] id 213 len 19
*Mar  1 19:25:11.163: Vi1 LCP:    MRU 1492 (0x010405D4)
*Mar  1 19:25:11.163: Vi1 LCP:    AuthProto CHAP (0x0305C22305)
*Mar  1 19:25:11.163: Vi1 LCP:    MagicNumber 0x359B4B92 (0x0506359B4B92)
*Mar  1 19:25:11.163: Vi1 LCP: O CONFNAK [REQsent] id 213 len 8
*Mar  1 19:25:11.163: Vi1 LCP:    MRU 1500 (0x010405DC)
*Mar  1 19:25:11.163: Vi1 LCP: I CONFACK [REQsent] id 1 len 10
*Mar  1 19:25:11.163: Vi1 LCP:    MagicNumber 0x16AB9F4C (0x050616AB9F4C)
*Mar  1 19:25:11.175: Vi1 PPP: I pkt type 0xC021, datagramsize 21 link[ppp]
*Mar  1 19:25:11.175: Vi1 LCP: I CONFREQ [ACKrcvd] id 214 len 19
*Mar  1 19:25:11.175: Vi1 LCP:    MRU 1500 (0x010405DC)
*Mar  1 19:25:11.175: Vi1 LCP:    AuthProto CHAP (0x0305C22305)
*Mar  1 19:25:11.175: Vi1 LCP:    MagicNumber 0x359B4B92 (0x0506359B4B92)
*Mar  1 19:25:11.175: Vi1 LCP: O CONFACK [ACKrcvd] id 214 len 19
*Mar  1 19:25:11.175: Vi1 LCP:    MRU 1500 (0x010405DC)
*Mar  1 19:25:11.175: Vi1 LCP:    AuthProto CHAP (0x0305C22305)
*Mar  1 19:25:11.175: Vi1 LCP:    MagicNumber 0x359B4B92 (0x0506359B4B92)
*Mar  1 19:25:11.191: Vi1 PPP: I pkt type 0xC223, datagramsize 34 link[ppp]
*Mar  1 19:25:11.191: Vi1 CHAP: I CHALLENGE id 1 len 32 from "CHRLNCCE61W"
*Mar  1 19:25:11.191: Vi1 CHAP: Using hostname from interface CHAP
*Mar  1 19:25:11.191: Vi1 CHAP: Using password from interface CHAP
*Mar  1 19:25:11.191: Vi1 CHAP: O RESPONSE id 1 len 45 from "xxxxxxx@mybirch.net"
*Mar  1 19:25:11.679: Vi1 PPP: I pkt type 0xC021, datagramsize 16 link[ppp]
*Mar  1 19:25:11.683: Vi1 LCP: I CONFREQ [Open] id 1 len 14
*Mar  1 19:25:11.683: Vi1 LCP:    AuthProto PAP (0x0304C023)
*Mar  1 19:25:11.683: Vi1 LCP:    MagicNumber 0x355864A3 (0x0506355864A3)
*Mar  1 19:25:11.683: Vi1 PPP: Authorization NOT required
*Mar  1 19:25:11.683: Vi1 PPP: No remote authentication for call-out
*Mar  1 19:25:11.683: Vi1 LCP: O CONFREQ [Open] id 2 len 10
*Mar  1 19:25:11.683: Vi1 LCP:    MagicNumber 0x16ABA165 (0x050616ABA165)
*Mar  1 19:25:11.683: Vi1 LCP: O CONFACK [Open] id 1 len 14
*Mar  1 19:25:11.683: Vi1 LCP:    AuthProto PAP (0x0304C023)
*Mar  1 19:25:11.683: Vi1 LCP:    MagicNumber 0x355864A3 (0x0506355864A3)
*Mar  1 19:25:11.703: Vi1 PPP: I pkt type 0xC021, datagramsize 12 link[ppp]
*Mar  1 19:25:11.703: Vi1 LCP: I CONFACK [ACKsent] id 2 len 10
*Mar  1 19:25:11.703: Vi1 LCP:    MagicNumber 0x16ABA165 (0x050616ABA165)
*Mar  1 19:25:11.703: Vi1 LCP: O TERMREQ [Open] id 3 len 4
*Mar  1 19:25:11.723: Vi1 PPP: I pkt type 0xC021, datagramsize 6 link[ppp]
*Mar  1 19:25:11.727: Vi1 LCP: I TERMACK [TERMsent] id 3 len 4
*Mar  1 19:25:11.727: %DIALER-6-UNBIND: Interface Vi1 unbound from profile Di1
*Mar  1 19:25:11.731: %LINK-3-UPDOWN: Interface Virtual-Access1, changed state to down
TimotiStDatacenter Technician
Top Expert 2012

Commented:
You'll need to config FastEth4 to actually do PPPoE, like:

interface FastEthernet4
 no ip address
 duplex auto
 speed auto
 pppoe enable group global
 pppoe-client dial-pool-number 1
end

Also, mixing BVI, vlan and dot11radio interfaces this much looks a bit complicated to me, but might work.

Tamas

Author

Commented:
Well, I used a configuration template, so it is possible that the mixing of the interfaces is not efficient. I am rather new to this, and I appreciate the help. I will make the changes, and see if that works. Thanks.

Author

Commented:
That does not appear to have corrected the issue. I am really lost at this point.

Current Debug Output:

*Mar  1 19:16:51.279: %DIALER-6-BIND: Interface Vi1 bound to profile Di1
*Mar  1 19:16:51.279: Vi1 PPP: Phase is DOWN, Setup
*Mar  1 19:16:51.279: Vi1 PPP: Using dialer call direction
*Mar  1 19:16:51.279: Vi1 PPP: Treating connection as a callout
*Mar  1 19:16:51.279: Vi1 PPP: Phase is ESTABLISHING, Active Open
*Mar  1 19:16:51.279: Vi1 PPP: Authorization NOT required
*Mar  1 19:16:51.279: Vi1 PPP: No remote authentication for call-out
*Mar  1 19:16:51.279: Vi1 LCP: O CONFREQ [Closed] id 1 len 10
*Mar  1 19:16:51.279: Vi1 LCP:    MagicNumber 0x16A50FD2 (0x050616A50FD2)
*Mar  1 19:16:51.283: %LINK-3-UPDOWN: Interface Virtual-Access1, changed state to up
*Mar  1 19:16:51.291: Vi1 LCP: I CONFREQ [REQsent] id 175 len 19
*Mar  1 19:16:51.291: Vi1 LCP:    MRU 1492 (0x010405D4)
*Mar  1 19:16:51.291: Vi1 LCP:    AuthProto CHAP (0x0305C22305)
*Mar  1 19:16:51.291: Vi1 LCP:    MagicNumber 0x189F068E (0x0506189F068E)
*Mar  1 19:16:51.291: Vi1 LCP: O CONFNAK [REQsent] id 175 len 8
*Mar  1 19:16:51.291: Vi1 LCP:    MRU 1500 (0x010405DC)
*Mar  1 19:16:51.291: Vi1 LCP: I CONFACK [REQsent] id 1 len 10
*Mar  1 19:16:51.291: Vi1 LCP:    MagicNumber 0x16A50FD2 (0x050616A50FD2)
*Mar  1 19:16:51.303: Vi1 LCP: I CONFREQ [ACKrcvd] id 176 len 19
*Mar  1 19:16:51.303: Vi1 LCP:    MRU 1500 (0x010405DC)
*Mar  1 19:16:51.303: Vi1 LCP:    AuthProto CHAP (0x0305C22305)
*Mar  1 19:16:51.303: Vi1 LCP:    MagicNumber 0x189F068E (0x0506189F068E)
*Mar  1 19:16:51.303: Vi1 LCP: O CONFACK [ACKrcvd] id 176 len 19
*Mar  1 19:16:51.307: Vi1 LCP:    MRU 1500 (0x010405DC)
*Mar  1 19:16:51.307: Vi1 LCP:    AuthProto CHAP (0x0305C22305)
*Mar  1 19:16:51.307: Vi1 LCP:    MagicNumber 0x189F068E (0x0506189F068E)
*Mar  1 19:16:51.307: Vi1 LCP: State is Open
*Mar  1 19:16:51.307: Vi1 PPP: Phase is AUTHENTICATING, by the peer
*Mar  1 19:16:51.319: Vi1 CHAP: I CHALLENGE id 1 len 32 from "CHRLNCCE61W"
*Mar  1 19:16:51.319: Vi1 CHAP: Using hostname from interface CHAP
*Mar  1 19:16:51.319: Vi1 CHAP: Using password from interface CHAP
*Mar  1 19:16:51.319: Vi1 CHAP: O RESPONSE id 1 len 45 from "xxxxxxxxx@mybirch.net"
*Mar  1 19:16:51.563: Vi1 LCP: I CONFREQ [Open] id 1 len 14
*Mar  1 19:16:51.563: Vi1 LCP:    AuthProto PAP (0x0304C023)
*Mar  1 19:16:51.563: Vi1 LCP:    MagicNumber 0x358B08FB (0x0506358B08FB)
*Mar  1 19:16:51.563: Vi1 PPP: Sending Acct Event[Reneg] id[6]
*Mar  1 19:16:51.563: Vi1 PPP: Phase is TERMINATING
*Mar  1 19:16:51.563: Vi1 PPP: Authorization NOT required
*Mar  1 19:16:51.563: Vi1 PPP: No remote authentication for call-out
*Mar  1 19:16:51.563: Vi1 PPP: Phase is ESTABLISHING
*Mar  1 19:16:51.563: Vi1 LCP: O CONFREQ [Open] id 2 len 10
*Mar  1 19:16:51.563: Vi1 LCP:    MagicNumber 0x16A510EF (0x050616A510EF)
*Mar  1 19:16:51.567: Vi1 LCP: O CONFACK [Open] id 1 len 14
*Mar  1 19:16:51.567: Vi1 LCP:    AuthProto PAP (0x0304C023)
*Mar  1 19:16:51.567: Vi1 LCP:    MagicNumber 0x358B08FB (0x0506358B08FB)
*Mar  1 19:16:51.583: Vi1 LCP: I CONFACK [ACKsent] id 2 len 10
*Mar  1 19:16:51.583: Vi1 LCP:    MagicNumber 0x16A510EF (0x050616A510EF)
*Mar  1 19:16:51.583: Vi1 LCP: State is Open
*Mar  1 19:16:51.583: Vi1 PPP: Phase is AUTHENTICATING, by the peer
*Mar  1 19:16:51.587: Vi1 PPP: Sending Acct Event[Down] id[6]
*Mar  1 19:16:51.587: Vi1 PPP: Phase is TERMINATING
*Mar  1 19:16:51.587: Vi1 LCP: O TERMREQ [Open] id 3 len 4
*Mar  1 19:16:51.607: Vi1 LCP: I TERMACK [TERMsent] id 3 len 4
*Mar  1 19:16:51.607: Vi1 LCP: State is Closed
*Mar  1 19:16:51.607: Vi1 PPP: Phase is DOWN
*Mar  1 19:16:51.607: %DIALER-6-UNBIND: Interface Vi1 unbound from profile Di1
*Mar  1 19:16:51.611: %LINK-3-UPDOWN: Interface Virtual-Access1, changed state to down
*Mar  1 19:17:14.187: %DIALER-6-BIND: Interface Vi1 bound to profile Di1
*Mar  1 19:17:14.187: Vi1 PPP: Phase is DOWN, Setup
*Mar  1 19:17:14.187: Vi1 PPP: Using dialer call direction
*Mar  1 19:17:14.187: Vi1 PPP: Treating connection as a callout
*Mar  1 19:17:14.187: Vi1 PPP: Phase is ESTABLISHING, Active Open
*Mar  1 19:17:14.187: Vi1 PPP: Authorization NOT required
*Mar  1 19:17:14.187: Vi1 PPP: No remote authentication for call-out
*Mar  1 19:17:14.187: Vi1 LCP: O CONFREQ [Closed] id 1 len 10
*Mar  1 19:17:14.187: Vi1 LCP:    MagicNumber 0x16A56950 (0x050616A56950)
*Mar  1 19:17:14.191: %LINK-3-UPDOWN: Interface Virtual-Access1, changed state to up
*Mar  1 19:17:14.199: Vi1 LCP: I CONFREQ [REQsent] id 149 len 19
*Mar  1 19:17:14.199: Vi1 LCP:    MRU 1492 (0x010405D4)
*Mar  1 19:17:14.199: Vi1 LCP:    AuthProto CHAP (0x0305C22305)
*Mar  1 19:17:14.199: Vi1 LCP:    MagicNumber 0x2C54E0B2 (0x05062C54E0B2)
*Mar  1 19:17:14.199: Vi1 LCP: O CONFNAK [REQsent] id 149 len 8
*Mar  1 19:17:14.199: Vi1 LCP:    MRU 1500 (0x010405DC)
*Mar  1 19:17:14.199: Vi1 LCP: I CONFACK [REQsent] id 1 len 10
*Mar  1 19:17:14.199: Vi1 LCP:    MagicNumber 0x16A56950 (0x050616A56950)
*Mar  1 19:17:14.211: Vi1 LCP: I CONFREQ [ACKrcvd] id 150 len 19
*Mar  1 19:17:14.211: Vi1 LCP:    MRU 1500 (0x010405DC)
*Mar  1 19:17:14.211: Vi1 LCP:    AuthProto CHAP (0x0305C22305)
*Mar  1 19:17:14.215: Vi1 LCP:    MagicNumber 0x2C54E0B2 (0x05062C54E0B2)
*Mar  1 19:17:14.215: Vi1 LCP: O CONFACK [ACKrcvd] id 150 len 19
*Mar  1 19:17:14.215: Vi1 LCP:    MRU 1500 (0x010405DC)
*Mar  1 19:17:14.215: Vi1 LCP:    AuthProto CHAP (0x0305C22305)
*Mar  1 19:17:14.215: Vi1 LCP:    MagicNumber 0x2C54E0B2 (0x05062C54E0B2)
*Mar  1 19:17:14.215: Vi1 LCP: State is Open
*Mar  1 19:17:14.215: Vi1 PPP: Phase is AUTHENTICATING, by the peer
*Mar  1 19:17:14.227: Vi1 CHAP: I CHALLENGE id 1 len 32 from "CHRLNCCE61W"
*Mar  1 19:17:14.227: Vi1 CHAP: Using hostname from interface CHAP
*Mar  1 19:17:14.227: Vi1 CHAP: Using password from interface CHAP
*Mar  1 19:17:14.227: Vi1 CHAP: O RESPONSE id 1 len 45 from "xxxxxxxx@mybirch.net"
*Mar  1 19:17:14.531: Vi1 LCP: I CONFREQ [Open] id 1 len 14
*Mar  1 19:17:14.531: Vi1 LCP:    AuthProto PAP (0x0304C023)
*Mar  1 19:17:14.531: Vi1 LCP:    MagicNumber 0x358B62D9 (0x0506358B62D9)
*Mar  1 19:17:14.531: Vi1 PPP: Sending Acct Event[Reneg] id[7]
*Mar  1 19:17:14.535: Vi1 PPP: Phase is TERMINATING
*Mar  1 19:17:14.535: Vi1 PPP: Authorization NOT required
*Mar  1 19:17:14.535: Vi1 PPP: No remote authentication for call-out
*Mar  1 19:17:14.535: Vi1 PPP: Phase is ESTABLISHING
*Mar  1 19:17:14.535: Vi1 LCP: O CONFREQ [Open] id 2 len 10
*Mar  1 19:17:14.535: Vi1 LCP:    MagicNumber 0x16A56AAD (0x050616A56AAD)
*Mar  1 19:17:14.535: Vi1 LCP: O CONFACK [Open] id 1 len 14
*Mar  1 19:17:14.535: Vi1 LCP:    AuthProto PAP (0x0304C023)
*Mar  1 19:17:14.535: Vi1 LCP:    MagicNumber 0x358B62D9 (0x0506358B62D9)
*Mar  1 19:17:14.555: Vi1 LCP: I CONFACK [ACKsent] id 2 len 10
*Mar  1 19:17:14.555: Vi1 LCP:    MagicNumber 0x16A56AAD (0x050616A56AAD)
*Mar  1 19:17:14.555: Vi1 LCP: State is Open
*Mar  1 19:17:14.555: Vi1 PPP: Phase is AUTHENTICATING, by the peer
*Mar  1 19:17:14.555: Vi1 PPP: Sending Acct Event[Down] id[7]
*Mar  1 19:17:14.559: Vi1 PPP: Phase is TERMINATING
*Mar  1 19:17:14.559: Vi1 LCP: O TERMREQ [Open] id 3 len 4
*Mar  1 19:17:14.579: Vi1 LCP: I TERMACK [TERMsent] id 3 len 4
*Mar  1 19:17:14.579: Vi1 LCP: State is Closed
*Mar  1 19:17:14.579: Vi1 PPP: Phase is DOWN
*Mar  1 19:17:14.579: %DIALER-6-UNBIND: Interface Vi1 unbound from profile Di1
*Mar  1 19:17:14.583: %LINK-3-UPDOWN: Interface Virtual-Access1, changed state to down
Datacenter Technician
Top Expert 2012
Commented:
Below is the current config of my home 851w with ADSL. I don't bridge the radio with vlan1, so you'll have to modify that.

!
! No configuration change since last restart
!
version 12.4
no service pad
service timestamps debug datetime
service timestamps log datetime
service password-encryption
!
hostname cerberus
!
boot-start-marker
boot-end-marker
!
logging buffered 64000
enable secret 5 $1$xxxxxxxxxxxxxxxxxxxx
!
no aaa new-model
clock timezone CET 1
!
!
dot11 syslog
!
dot11 ssid bela
   vlan 1
   max-associations 20
   authentication open 
   authentication key-management wpa
   guest-mode
   wpa-psk ascii 7 xxxxxxxxxxxxxxxxxxxxx
!
dot11 ssid masodikbela
   vlan 10
   max-associations 5
   authentication open 
   authentication key-management wpa
   wpa-psk ascii 7 xxxxxxxxxxxxxxxxxxxxxxx
!
no ip dhcp use vrf connected
ip dhcp excluded-address 192.168.1.254
ip dhcp excluded-address 192.168.10.254
!
ip dhcp pool dpool1
   import all
   network 192.168.1.0 255.255.255.0
   default-router 192.168.1.254 
   domain-name timoti.local
   dns-server 192.168.1.254 8.8.8.8 109.61.0.20 
!
ip dhcp pool dpool10
   import all
   network 192.168.10.0 255.255.255.0
   default-router 192.168.10.254 
   dns-server 109.61.0.20 8.8.8.8 8.8.4.4 
   domain-name lab.timoti.local
!
!
ip cef
ip inspect udp idle-time 300
ip inspect tcp reassembly queue length 256
ip inspect tcp reassembly timeout 45
ip inspect name firewall udp
ip inspect name firewall http
ip inspect name firewall https
ip inspect name firewall ftp
ip inspect name firewall ftps
ip inspect name firewall pop3s
ip inspect name firewall imap
ip inspect name firewall imaps
ip domain name timoti.local
ip name-server 8.8.8.8
ip name-server 8.8.4.4
ip ddns update method dyndns
 HTTP
  add http://xxxxxxxxt:xxxxxxxxxxxx@members.dyndns.org/nic/update?system=dyndns&hostname=<h>&myip=<a>
 interval maximum 2 0 0 0
!
!
!
!
username xxxxxx password 7 xxxxxxxxxxxxxxxxxx
! 
!         
archive
 log config
  hidekeys
!
!
ip ssh version 2
!
!
!
interface FastEthernet0
!
interface FastEthernet1
!
interface FastEthernet2
!
interface FastEthernet3
!
interface FastEthernet4
 no ip address
 duplex auto
 speed auto
 pppoe enable group global
 pppoe-client dial-pool-number 1
!
interface Dot11Radio0
 no ip address
 no ip route-cache cef
 no ip route-cache
 !
 encryption vlan 1 mode ciphers aes-ccm tkip 
 !
 encryption vlan 10 mode ciphers aes-ccm tkip 
 !
 ssid bela
 !
 ssid masodikbela
 !
 speed basic-1.0 basic-2.0 basic-5.5 6.0 9.0 basic-11.0 12.0 18.0 24.0 36.0 48.0 54.0
 power client 17
 packet retries 128 drop-packet
 channel 2412
 station-role root
!
interface Dot11Radio0.1
 encapsulation dot1Q 1 native
 ip address 192.168.1.254 255.255.255.0
 ip nat inside
 ip virtual-reassembly
 no ip route-cache
 ip tcp adjust-mss 1442
!
interface Dot11Radio0.10
 encapsulation dot1Q 10
 ip address 192.168.10.254 255.255.255.0
 ip nat inside
 ip virtual-reassembly
 no ip route-cache
!
interface Vlan1
 ip address 192.168.2.254 255.255.255.0
!
interface Dialer0
 ip ddns update hostname xxxxxxxxxxxxxxxxx.dyndns.org
 ip ddns update dyndns
 ip address negotiated
 ip mtu 1442
 ip inspect firewall out
 ip nat outside
 ip virtual-reassembly
 encapsulation ppp
 dialer pool 1
 dialer-group 1
 no cdp enable
 ppp authentication pap callin
 ppp pap sent-username xxxxxxxxxxxxxxxx password 7 xxxxxxxxxxxxxxxxxxxxxxxxxxxx
!
no ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 Dialer0
!
no ip http server
no ip http secure-server
ip dns server
ip nat inside source list 1 interface Dialer0 overload
ip nat inside source static tcp 192.168.1.250 22 interface Dialer0 22222
!
logging 192.168.1.105
access-list 1 permit 192.168.0.0 0.0.255.255
access-list 101 permit tcp any any eq 22
access-list 101 permit tcp any any established
access-list 101 permit udp any any eq ntp
access-list 101 deny   ip any any log
dialer-list 1 protocol ip permit
!
control-plane
!
!
line con 0
 logging synchronous
 no modem enable
line aux 0
line vty 0 4
 login local
 transport input ssh
!
scheduler max-task-time 5000
sntp server 193.225.130.250
sntp server 193.225.14.182
sntp server 195.111.98.30
end

Open in new window

Author

Commented:
my IOS is 12.3 will this matter, as I noticed yours is 12.4. Unfortunately I no longer am able to download the 12.4 IOS.

Author

Commented:
And....Thank you for the config!
TimotiStDatacenter Technician
Top Expert 2012

Commented:
Most functionality should be present in IOS 12.3.

This is the most recent IOS release for the 851w:

http://www.cisco.com/cisco/software/release.html?mdfid=279623991&softwareid=280805680&release=12.4.15T17&relind=AVAILABLE&rellifecycle=MD&reltype=latest

Tamas

Author

Commented:
I cant download the software as I dont have a contract. Unfortunately nothing has worked. We are going to pull the cisco equipment and put a different manufacturer in. Thank you for all your input.

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial