SBS2011 Backup - System State

aNaLyz3R
aNaLyz3R used Ask the Experts™
on
Hi Guys

My backups have been failing for the past 3 days.
I get the following error msg :

"Operation stopped. Detailed Error: The volume shadow copy operation failed with error 0x800423F0. View event log for more information."

Please assists
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®

Author

Commented:
Sharepoint was updated via WSUS recently.
Attached is the response i get after running the PSConfig cmd.
Capture-1.PNG

Commented:
Hmmm... has there been a reboot since the WSUS updates? you may need one.
Acronis in Gartner 2019 MQ for datacenter backup

It is an honor to be featured in Gartner 2019 Magic Quadrant for Datacenter Backup and Recovery Solutions. Gartner’s MQ sets a high standard and earning a place on their grid is a great affirmation that Acronis is delivering on our mission to protect all data, apps, and systems.

Author

Commented:
No there hasnt, i'll reboot tonight out of business hours and refer back to you.......

Author

Commented:
Ok i have rebooted the server, still no luck, backups still failing

Author

Commented:
I've requested that this question be deleted for the following reason:

Issue requires re-assessment as all current questions are interlinked.....
Distinguished Expert 2018

Commented:
Not allowing an expert to finish working with you in the question is extremely disrespectful. Not that I have not actively participated in this question, so I do not say this out of any self-benefit. But following up that a suggestion has not worked, deleting the question, and immediately opening a new one elsewhere does not allow experts to follow what has already been tried. You actually get LESS assistance at a lower quality. You SHOIOD really follow this question through to completion. And if you choose not to, certainly do not open a new question asking the exact same thing.

Author

Commented:
Cgaliher

As mentioned in my other question, i do apologise, can you reject these and we carry on with the original questions?
Distinguished Expert 2018

Commented:
I am not a moderator so there is little I can do about the various statuses of your questions. I can, however, try to work with you on this problem, along with the other experts that have already contributed.

With your latest reply, the first thing that is unclear to me is what you mean by "no luck" after the reboot.  In a previous reply, you showed the output of the psconfig command, and that output shows a clear failure at step 5, which the expert in question suggested a reboot to fix. You say that backups still fail. But no indication that you retried the psconfig command. Backups WILL fail until you get that command to succeed. If you can provide more context on whether you've tried that and what errors you received, that would be helpful.

-Cliff

Author

Commented:
Kinecsys recommended that i reboot the server, which i did, however after that the backups still failed.
Even after the reboot, re-ran the Psconfig solution and it came back with the same error.
If you're saying that the issue may be resolved by relooking at the PSconfig solution, then let's run with it......
What next ?
Distinguished Expert 2018

Commented:
Yes, the backup relies on VSS, which in turn relies on the database being in a consistent state. The psconfig command is what brings the database up to a consistent state after a sharepoint upgrade (service pack, security update) and thus backups failing are actually expected behavior until the upgrade process is complete.

Psconfig will fail if SQL is timing out. Here is what I'd do to try and prevent that:

1) open up IIS and stop the "company web" website.
2) disable all antivirus temporarily, their memory scanning can easily kill SQL
3) open up the "services" control panel and restart all SQL related processes.
4) run psconfig from an elevated command prompt (right click, choose run as administrator)

Those steps, done in order, will usually eliminate any SQL memory timing and locking issues that prevent psconfig from completing.

Please post back results.

-Cliff

Author

Commented:
Cliff

Ok followed your recommendation to the T, ran point no 4 :

PSConfig.exe -cmd upgrade -inplace b2b -force -cmd applicationcontent -install -cmd installfeatures

from an elevated cmd, still fails please see attached
Capture.PNG

Author

Commented:
Cliff

I ran the Sharepoint products configuration wizard as well, attached is the log file i got from that failure, also ran it as administrator at cmd prompt....
PSCDiagnostics-4-20-2012-15-35-2.log
Distinguished Expert 2018
Commented:
Why did you run the setup and configuration wizard?!?  That does a completely different set of things to your database. Truthfully, between an only partially applied SP1 and now a configuration rewrite, I can only guess at the state of corruption now present in the database. I doubt it is reversible at this point. You can restore a backup or call MS, but I don't see a way back now...

Author

Commented:
Thanks will give MS a call regarding this....

Author

Commented:
Found the solution to this problem hope someone out there who has this issue will try this.
When running the PSConfig command, on my server it failed when getting to 10.00%.

Run the below, and it fixes the issue :

My workaround:
I run once again the command „PSConfig.exe -cmd upgrade -inplace b2b -force -cmd applicationcontent -install -cmd installfeatures“  in the “Bin” Folder as an administrator console session.
In the moment I saw the staus “Configurationtask 5 of 6 is executed” I start to run the command “net start SPTraceV4 & net start SPWriterV4 & net start SPAdminV4 & net start SPSearch4 & net start SPTimerV4” in a parallel administrator console session and after that the configuration task finished successfully.

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial