Cisco Aironet 1240 AP

YorkData
YorkData used Ask the Experts™
on
Hi,

I have a Cisco AIR-LAP1242G-E-K9 Access point and have upgraded (or downgraded) the firmware so it is able to work autonomously. The new firmware version is c1240-k9w7-mx.124-10b.JA3. I have configured the access point via the command line as the web interface seems massively over complicated.

The problem is that the AP seems to run very intermittently, sometimes is works fine then half an hour later the SSID will completely dissapear, or it will not allow any clients to connect up to it, or it will kick off the existing clients. I have posted the config below:

Building configuration...

Current configuration : 1583 bytes
!
version 12.4
no service pad
no service timestamps debug uptime
no service timestamps log uptime
service password-encryption
!
hostname AP2
!
no logging console
enable secret 5 $1$IaVq$Q1UxjBexQsYikjr5SgoJ00
!
no aaa new-model
!
!
!
dot11 ssid AP2
   authentication open
   authentication key-management wpa
   guest-mode
   wpa-psk ascii 7 153C283A557D7C717D
!
power inline negotiation prestandard source
!
!
username Cisco password 7 14341B180F0B
!
bridge irb
!
!
interface Dot11Radio0
 no ip address
 no ip route-cache
 !
 encryption mode ciphers tkip
 !
 ssid AP2
 !
 packet retries 125
 channel 2462
 fragment-threshold 1000
 station-role root
 rts threshold 1000
 rts retries 120
 beacon period 2000
 beacon dtim-period 50
 bridge-group 1
 bridge-group 1 subscriber-loop-control
 bridge-group 1 block-unknown-source
 no bridge-group 1 source-learning
 no bridge-group 1 unicast-flooding
 bridge-group 1 spanning-disabled
!
interface FastEthernet0
 no ip address
 no ip route-cache
 duplex auto
 speed auto
 bridge-group 1
 no bridge-group 1 source-learning
 bridge-group 1 spanning-disabled
!
interface BVI1
 ip address dhcp client-id FastEthernet0
 no ip route-cache
!
ip http server
no ip http secure-server
ip http help-path http://www.cisco.com/warp/public/779/smbiz/prodconfig/help/eag
bridge 1 route ip
!
!
wlccp ap username AIR-1 password 7 0208317627292C0A
!
line con 0
 transport output all
line vty 0 4
 login local
 transport input all
 transport output all
line vty 5 15
 login
 transport input all
 transport output all
!
end

Open in new window


The AP picks up it's ip from DHCP reservation.

Any help would be appreciated.

Thanks,
Adam
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Top Expert 2014
Commented:
Your timers and variables are a bit random!  Also, you've set the AP to a specific channel which might be suffering from interference.

Try this at the console...

conf t
default int dot 0
int dot 0
encrypt mode cipher tkip
ssid AP2
end

Open in new window

Author

Commented:
Hi Craigbeck,

Thanks for the advice, I decided to strip out all of the what is seemingly unnecessary config and it seems to be working as of now. Here is what I changed it to:

Building configuration...

Current configuration : 1458 bytes
!
version 12.4
no service pad
no service timestamps debug uptime
no service timestamps log uptime
service password-encryption
!
hostname AP2
!
no logging console
enable secret 5 $1$IaVq$Q1UxjBexQsYikjr5SgoJ00
!
no aaa new-model
!
!
!
dot11 ssid AP2
   authentication open
   authentication key-management wpa
   guest-mode
   wpa-psk ascii 7 153C283A557D7C717D
!
power inline negotiation prestandard source
!
!
username Cisco password 7 14341B180F0B
!
bridge irb
!
!
interface Dot11Radio0
 no ip address
 no ip route-cache
 !
 encryption mode ciphers tkip
 !
 ssid AP2
 !
 channel 2462
 station-role root
 bridge-group 1
 bridge-group 1 subscriber-loop-control
 bridge-group 1 block-unknown-source
 no bridge-group 1 source-learning
 no bridge-group 1 unicast-flooding
 bridge-group 1 spanning-disabled
!
interface FastEthernet0
 no ip address
 no ip route-cache
 duplex auto
 speed auto
 bridge-group 1
 no bridge-group 1 source-learning
 bridge-group 1 spanning-disabled
!
interface BVI1
 ip address dhcp client-id FastEthernet0
 no ip route-cache
!
ip http server
no ip http secure-server
ip http help-path http://www.cisco.com/warp/public/779/smbiz/prodconfig/help/eag
bridge 1 route ip
!
!
wlccp ap username AIR-1 password 7 0208317627292C0A
!
line con 0
 transport output all
line vty 0 4
 login local
 transport input all
 transport output all
line vty 5 15
 login
 transport input all
 transport output all
!
end

Newitts-AP2#

Open in new window


It has held up ok for the past week however I will put your suggestions in to place if it does go down.

Thanks,
Adam
Top Expert 2014

Commented:
Hi Adam,

That's exactly what I was suggesting by issuing the default int dot 0 command! :-)

Let me know how it goes,

Craig

Author

Commented:
Taking out a lot of the bumph seemed to resolve the problem

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial