SharePoint 2010 deleted page problem

garion1
garion1 used Ask the Experts™
on
I am an administrator of SharePoint 2010 at my company.

I created a page called "Surveys" in the Pages library. It appeared on the left side of the site's Home Page. I added a test survey to it. The survey appeared as a link under the Surveys heading on the Home Page. After a successful test, I removed the survey which then disappeared from under the Surveys heading. I then deleted the page from the Pages library. It is no longer listed there.

I cannot understand how it is still displaying on the left side of the screen on the Home Page. I have cleared the web cache and refreshed but no luck. The page is still there!? Users can browse to it.
Is this a SharePoint caching issue? How do I remove the page?
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Most Valuable Expert 2011
Awarded 2010
Commented:
Hello,

if this is a site with the publishing feature enabled, go to Site Actions > Site Settings > Navigation and delete the link in the "Current Navigation"

If it is not a publishing site, go to Site Actions > Site Settings > Quick Launch and delete the link there.

cheers, teylyn

Author

Commented:
Perfect, thank you.
I deleted the link here: Site Actions > Site Settings > Navigation > Navigation Editing and Sorting

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial