troubleshooting Question

VMware ESXi 5.0 constantly resetting vmnic

Avatar of johnnyt29
johnnyt29Flag for Canada asked on
VMware
10 Comments1 Solution2353 ViewsLast Modified:
I can't stay connected to my ESXi 5.0 host or its VM's, via either vSphere client or Windows RDP. The VM Kernel Log reports errors like:

1836 Netsched ... packets seem stuck... issuing reset of vmnic2
1817 ... scheduler [<some number>] lockup [stopped=0]...
1827 ... detected at 578999 while last xmit at 573549 and 27/20375

I did try to optimize the TCP stack (using TCP Optimizer 3 from http://www.speedguide.net/downloads.php) in one of my Windows VM's then did a host reboot (for other reasons) just before this problem appears. Could that have corrupted something or is it just a coincidence?

Tried removing all other devices from my router except ESXi host and a laptop to run vSphere client and RDP. Was able to shut down all VM's to keep them from causing or contributing to the problem. Tried adjusting router MTU (between 1492 and 1500) guessing that is was a packet fragmentation issue (although the router should be able to handle that I thought). Tried restarting all devices (host, router, laptop). Only thing I haven't done yet is re-installing ESXi OS on the USB thumb drive.
ASKER CERTIFIED SOLUTION
Join our community to see this answer!
Unlock 1 Answer and 10 Comments.
Start Free Trial
Learn from the best

Network and collaborate with thousands of CTOs, CISOs, and IT Pros rooting for you and your success.

Andrew Hancock - VMware vExpert
See if this solution works for you by signing up for a 7 day free trial.
Unlock 1 Answer and 10 Comments.
Try for 7 days

”The time we save is the biggest benefit of E-E to our team. What could take multiple guys 2 hours or more each to find is accessed in around 15 minutes on Experts Exchange.

-Mike Kapnisakis, Warner Bros