Enable Set Command in Windows XP Recovery Console

arthurh88
arthurh88 used Ask the Experts™
on
I can't boot to windows.  
I need to backup my data on my hard drive to a USB drive before using the FIXMBR command.
I can access the recovery console
I cannot copy any data due to the limitations of the environment  SET AllowAllPaths = FALSE

I cannot boot to windows to change this (obviously)
So how can I change this to TRUE without being able to boot into windows?
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
captainTechnical Director

Commented:
You cannot simply set this to true, as described in the MS kb:
http://support.microsoft.com/kb/235364

There are a variety of ways to get to your data, the simplest requires only a second PC and that your drive is not encrypted and you can just slave the drive to a running OS and pull of your data that way.

Is that an option for you?

Author

Commented:
i cant slave the drive because it is 2 drives as a RAID 0 and I need my motherboard.  Do you have another idea to access my data?  I do not have the original XP CD, I only have a recovery console ISO that boots to an XP Recovery Console.  I need to backup my data before I run the FIXMBR command.
You can build a BartPE boot disk, then use the offline registry editor to enable you to use the set command from the recovery console.

http://www.nu2.nu/pebuilder/

Once booted using BartPE, do the following at the command prompt:

regedit.exe <enter>

Select the HK_Local_Machine Hive

From the File menu, choose the Load Hive option. Browse to your Windows installation drive, for example the following location:

C:\Windows\System32\Config\
Select the file named SOFTWARE (the file without any extensions), and click Open

Type a name for the hive that you've loaded now. (Example: MyXPHive)
Now the SOFTWARE hive is loaded, and present under the HK_Local_Machine base hive.

Now navigate to the following key:
HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\Setup\RecoveryConsole\.

In the right pane, look for the SetCommand key
Double-click on the value and change it to 1
(This change will now allow you to use the set command in the recovery console)

After making the change, you MUST unload the Hive:
To do so, select MyXPHive branch, and then in the File menu, choose Unload Hive

Quit BartPE and restart windows and load the recovery console. Use the set command to set the environment variable as you like. It should now work.
LeeTutorretired
Top Expert 2009

Commented:
I've requested that this question be deleted for the following reason:

Not enough information to confirm an answer.
I object to closing the question in this manner. The instructions I provided absolutely provide an answer to the original post as to how to allow the set command to be used from the recovery console on a non-booting system. The instructions are specific and do exactly as the poster requested, which is enabling the "Allow set command" to be true in the registry.
captainTechnical Director

Commented:
Lee,

I agree with flubbster.

capt.

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial