SBS 2003 OWA not working with external address

Hi

I’ve got a server running SBS 2003 and I’ve just installed a SSL certificate for remote.domainname.com and externally the certificate works fine and I can access OWA through https://remote.domainname.com/exchange.  If I go to this address internally it doesn't work. if I go to http://servername/exchange it loads OWA fine.  I've done a bit of research into how to get the same address https://remote.domainname/exchange working internally and externally and there's a few forum posts which talk about setting up split DNS, I've followed a couple of guides and cant quite get it working correctly.

If anyone could assist that would be greatly appreciated.

Thanks
LVL 1
systemagicAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

PerarduaadastraCommented:
Why is it necessary to have the external address work internally at all?
You wouldn't normally use secure HTTP  to access your Exchange server from the LAN, which may be part of the problem.

As the internal and external methods you described both work, why not just set up appropriate shortcuts on the users' browser toolbars so that they can select whichever one fits the circumstances?
0
systemagicAuthor Commented:
The reason I want it to work internally and externally is because of mobile devices such as iPhones, they are used in the office connected to wifi and also outside the office so need to be setup with the same address in the email config.
0
systemagicAuthor Commented:
I have another client server which are also sbs 2003 and have the same type of ssl, it was setup a while ago but if I go to https://remote.domainname.com/exchange from inside and outside the network it loads fine and mobile devices work fine.  So I know it can be done, I've gone through and compared the dns settings, iis settings and site bindings and can't see any differences so I'm not really sure why it works fine for one client but not the other.
0
IT Pros Agree: AI and Machine Learning Key

We’d all like to think our company’s data is well protected, but when you ask IT professionals they admit the data probably is not as safe as it could be.

footechCommented:
Are you using SBS Premium (w/ ISA installed) or just standard? If using ISA, there are some additional steps you can take to deal with certificates so you don't get a warning, but they're not 100% necessary.

Is your internal (Active Directory) domain name the same as your external name used to access your public IP from the internet?

If not, open the DNS Management console, create a new Forward Lookup Zone.  Use Primary, AD integrated, replicate to all DNS in domain.  Name it "remote.domainname.com".  Then create a new A (host) record in the zone, leave the name blank (for "same as parent") and enter the internal IP of your SBS.  By naming the new zone "remote.domainname.com" instead of "domainname.com", queries for other subdomains of domainname.com (e.g. www.domainname.com) will still be able to be resolved by DNS records available on the internet instead of having to create these records manually.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
systemagicAuthor Commented:
Hey

its not premium just the standard version.

I've setup the Forward lookup zone and A record as you have asked and that's now working fine :) I'm sure I tried that before and was getting a username and password pop up when trying to access the site but I must have done something wrong

Thanks for your help :)
0
footechCommented:
Glad I could help.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows Server 2003

From novice to tech pro — start learning today.