Remote Desktop Connection has stopped working

EricLynnWright
EricLynnWright used Ask the Experts™
on
My company did an upgrade on our computers.  that upgrade has stopped my remote desk top from working.

When I try to connect to a computer, I get "Remote Desktop Connection" has stopped working (check online..., close the program, debug the program).

I really don't have time to wait for them to look at it.  Hoping someone can give some suggestions.

Computer:
Windows 7 Enterprise, Service Pack 1, 32 bit OS.
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Maybe a corrupt dll. Try this:

a)   Click on  Start > Type in   cmd in the search box

b)   Right click on  cmd that appears on the start menu under programs and hit   “Run as administrator”

c)   Now run the command  regsvr32 remotepg.dll

Other suggestions listed at the link:

http://answers.microsoft.com/en-us/windows/forum/windows_vista-networking/remote-desktop-connection-not-working/1b9f5f98-1a7c-48cb-a97f-161a993fc1ed

Author

Commented:
Thanks, motnahp00.  Tried all suggestions, but still the same.
Is it only your profile on that computer showing the problem?
PMI ACP® Project Management

Prepare for the PMI Agile Certified Practitioner (PMI-ACP)® exam, which formally recognizes your knowledge of agile principles and your skill with agile techniques.

Author

Commented:
>>Is it only your profile on that computer showing the problem?

That's a good question.  I'll try to have someone else test it out, but that's a few hours before I can.
Check if RDP has been enabled on the Windows 7 machine and it has been configured with right option.

Refer the link for configuring he RDP on window 7
http://4sysops.com/archives/how-to-setup-remote-desktop-with-windows-7/

If the RDP has enabled with right option, run the netstat -aon and check if there is any listening on port 3389.

Also check the registry if the RDP as the default port.
HKLM\System\CurrentControlSet\Control\TerminalServer\WinStations\RDP-Tcp
 "PortNumber" as 3389.
Raymond PengSystems Engineer

Commented:
Any antivirus / firewall enabled on the machine?  You mentioned an upgrade - can you check to see if the RDP settings are set so that 'any version of RDP is able to connect'

Author

Commented:
I apologize.  I will have to try the additional solutions tomorrow.

Thank you guys for your posts and help - I'll get back soon.
Raymond PengSystems Engineer
Commented:
You can also try the Microsoft Fixit Tool here:

http://support.microsoft.com/kb/306759

Author

Commented:
My IT dept was able to get it working.  Not sure what they did.

But I believe these all to be legitimate suggestions for others should this problem occur and therefore rewarding points.

Thanks again.

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial