Link to home
Start Free TrialLog in
Avatar of Zuzan329
Zuzan329Flag for United States of America

asked on

sql variable issue when selecting in ('&')

Hello I am useind Toad for oracle and can not get past this variable pop up when selecting specific  files with '&' in them.
example:
Where C.CLTR in ('SS&G')
Can anyone help.
Avatar of smilitaru
smilitaru
Flag of Romania image

just run this before your statement
set scan off;
or you could use:
Where C.CLTR in ('SS\&%’ ESCAPE ‘\G')
Avatar of Zuzan329

ASKER

Thank you... tried both neither worked.
Susan
try by this

Where C.CLTR in ('SSamp;G')


Html encoding of & is amp;

when it goes to heml it will automatically decode it as &
Sorry that did not work either.... it should give me 16 accounts but it gave me 0
Avatar of David VanZandt
There's probably some setting for this, but I've little success in having my SET commands recognized in TOAD.  I would ask, therefore, that you go into an old-fashioned SQL*Plus session, devoid of any GUI layering, and try your statement with smilitaru's answer.  If that doesn't work as advertised, reply and post your statement here.
ASKER CERTIFIED SOLUTION
Avatar of keyu
keyu
Flag of India image

Link to home
membership
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial
Thank you this finally worked