MS EXCHANGE to Google Apps (gmail) internal routing problem

Dale Massicotte
Dale Massicotte used Ask the Experts™
on
i wish to have GOOGLE APPS handle company email instead of my MSEXCHANGE server.

We are running SBS2003 with MS Exchange on the server.

All the email is now being directed to google except:

Incoming faxes - was being routed to an internal distribution group

Internal email - sent from one client with outlook to another within the company

This seems to be an internal vs external dns issue on the server.

Do i need to somehow disable internal dns on the server so that all email goes through google?  How can I accomplish this?
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Sounds like you'll have to elaborate on your fax setup first.

Commented:
You will have to uninstall the internal exchange server and move everyone to Google Sync and local PST.  The SBS will always point the outlooks to the internal server and also change the Exchange account to the default via GPO.  Then you will have to dump all the nk2 files (the cached email addresses that pop up as people type) as they will in some cases point to the AD addresses instead of the actual person@domain.com address.

There are a few articles on how to change GPO to stop pushing these items, but found the one to prevent the Exchange being the default to not work for me, and in the end, uninstalling was the only way.  

If you disable internal DNS, you will break other AD aspects such as security, scripts, and joining the domain with a new computer.  If you still insist on it, another way you can do is to change the DHCP server information to spit out your router as the dns instead of the SBS machine, or you can turn off the DHCP function entirely on the server and turn it on the router.  Though as a side note, you will lose a lot more functionality than you think, and I wouldn't recommend it.
Dale MassicottePresident

Author

Commented:
Fax set up has faxes being routed through email, specifically what was formally an internal distribution group.

A same distribution group with the same exact name was set up in GOOGLE APPS, and the distribution group was removed from my distribution groups on exchange server.

Still the faxes will not route to the newly formed google distribution group.
Success in ‘20 With a Profitable Pricing Strategy

Do you wonder if your IT business is truly profitable or if you should raise your prices? Learn how to calculate your overhead burden using our free interactive tool and use it to determine the right price for your IT services. Start calculating Now!

Commented:
sorry, forgot the articles on how to stop certain SBS functions
stop exchagne from being default account to send from
http://sbs.seandaniel.com/2004/10/having-trouble-trusting-exchange-from.html

And if you were using the fax distribution on the SBS to receive on an internal modem, that won't work without everyone connected to exchange.

Also, SBS starts acting strange when you disable certain aspects, wizards, reports, can stop working.
Dale MassicottePresident

Author

Commented:
tsaico I just remembered that I will not be able to fully uninstall exchange.  i need the SMTP server to send email from an application - or maybe that could be routed though google somehow with coding.
Dale MassicottePresident

Author

Commented:
"And if you were using the fax distribution on the SBS to receive on an internal modem, that won't work without everyone connected to exchange."

Not true I dont think

I am able to route the faxes though a personal email so I should be able to route them through google as long as exchange doesn't intercept and attempt to route internally
Dale MassicottePresident

Author

Commented:
This tweek solved my fax problem

"You need to configure the Fax server to use Google Apps SMTP. Right click on My Computer and choose Manage. Then go to Services and Applications and right click on Fax and choose Properties. On the Receipts tab make sure "Enable SMTP e-mail receipts delivery" is checked. Assuming you only send fax receipts to users in your domain set the Server Address to be aspmx.l.google.com, authentication is not necessary."

from
http://productforums.google.com/forum/#!topic/apps/W_t2UI_Xgkw
Commented:
Ok, I would still recommend giving the article link a shot, just so SBS doesn't hijack your users.

Then perhaps you can put the distribution group back, and have your google apps account check it via old fashioned pop, and then make a filter in gmail to then send it to the distribution group.  Not ideal, but might work for you.

What I meant was if Exchange is gone, the fax distribution does work because nothing to email with.  Perhaps still uninstall/disable, then use a separate SMTP for the application like the built in one and managed by IIS?
http://www.windowsitpro.com/article/smtp/how-can-i-install-the-smtp-service-under-windows-server-2003-

I also don't recall, but can you have Google Sync account with an Exchange account?  Then you could just leave the exchange in place, have it handle all your internal emails, (user@domain.local) and Google Apps account for external people emailing your domain.

Edit: actually that would be bad, since your email trail will now be in two places making more work for you...
Dale MassicottePresident

Author

Commented:
Yes there is GOOGLE SYNC that works with Outlook and is supposed to bypass exchange server.

I have not yet installed it but that is my next step for today.

I want to see if that works before tinkering with any more exchange settings.

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial